LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 11-16-2005, 09:19 PM   #1
rich_montana
LQ Newbie
 
Registered: Oct 2005
Distribution: Suse 10.0
Posts: 14

Rep: Reputation: 0
error running eclipse


hello i have little linux knowledge and especially when it comes to makin work right. anyway here is my problem. i had eclipse running perfectly on my linux machine (suse10.0) and had it installed to using Yast. i then changed the java version from 1.4.2 to 1.5. then it didnt work. by that i mean i would try to run eclipse and it wouldnt open and i had the following error:

An error has occurred. See the log file
/home/rich/.eclipse/.metadata/.log

i figured it was just because i had changed the version of java. so i removed eclipse using yast then reinstalled it in hopes that it would do whatever it needed to do to resolve that problem, but this was no help still got the same error. here is the log file would someone please please help me!!!

also the $JAVA_HOME is to the corrected java 1.5 folder
and note the java version on the third line!!!

thank you rich

***************************************************************
/home/rich/.eclipse/.metadata/.log:
***************************************************************

!SESSION 2005-10-20 13:55:21.188 -----------------------------------------------
eclipse.buildId=I20050627-1435
java.version=1.4.2_06
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
Command-line arguments: -os linux -ws gtk -arch x86 -data /home/rich/.eclipse

!ENTRY org.eclipse.core.resources 1 1 2005-10-20 13:57:50.697
!MESSAGE Could not load library: libcore_3_1_0.so. This library provides platform-specific optimizations for certain file system operations. This library is not present on all platforms, so this may not be an error. The resources plug-in will safely fall back to using java.io.File functionality.
!SESSION 2005-10-20 19:08:30.756 -----------------------------------------------
eclipse.buildId=I20050627-1435
java.version=1.4.2_09
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
Command-line arguments: -os linux -ws gtk -arch x86 -data /home/rich/.eclipse

!ENTRY org.eclipse.core.resources 1 1 2005-10-20 19:08:38.40
!MESSAGE Could not load library: libcore_3_1_0.so. This library provides platform-specific optimizations for certain file system operations. This library is not present on all platforms, so this may not be an error. The resources plug-in will safely fall back to using java.io.File functionality.
!SESSION 2005-11-08 20:17:16.237 -----------------------------------------------
eclipse.buildId=I20050627-1435
java.version=1.4.2_06
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
Command-line arguments: -os linux -ws gtk -arch x86 -data /home/rich/.eclipse

!ENTRY org.eclipse.core.resources 1 1 2005-11-08 20:17:23.523
!MESSAGE Could not load library: libcore_3_1_0.so. This library provides platform-specific optimizations for certain file system operations. This library is not present on all platforms, so this may not be an error. The resources plug-in will safely fall back to using java.io.File functionality.
!SESSION 2005-11-15 19:54:53.616 -----------------------------------------------
eclipse.buildId=I20050627-1435
java.version=1.4.2_06
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
Command-line arguments: -os linux -ws gtk -arch x86 -data /home/rich/.eclipse
!ENTRY org.eclipse.core.resources 1 1 2005-11-15 19:55:00.361
!MESSAGE Could not load library: libcore_3_1_0.so. This library provides platform-specific optimizations for certain file system operations. This library is not present on all platforms, so this may not be an error. The resources plug-in will safely fall back to using java.io.File functionality.

!ENTRY org.eclipse.ui 4 4 2005-11-15 19:55:27.795
!MESSAGE Unhandled event loop exception

!ENTRY org.eclipse.ui 4 0 2005-11-15 19:55:27.796
!MESSAGE Failed to execute runnable (java.lang.NullPointerException)
!STACK 0
org.eclipse.swt.SWTException: Failed to execute runnable (java.lang.NullPointerException)
at org.eclipse.swt.SWT.error(SWT.java:2942)
at org.eclipse.swt.SWT.error(SWT.java:2865)
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:126)
at org.eclipse.swt.widgets.Display.runAsyncMessages(Display.java:2844)
at org.eclipse.swt.widgets.Display.readAndDispatch(Display.java:2575)
at org.eclipse.ui.internal.Workbench.runEventLoop(Workbench.java:1699)
at org.eclipse.ui.internal.Workbench.runUI(Workbench.java:1663)
at org.eclipse.ui.internal.Workbench.createAndRunWorkbench(Workbench.java:367)
at org.eclipse.ui.PlatformUI.createAndRunWorkbench(PlatformUI.java:143)
at org.eclipse.ui.internal.ide.IDEApplication.run(IDEApplication.java:103)
at org.eclipse.core.internal.runtime.PlatformActivator$1.run(PlatformActivator.java:226)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:376)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:163)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
at java.lang.reflect.Method.invoke(Method.java:324)
at org.eclipse.core.launcher.Main.invokeFramework(Main.java:334)
at org.eclipse.core.launcher.Main.basicRun(Main.java:278)
at org.eclipse.core.launcher.Main.run(Main.java:973)
org.eclipse.core.launcher.Main.main(Main.java:948)
Caused by: java.lang.NullPointerException
at org.eclipse.jdt.internal.ui.text.javadoc.JavaDocCompletionEvaluator.computeCompletionProposals(JavaD ocCompletionEvaluator.java:176)
at org.eclipse.jdt.internal.ui.text.javadoc.JavaDocCompletionProcessor.computeCompletionProposals(JavaD ocCompletionProcessor.java:200)
at org.eclipse.jface.text.contentassist.ContentAssistant.computeCompletionProposals(ContentAssistant.ja va:1503)
at org.eclipse.jface.text.contentassist.CompletionProposalPopup.computeProposals(CompletionProposalPopu p.java:261)
at org.eclipse.jface.text.contentassist.CompletionProposalPopup.access$7(CompletionProposalPopup.java:2 58)
at org.eclipse.jface.text.contentassist.CompletionProposalPopup$1.run(CompletionProposalPopup.java:221)
at org.eclipse.swt.custom.BusyIndicator.showWhile(BusyIndicator.java:69)
at org.eclipse.jface.text.contentassist.CompletionProposalPopup.showProposals(CompletionProposalPopup.j ava:216)
at org.eclipse.jface.text.contentassist.ContentAssistant$2.run(ContentAssistant.java:327)
at org.eclipse.swt.widgets.RunnableLock.run(RunnableLock.java:35)
at org.eclipse.swt.widgets.Synchronizer.runAsyncMessages(Synchronizer.java:123)
... 18 more
!SESSION 2005-11-16 11:14:39.39 ------------------------------------------------
eclipse.buildId=I20050627-1435
java.version=1.4.2_06
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
Command-line arguments: -os linux -ws gtk -arch x86 -data /home/rich/.eclipse

!ENTRY org.eclipse.core.resources 1 1 2005-11-16 11:14:45.651
!MESSAGE Could not load library: libcore_3_1_0.so. This library provides platform-specific optimizations for certain file system operations. This library is not present on all platforms, so this may not be an error. The resources plug-in will safely fall back to using java.io.File functionality.
!SESSION 2005-11-16 17:21:46.247 -----------------------------------------------
eclipse.buildId=I20050627-1435
java.version=1.5.0_03
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=linux, ARCH=x86, WS=gtk, NL=en_US
Command-line arguments: -os linux -ws gtk -arch x86 -data /home/rich/.eclipse


....and from there it seems to go on forever... if anyone could help that would be awesome too if you think that the rest of the log would be more usefull i will repost but this was like only 10% of it or something, so
anyway thanks
rich
 
Old 11-18-2005, 04:04 AM   #2
MassDosage
Member
 
Registered: Aug 2005
Location: London, UK
Distribution: Kubuntu
Posts: 75

Rep: Reputation: 15
Strange that it seems to be using the old JDK even though you say you have updated your $JAVA_HOME environment variable to point to the 1.5 JDK. Are you starting eclipse using some sort of shortcut/menu option? What happens if you start it "manually" from a shell where you can echo out the value of JAVA_HOME to be sure it is correct. Another idea might be to try remove the YAST-installed version of eclipse and get it directly from eclipse.org and try that...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
running tomcat with eclipse as non-root javcerty Linux - Newbie 4 04-16-2009 01:09 PM
Problem running Eclipse with gij lvella Linux - Software 2 05-11-2005 04:30 PM
Problem's running eclipse UmneyDurak Linux - Software 2 09-01-2004 10:29 PM
error running eclipse with stock jvm! c24chan Slackware 2 05-09-2004 04:39 AM
problem running Eclipse 2.1 on mandrake 9.2 nurien Linux - Software 3 01-08-2004 05:30 AM


All times are GMT -5. The time now is 09:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration