LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   error occured when installing wine-1.1.9 (http://www.linuxquestions.org/questions/linux-software-2/error-occured-when-installing-wine-1-1-9-a-688217/)

cricketlong 12-04-2008 02:22 AM

error occured when installing wine-1.1.9
 
The following error occur when I used command "sudo ./configure" in Ubuntu:
checking build system type... i686-pc-linux-gnulibc1
checking host system type... i686-pc-linux-gnulibc1
checking whether make sets $(MAKE)... yes
checking for gcc... gcc
checking for C compiler default output file name...
configure: error: in `/home/cricket/myfiles/wine-1.1.9':
configure: error: C compiler cannot create executables
See `config.log' for more details.

******************************************
Then I view config.log for further info and found:
74 configure:2828: $? = 1
75 configure:2866: result:
76 configure: failed program was:
77 | /* confdefs.h. */
78 | #define PACKAGE_NAME "Wine"
79 | #define PACKAGE_TARNAME "wine"
80 | #define PACKAGE_VERSION "1.1.9"
81 | #define PACKAGE_STRING "Wine 1.1.9"
82 | #define PACKAGE_BUGREPORT "wine-devel@winehq.org"
83 | /* end confdefs.h. */
84 |
85 | int
86 | main ()
87 | {
88 |
89 | ;
90 | return 0;
91 | }
92 configure:2872: error: in `/home/cricket/myfiles/wine-1.1.9':
93 configure:2875: error: C compiler cannot create executables
94 See `config.log' for more details.

***************************************************
but I can not find the file named 'confdefs.h'
Had any one ever met this error?

Any help would be appreciated.

reddazz 12-04-2008 02:40 AM

You are probably missing some development packages. Go to Applications -> Accessories -> Terminal and enter
Code:

sudo apt-get install build-essential

cricketlong 12-07-2008 07:51 AM

enter:
sudo apt-get install build-essential
then:
The following packages have unmet dependencies:
build-essential: Depends: libc6-dev but it is not going to be installed or
libc-dev
Depends: g++ (>= 4:4.1.1) but it is not going to be installed
Depends: dpkg-dev (>= 1.13.5) but it is not going to be installed

if I enter "sudo apt-get install <one of the items above>", more Depends would be shown,and "*** is already the newest version."

being annoyed.

reddazz 12-07-2008 11:51 AM

Try
Code:

sudo apt-get update
sudo apt-get install build-essential



All times are GMT -5. The time now is 05:33 AM.