LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 06-17-2010, 09:15 AM   #1
abdullah12
LQ Newbie
 
Registered: Jun 2010
Posts: 3

Rep: Reputation: 0
error message after partial upgrade on ubuntu 10.04


Hi all,

when running Synaptic manager I get this message:
Code:
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem. 
E: _cache->open() failed, please report.
As I run the dpkg in the terminal I get this message:

Code:
You have 1 broken package on your sytem!
Use the "Broken" filter to locate it
Returning back to the Synaptic manager And when I try to upgrade that package it will hang with the following text displayed

preconfiguring packages ...
(reading database ... 199488 files and directories currently installed.)
preparing to replace mysql-server-5.1 5.1.41-3ubuntu12.1 (using .../mysql-server-5.1_5.1.41-3ubuntu12.3_i386.deb) ...

please help
 
Old 06-17-2010, 10:33 AM   #2
yooy
Senior Member
 
Registered: Dec 2009
Posts: 1,107

Rep: Reputation: 127Reputation: 127
here is some older thread on broken packages that may help

why would you update in synaptic, maybe you should try to remove it.
 
Old 06-17-2010, 11:47 AM   #3
abdullah12
LQ Newbie
 
Registered: Jun 2010
Posts: 3

Original Poster
Rep: Reputation: 0
Thanks yooy,

Since I did the partial upgrade no further update to my system is posseble nor any installation of any software is posseble.

And what I did basically was use search engines to try to resolve any issue I encounter by posting the error messages I got in search engines. I end up running in circle trying to resolve the problem.

If I try to install for example ftop using

sudo apt-get install ftop

It will end up to the same result hanging trying to replace mysql server

here is some code:

Code:
abdullah@virtual-desktop:~$ sudo aptitude install ftop
[sudo] password for abdullah: 
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem. 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Reading extended state information      
Initializing package states... Done
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
Code:
abdullah@virtual-desktop:~$ sudo dpkg --configure -a
dpkg: error processing openoffice.org-emailmerge (--configure):
 Package is in a very bad inconsistent state - you should
 reinstall it before attempting configuration.
dpkg: error processing mysql-server-5.1 (--configure):
 Package is in a very bad inconsistent state - you should
 reinstall it before attempting configuration.
Errors were encountered while processing:
 openoffice.org-emailmerge
 mysql-server-5.1
and this if i try to install mysql

Code:
abdullah@virtual-desktop:~$ sudo aptitude install mysql
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Reading extended state information      
Initializing package states... Done
Couldn't find package "mysql", and more than 40
packages contain "mysql" in their name.
Couldn't find package "mysql", and more than 40
packages contain "mysql" in their name.
The following packages are BROKEN:
  ure 
The following packages will be REMOVED:
  libaio1{u} libxml++2.6-2{u} libxvidcore4{u} qemu-common{u} seabios{u} vgabios{u} 
0 packages upgraded, 0 newly installed, 6 to remove and 84 not upgraded.
Need to get 0B of archives. After unpacking 1,720kB will be freed.
The following packages have unmet dependencies:
  ure: Depends: uno-libs3 (= 1.6.0+OOo3.2.0-7ubuntu4) but 1.6.0+OOo3.2.0-7ubuntu4.1 is installed.
E: I wasn't able to locate file for the mysql-server-5.1 package. This might mean you need to manually fix this package.
The following actions will resolve these dependencies:

Upgrade the following packages:
ure [1.6.0+OOo3.2.0-7ubuntu4 (lucid, now) -> 1.6.0+OOo3.2.0-7ubuntu4.1 (lucid-updates,
lucid-security)]

Score is 120

Accept this solution? [Y/n/q/?] y
The following packages will be REMOVED:
  libaio1{u} libxml++2.6-2{u} libxvidcore4{u} qemu-common{u} seabios{u} vgabios{u} 
The following packages will be upgraded:
  ure 
1 packages upgraded, 0 newly installed, 6 to remove and 83 not upgraded.
Need to get 0B of archives. After unpacking 1,720kB will be freed.
Do you want to continue? [Y/n/?] y
E: I wasn't able to locate file for the mysql-server-5.1 package. This might mean you need to manually fix this package.
Writing extended state information... Done
E: I wasn't able to locate file for the mysql-server-5.1 package. This might mean you need to manually fix this package.
E: Internal error: couldn't generate list of packages to download
abdullah@virtual-desktop:~$ sudo aptitude install ftop
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Reading extended state information      
Initializing package states... Done
Couldn't find package "ftop".  However, the following
packages contain "ftop" in their name:
  iftop iftop-dbg 
Couldn't find package "ftop".  However, the following
packages contain "ftop" in their name:
  iftop iftop-dbg 
The following packages are BROKEN:
  ure 
The following packages will be REMOVED:
  libaio1{u} libxml++2.6-2{u} libxvidcore4{u} qemu-common{u} seabios{u} vgabios{u} 
0 packages upgraded, 0 newly installed, 6 to remove and 84 not upgraded.
Need to get 0B of archives. After unpacking 1,720kB will be freed.
The following packages have unmet dependencies:
  ure: Depends: uno-libs3 (= 1.6.0+OOo3.2.0-7ubuntu4) but 1.6.0+OOo3.2.0-7ubuntu4.1 is installed.
E: I wasn't able to locate file for the mysql-server-5.1 package. This might mean you need to manually fix this package.
The following actions will resolve these dependencies:

Upgrade the following packages:
ure [1.6.0+OOo3.2.0-7ubuntu4 (lucid, now) -> 1.6.0+OOo3.2.0-7ubuntu4.1 (lucid-updates,
lucid-security)]

Score is 120

Accept this solution? [Y/n/q/?] y
The following packages will be REMOVED:
  libaio1{u} libxml++2.6-2{u} libxvidcore4{u} qemu-common{u} seabios{u} vgabios{u} 
The following packages will be upgraded:
  ure 
1 packages upgraded, 0 newly installed, 6 to remove and 83 not upgraded.
Need to get 0B of archives. After unpacking 1,720kB will be freed.
Do you want to continue? [Y/n/?] y
E: I wasn't able to locate file for the mysql-server-5.1 package. This might mean you need to manually fix this package.
Writing extended state information... Done
E: I wasn't able to locate file for the mysql-server-5.1 package. This might mean you need to manually fix this package.
E: Internal error: couldn't generate list of packages to download
abdullah@virtual-desktop:~$ apt-get install -f
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
abdullah@virtual-desktop:~$ sudo apt-get install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  libxvidcore4 libaio1 seabios vgabios libxml++2.6-2 qemu-common
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  mysql-server-5.1 ure
Suggested packages:
  tinyca mailx cli-uno-bridge
The following packages will be upgraded:
  mysql-server-5.1 ure
2 upgraded, 0 newly installed, 0 to remove and 82 not upgraded.
2 not fully installed or removed.
Need to get 10.4kB/8,239kB of archives.
After this operation, 0B of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://archive.ubuntu.com/ubuntu/ lucid/main openoffice.org-emailmerge 1:3.2.0-7ubuntu4 [10.4kB]
Fetched 10.4kB in 5s (1,774B/s)                    
Preconfiguring packages ...
(Reading database ... 199488 files and directories currently installed.)
Preparing to replace mysql-server-5.1 5.1.41-3ubuntu12.1 (using .../mysql-server-5.1_5.1.41-3ubuntu12.3_i386.deb) ...
 
Old 06-17-2010, 12:24 PM   #4
abdullah12
LQ Newbie
 
Registered: Jun 2010
Posts: 3

Original Poster
Rep: Reputation: 0
apt-get is not working too

Thanks yooy,

Since I did the partial upgrade no further update to my system is posseble nor any installation of any software is posseble.

And what I did basically was use search engines to try to resolve any issue I encounter by posting the error messages I got in search engines. I end up running in circle trying to resolve the problem.

If I try to install for example ftop using

sudo apt-get install ftop

It will end up to the same result hanging trying to replace mysql server

here is some code:

Code:
abdullah@virtual-desktop:~$ sudo aptitude install ftop
[sudo] password for abdullah: 
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem. 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Reading extended state information      
Initializing package states... Done
E: dpkg was interrupted, you must manually run 'sudo dpkg --configure -a' to correct the problem.
Code:
abdullah@virtual-desktop:~$ sudo dpkg --configure -a
dpkg: error processing openoffice.org-emailmerge (--configure):
 Package is in a very bad inconsistent state - you should
 reinstall it before attempting configuration.
dpkg: error processing mysql-server-5.1 (--configure):
 Package is in a very bad inconsistent state - you should
 reinstall it before attempting configuration.
Errors were encountered while processing:
 openoffice.org-emailmerge
 mysql-server-5.1
and this if i try to install mysql

Code:
abdullah@virtual-desktop:~$ sudo aptitude install mysql
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Reading extended state information      
Initializing package states... Done
Couldn't find package "mysql", and more than 40
packages contain "mysql" in their name.
Couldn't find package "mysql", and more than 40
packages contain "mysql" in their name.
The following packages are BROKEN:
  ure 
The following packages will be REMOVED:
  libaio1{u} libxml++2.6-2{u} libxvidcore4{u} qemu-common{u} seabios{u} vgabios{u} 
0 packages upgraded, 0 newly installed, 6 to remove and 84 not upgraded.
Need to get 0B of archives. After unpacking 1,720kB will be freed.
The following packages have unmet dependencies:
  ure: Depends: uno-libs3 (= 1.6.0+OOo3.2.0-7ubuntu4) but 1.6.0+OOo3.2.0-7ubuntu4.1 is installed.
E: I wasn't able to locate file for the mysql-server-5.1 package. This might mean you need to manually fix this package.
The following actions will resolve these dependencies:

Upgrade the following packages:
ure [1.6.0+OOo3.2.0-7ubuntu4 (lucid, now) -> 1.6.0+OOo3.2.0-7ubuntu4.1 (lucid-updates,
lucid-security)]

Score is 120

Accept this solution? [Y/n/q/?] y
The following packages will be REMOVED:
  libaio1{u} libxml++2.6-2{u} libxvidcore4{u} qemu-common{u} seabios{u} vgabios{u} 
The following packages will be upgraded:
  ure 
1 packages upgraded, 0 newly installed, 6 to remove and 83 not upgraded.
Need to get 0B of archives. After unpacking 1,720kB will be freed.
Do you want to continue? [Y/n/?] y
E: I wasn't able to locate file for the mysql-server-5.1 package. This might mean you need to manually fix this package.
Writing extended state information... Done
E: I wasn't able to locate file for the mysql-server-5.1 package. This might mean you need to manually fix this package.
E: Internal error: couldn't generate list of packages to download
abdullah@virtual-desktop:~$ sudo aptitude install ftop
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Reading extended state information      
Initializing package states... Done
Couldn't find package "ftop".  However, the following
packages contain "ftop" in their name:
  iftop iftop-dbg 
Couldn't find package "ftop".  However, the following
packages contain "ftop" in their name:
  iftop iftop-dbg 
The following packages are BROKEN:
  ure 
The following packages will be REMOVED:
  libaio1{u} libxml++2.6-2{u} libxvidcore4{u} qemu-common{u} seabios{u} vgabios{u} 
0 packages upgraded, 0 newly installed, 6 to remove and 84 not upgraded.
Need to get 0B of archives. After unpacking 1,720kB will be freed.
The following packages have unmet dependencies:
  ure: Depends: uno-libs3 (= 1.6.0+OOo3.2.0-7ubuntu4) but 1.6.0+OOo3.2.0-7ubuntu4.1 is installed.
E: I wasn't able to locate file for the mysql-server-5.1 package. This might mean you need to manually fix this package.
The following actions will resolve these dependencies:

Upgrade the following packages:
ure [1.6.0+OOo3.2.0-7ubuntu4 (lucid, now) -> 1.6.0+OOo3.2.0-7ubuntu4.1 (lucid-updates,
lucid-security)]

Score is 120

Accept this solution? [Y/n/q/?] y
The following packages will be REMOVED:
  libaio1{u} libxml++2.6-2{u} libxvidcore4{u} qemu-common{u} seabios{u} vgabios{u} 
The following packages will be upgraded:
  ure 
1 packages upgraded, 0 newly installed, 6 to remove and 83 not upgraded.
Need to get 0B of archives. After unpacking 1,720kB will be freed.
Do you want to continue? [Y/n/?] y
E: I wasn't able to locate file for the mysql-server-5.1 package. This might mean you need to manually fix this package.
Writing extended state information... Done
E: I wasn't able to locate file for the mysql-server-5.1 package. This might mean you need to manually fix this package.
E: Internal error: couldn't generate list of packages to download
abdullah@virtual-desktop:~$ apt-get install -f
E: Could not open lock file /var/lib/dpkg/lock - open (13: Permission denied)
E: Unable to lock the administration directory (/var/lib/dpkg/), are you root?
abdullah@virtual-desktop:~$ sudo apt-get install -f
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  libxvidcore4 libaio1 seabios vgabios libxml++2.6-2 qemu-common
Use 'apt-get autoremove' to remove them.
The following extra packages will be installed:
  mysql-server-5.1 ure
Suggested packages:
  tinyca mailx cli-uno-bridge
The following packages will be upgraded:
  mysql-server-5.1 ure
2 upgraded, 0 newly installed, 0 to remove and 82 not upgraded.
2 not fully installed or removed.
Need to get 10.4kB/8,239kB of archives.
After this operation, 0B of additional disk space will be used.
Do you want to continue [Y/n]? y
Get:1 http://archive.ubuntu.com/ubuntu/ lucid/main openoffice.org-emailmerge 1:3.2.0-7ubuntu4 [10.4kB]
Fetched 10.4kB in 5s (1,774B/s)                    
Preconfiguring packages ...
(Reading database ... 199488 files and directories currently installed.)
Preparing to replace mysql-server-5.1 5.1.41-3ubuntu12.1 (using .../mysql-server-5.1_5.1.41-3ubuntu12.3_i386.deb) ...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Froze In Middle of Upgrade With Error Message. Randymanme Linux - Newbie 2 08-22-2009 08:51 AM
Partial upgrade of KDE 3.5 to 4.2 (grrrrr) in Squeeze jdkaye Debian 2 05-18-2009 07:13 AM
Error Message When attempting upgrade to 8.04 lts ericbrown56 Linux - Newbie 5 01-13-2009 06:52 AM
Partial System Breaks Down after upgrade to v10.1 Manuel-H Slackware 1 03-09-2005 05:32 PM
Partial upgrade with APT pinning (debian)? MaulingMonkey Linux - Software 1 01-21-2005 06:11 AM


All times are GMT -5. The time now is 12:41 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration