LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Error in installing Lidia -2.3.0 in Ubuntu 11.04. show error in precondition_error.cc (http://www.linuxquestions.org/questions/linux-software-2/error-in-installing-lidia-2-3-0-in-ubuntu-11-04-show-error-in-precondition_error-cc-918723/)

Anamika Paul 12-14-2011 11:30 AM

Error in installing Lidia -2.3.0 in Ubuntu 11.04. show error in precondition_error.cc
 
I am trying to install Lidia-2.3.0.When a write make command after configuring the software it shows some error.It is given below.
error: prototype for
‘LiDIA::precondition_error::precondition_error(const int&)’ does not match any in class ‘LiDIA::precondition_error’
/src/base/include/LiDIA/precondition_error.h:44:5: error: candidates are: LiDIA::precondition_error::precondition_error(const LiDIA::precondition_error&)
LiDIA::precondition_error::precondition_error(const std::string&, const std::string&, const std::string&)
/src/base/system/precondition_error.cc:64:3: error: ‘LiDIA::precondition_error::precondition_error’ names the constructor, not the type


Will u please help me?

knudfl 12-14-2011 05:28 PM

Welcome to LQ.

Please install the package 'g++-4.4' with your preferred Package Manager.

Then the install procedure is : cd lidia-2.3.0/ &&
export CC=gcc-4.4 CXX=g++-4.4 && ./configure && make && sudo make install

Be aware that the export command is temporary :
gcc / g++ will reset to the default version = 4.6.1,
when you exit the terminal.

..

Anamika Paul 12-14-2011 10:08 PM

Error at configure!!
export CC=gcc-4.4 CXX=g++-4.4 is not working


configure: error: C compiler cannot create executables
See `config.log' for more details.


please help me!!!

---------- Post added 12-15-11 at 10:08 AM ----------

Error at configure!!
export CC=gcc-4.4 CXX=g++-4.4 is not working


configure: error: C compiler cannot create executables
See `config.log' for more details.


please help me!!!

knudfl 12-15-2011 07:19 AM

OK, Please try this :
sudo apt-get update && sudo apt-get install g++ g++-4.4


I got no errors with Lidia yesterday : Ubuntu 11.10, 32 bits.
The 64bits Ubuntu 11.10 may behave different. Which is yours ? ?

..

Anamika Paul 12-15-2011 09:07 AM

I have already uninstalled g++-4.5 because my friend's ubuntu have only g++-4.4 & i installed lidia successfully in his laptop.
But after uninstalling g++-4.5 a configure error
checking for g++... no
checking for c++... no
checking for gpp... gpp
checking whether we are using the GNU C++ compiler... no
checking whether gpp accepts -g... no
checking dependency style of gpp... none

Now i am trying to install g++ but
it shows Package dependencies cannot be resolved
g++: Depends: cpp (>= 4:4.5.1-1ubuntu3) but 4:4.5.2-1ubuntu3 is to be installed
Depends: gcc (>= 4:4.5.1-1ubuntu3) but 4:4.5.2-1ubuntu3 is to be installed

but cpp & gcc are both already installed..

Anamika Paul 12-15-2011 09:09 AM

I use ubuntu 11.04.
Now i am very upset with all this problems .
please help me!

knudfl 12-15-2011 01:00 PM

Sorry, Ubuntu 11.04 then.

You are right, the Ubuntu 11.04 "g++-4.4" cannot be used
with the latest updates.

Luckily a special "g++42-compat" for Ubuntu 11.04 does OK :
sudo dpkg -i gcc42-compat-4.2.4_i386.deb g++42-compat-4.2.4_i386.deb

gcc42-compat https://docs.google.com/open?id=0B7S...VlMjk4OTI5NGVk

g++42-compat https://docs.google.com/open?id=0B7S...FlODA4YWFiMTcx

Then please reboot, and the new gcc42, g++42 will work.

The build command will now be :
export CXX=g++42 && ./configure && make && sudo make install


P.S. : You can have as many gcc/g++ versions as you want,
installed at the same time. So please reinstall g++, if you can.

P.P.S. : Other 11.04 "compats" are gcc34/g++34 and gcc41/g++41.


Remarks about Ubuntu 11.04 :
Do not expect all special software to compile.
And : Ubuntu 11.10 is even worse.

..

Anamika Paul 01-15-2012 03:27 AM

I have installed Ubuntu 11.10 again and installed Lidia successfully.Thanks for your help.

Anamika Paul 05-16-2012 11:27 PM

Again facing problem in installing lidia in ubuntu 11.10.
After reinstalling ubuntu 11.10 when configuring Lidia---------

"checking for pdflatex... pdflatex
checking for texi2dvi... no
checking for texi2dvi4a2ps... no
checking for gunzip... gunzip
checking for bunzip2... bunzip2
configure: checking which multi-precision arithmetic library to use
checking for GNU MP (version >= 3.1)... no
checking for CLN... no
checking for Piologie... no
checking for libI... no
configure: error: could not find a multi-precision integer arithmetic.
"
i dont find anything called Libi, CLN,GNU MP in ubuntu software center. please help me, why error?

knudfl 05-23-2012 05:24 AM

Quote:

checking for GNU MP (version >= 3.1)... no
Required : gmp version 3.1 or later.

sudo apt-get install libgmp-dev


All times are GMT -5. The time now is 07:24 AM.