LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 05-01-2012, 11:09 AM   #1
Infotechie
LQ Newbie
 
Registered: Apr 2012
Posts: 3

Rep: Reputation: Disabled
Exclamation error in building rpm of open ldap from source using rpm package manager


Hi,

I am trying to build rpm through source of Openldap_2.4.30 version but getting below build error:

/bin/sh ../../libtool --mode=install ../../build/shtool install -c -m 644 libldap.la /usr/local/openldap-2.4.31-root/usr/lib
libtool: install: error: cannot install 'libldap.la' to a directory not ending in usr/local/lib

I have searched a lot on google to find the solution of this problem. Most of the articles say to run make clean after configure. But it did not work.
Some threads say that this is a known bug in libldap library and it is unresolved. But in previous versions it is running.

Please provide your valuable suggestions. Is it a known bug? If yes, how can I avoid this problem?
 
Old 05-01-2012, 06:33 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 22,978
Blog Entries: 11

Rep: Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879Reputation: 879
Help us in helping you ...

What distro are you on?

Which rpm build are you using? I find it odd that it would complain about /usr/local, as
that's NOT the default path for any rpm based distro I know of.


Cheers,
Tink


P.S.: What happened to your abandoned thread that's marked as solved?
 
Old 05-02-2012, 01:10 AM   #3
Infotechie
LQ Newbie
 
Registered: Apr 2012
Posts: 3

Original Poster
Rep: Reputation: Disabled
distro is Red Hat Linux Server release 5.3 (Tikanga)
rpm build: RPM version 4.4.2.3

About Abandoned Thread: By using debugging options I have traced the problem.
 
  


Reply

Tags
openldap, redhat, rpm, rpmbuild


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Questions regarding building Rpm package. mathnitin Linux - Newbie 1 09-30-2011 03:53 PM
Problem facing in building rpm package from source codes Arighna Programming 3 08-19-2011 12:50 PM
RPM Package building harish.patel Linux - Newbie 2 12-25-2008 11:57 PM
Install RPM with YAST Software / Package Manager ERROR! Balarabay1 Suse/Novell 5 07-10-2006 03:34 PM
Building own RPM package hems Linux - Newbie 1 11-28-2002 03:16 AM


All times are GMT -5. The time now is 09:14 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration