LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 04-30-2004, 03:10 AM   #1
lynsue
LQ Newbie
 
Registered: Apr 2004
Posts: 2

Rep: Reputation: 0
Unhappy Error: failed dependencies installing php-4.3.5 on redhat linux 9


Trying to install php-4.3.5.rpm on Redhat Linux 9 and I am recieving the following error message:

error: Failed dependencies:

httpd-mmn = 20020903 is needed by php-4.3.5-2
libaspell.so.15 is needed by php-4.3.5-2
libdb-4.1.so is needed by php-4.3.5-2
libpdf.so.1 is needed by php-4.3.5-2
libpspell.so.15 is needed by php-4.3.5-2

I have searched for the above dependencies but can not find them to download (php 4.3.5 rpm and the above packages are not on the redhat site). I am currently using apache version 2.0.40

Can anyone help?
 
Old 04-30-2004, 04:12 AM   #2
coolamit78
Member
 
Registered: Aug 2003
Location: New Delhi, India
Distribution: RHEL AS 3/4, Windows XP
Posts: 546

Rep: Reputation: 31
I think you will need to install 'httpd-devel' package and 'aspell' package. They would be there on one of the three Red Hat Cds...Install these two rpms and then again try to install php...

--amit
 
Old 04-30-2004, 04:37 AM   #3
lynsue
LQ Newbie
 
Registered: Apr 2004
Posts: 2

Original Poster
Rep: Reputation: 0
I have installed httpd-devel-2.0.40-21.11 and aspell-0.33.7.1-21 but unfortunately I am getting the same dependency failures.
 
Old 04-30-2004, 04:50 AM   #4
coolamit78
Member
 
Registered: Aug 2003
Location: New Delhi, India
Distribution: RHEL AS 3/4, Windows XP
Posts: 546

Rep: Reputation: 31
You are using the latest version of PHP with a version of apache that came with Red Hat 9..That is what seems to be causing problems...Upgrade to the latest apache version (2.0.49 I guess) ...and then try to install php...

Cheers,

--amit
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Error: Failed dependencies r0ck Linux - Software 3 05-09-2005 03:24 PM
error: Failed dependencies: Greenman Linux - Newbie 3 09-29-2004 06:23 AM
I recieve a failed dependencies error, but I have all required dependencies Laptop2250 Linux - Software 15 02-03-2004 07:58 PM
Failed dependencies error installing spamassassin-2.61-1.i386.rpm on RH7.0 camelia Linux - Newbie 1 01-20-2004 06:33 PM
error: failed dependencies punt Linux - General 8 07-23-2001 01:18 AM


All times are GMT -5. The time now is 08:56 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration