LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 05-22-2004, 08:33 PM   #1
w0lv3rin3
Member
 
Registered: Mar 2004
Location: Barrie, ON
Distribution: Slackware 9.1, 10.0, 10.1, 11.0
Posts: 102

Rep: Reputation: 15
Error activating XKB configuration ----- Probably internal X server problem.


I installed DROPLINE, and after I installed it, it worked fine, till I did the DROPLINE Update, now when I reboot, I recieve error @ startup

Error activating XKB configuration.
Probably internal X server problem.

X server version data:
The X.Org Foundation
60700000

If you report this situation as a bug, please include:
- The result of xprop -root | grep XKB
- The result of gconftool-2 -R /desktop/gnome/peripherals/keyboard/xkb

any suggestions on howto fix this problem
 
Old 05-23-2004, 05:25 PM   #2
drogers8
LQ Newbie
 
Registered: May 2004
Location: NY
Distribution: FC2
Posts: 4

Rep: Reputation: 0
I just upgrade from RH9 to FC2 and I get the same error with gnome window manager plus some other problems. I do not get that error when I use KDE manager. I hope someone can shine some light on the fix.
 
Old 05-25-2004, 03:32 PM   #3
holymadness83
LQ Newbie
 
Registered: May 2004
Distribution: Fedora Core 2
Posts: 10

Rep: Reputation: 0
same problem

Yeah guys,
mine does the exact same thing. I just upgraded my system from FC 1 to FC 2 and when it came up my smartd (whatever the heck that is) doesn work and i get that creepy xkb config error when i start up.

i have researched it and hereīs what ive found:
the xkb is the way X reads the keyboard. supposedly this error is just an improperly configured keyboard. right now i cant type apostrophes. every time i try to type one it just erases the next letter. weird eh? also i have to type in ?īs twice and ~s twice. anybody know how to properly config the keyboard?

best of luck!
 
Old 05-28-2004, 07:30 PM   #4
w0lv3rin3
Member
 
Registered: Mar 2004
Location: Barrie, ON
Distribution: Slackware 9.1, 10.0, 10.1, 11.0
Posts: 102

Original Poster
Rep: Reputation: 15
i wish i could get this thing fixed

argg
 
Old 05-29-2004, 03:42 AM   #5
Linner
Member
 
Registered: May 2004
Distribution: Fedora
Posts: 71

Rep: Reputation: 15
Re: same problem

Quote:
Originally posted by holymadness83
Yeah guys,
mine does the exact same thing. I just upgraded my system from FC 1 to FC 2 and when it came up my smartd (whatever the heck that is) doesn work and i get that creepy xkb config error when i start up.
same here..tsk tsk.
 
Old 05-29-2004, 06:46 AM   #6
drigz
Member
 
Registered: Apr 2004
Distribution: Gentoo ~x86
Posts: 407

Rep: Reputation: 30
i had that - it was really easy to fix. i got it from installing dropline gnome, which uses xorg. i fixed it by using removepkg to remove a certain package, then used the dropline updater to reinstall it, and then it all worked fine.

unfortuntely, i cant remember which one it was.

try making sure that 'grep XkbRules /etc/X11/xorg.conf' returns:
Option "XkbRules" "xorg"
if not, change it, then the same for /etc/X11/XF86Config.
then run setxkbmap -rules xorg -layout us (or gb or whatever)

ill try and find out the name of the package for u
 
Old 05-29-2004, 06:54 AM   #7
drigz
Member
 
Registered: Apr 2004
Distribution: Gentoo ~x86
Posts: 407

Rep: Reputation: 30
got it. run:
grep xkb/rules /var/log/packages/*
you will get something like this:
/var/log/packages/xorg-6.7.0-i686-#dl:etc/X11/xkb/rules/
/var/log/packages/xorg-6.7.0-i686-#dl:etc/X11/xkb/rules/xorg.lst
/var/log/packages/xorg-6.7.0-i686-#dl:etc/X11/xkb/rules/sun.lst
/var/log/packages/xorg-6.7.0-i686-#dl:etc/X11/xkb/rules/sun
/var/log/packages/xorg-6.7.0-i686-#dl:etc/X11/xkb/rules/xorg.xml
/var/log/packages/xorg-6.7.0-i686-#dl:etc/X11/xkb/rules/xorg
/var/log/packages/xorg-6.7.0-i686-#dl:etc/X11/xkb/rules/README
/var/log/packages/xorg-6.7.0-i686-#dl:etc/X11/xkb/rules/sgi
/var/log/packages/xorg-6.7.0-i686-#dl:etc/X11/xkb/rules/xorg-it.lst
/var/log/packages/xorg-6.7.0-i686-#dl:etc/X11/xkb/rules/sgi.lst

where # is a number. mine is currently 3. then leave gnome and run as root:
removepkg xorg-6.7.0-i686-#dl.tgz

replacing # with the number. then i ran the dropline installer to get it back.
this will of course be different for red hat, as it uses rpm, but im sure you can adapt it pretty easily. maybe something like rpm -(whatever to remove) xorg-6.7.0-i686-#dl.rpm ?
instead of the dropline installer, you could try running rpm -(to install) xorg-6.7.0-i686-1dl.rpm .

i hope this helps
 
Old 06-03-2004, 01:52 PM   #8
Bob Loblaw
LQ Newbie
 
Registered: Jun 2004
Posts: 1

Rep: Reputation: 0
Here is a workaround while the packages get sorted out

a simpler method is presented in bug #120858 in the bugzilla for Fedora ...

----
Additional Comment #16 From Ralf Ertzinger on 2004-04-17 08:02 -------

I solved this by simply adding a symlink in /usr/X11R6/lib/X11/xkb/rules:

ln -s xorg.lst xfree86.lst

Temporary, sure, but setxkbmap is happy again.
----

This worked like a charm for me and hopefully future updates of xorg will fix things in the background ... but having this symlink should not harm anything.
 
Old 06-09-2004, 07:17 AM   #9
ArthurDent
Member
 
Registered: Feb 2004
Location: London
Distribution: Fedora Core 5, Mandrake 10.0, Gentoo, Suse
Posts: 174

Rep: Reputation: 30
Bob,

I just wanted to say a great big thank you!

I have had the same problem since upgrading and it had been bugging me to death. Such a simple fix. Even though the problem was only a minor inconvenience (requiring one mouse click) it somehow spoilt things beyond all proportion.

Thanks again...

Mark
 
Old 06-15-2004, 12:15 AM   #10
mcleod52
LQ Newbie
 
Registered: Jun 2004
Posts: 1

Rep: Reputation: 0
I too want to thank Bob, nice and simple fix. Just what the doctor ordered.

Stew
 
Old 06-15-2004, 01:19 PM   #11
Islander
LQ Newbie
 
Registered: Jun 2004
Location: Seattle area
Distribution: Fedora2, redhat9, suse
Posts: 1

Rep: Reputation: 0
thanks bob

Okay,
Bob, Your symlink worked perfectly. Thank you.

I had no tangible system problems anyway. No real keyboard errors that I could find. I just had that error message at login. still. It was irritating.
I am pleased with the simplicity of the solution. I am still wondering why it happened on one system and not another.
I loaded ferdora 2 fresh and new on one system and I upgraded another system. The upgrade was the one with the error message problem. go figure.
but as I said, your solution worked completely. Kudos to you.
Islander.
 
Old 10-22-2004, 02:07 AM   #12
jev-bird
Member
 
Registered: Jul 2004
Location: USofA
Distribution: Whatever runs accordingly.
Posts: 200

Rep: Reputation: 30
I have had this problem on numerous distros with xorg. Finally a fix maybe, although I have not tried it yet.

To be blunt, xorg is getting on my last nerve and the developers need to get off their fat asses and do it right if they even halfway expect xorg to supercede xfree. It's just been one blooper after another with xorg. Xcomp, translucency, etc turned out to be a bust unless your on a high end machine that can handle the cpu power for it and that's if it doesn't crash before you even get to try it out. Then the problems with keyboard functions, switching vt's etc.

Hey XORG what is it, are you blatently screwing up releases for users of US keyboards. I know a bit far fetched but with all this Xborg madness who can really tell what the heak is going on.

*sighs* Linux........................one problem after another. Thats's what keeps me goin. ;-)
 
Old 01-08-2005, 07:58 AM   #13
bic
Member
 
Registered: Jan 2005
Distribution: MythDora 3.2, RHEL 6.3
Posts: 95

Rep: Reputation: 16
Re: Here is a workaround while the packages get sorted out

Quote:
Originally posted by Bob Loblaw
a simpler method is presented in bug #120858 in the bugzilla for Fedora ...

----
Additional Comment #16 From Ralf Ertzinger on 2004-04-17 08:02 -------

I solved this by simply adding a symlink in /usr/X11R6/lib/X11/xkb/rules:

ln -s xorg.lst xfree86.lst

Temporary, sure, but setxkbmap is happy again.
----

This worked like a charm for me and hopefully future updates of xorg will fix things in the background ... but having this symlink should not harm anything.
I did this, but when I restart X, metacity seems to hang. I am able to login as root and not get the error message. I am not sure how to fix this for the user.
 
Old 07-03-2011, 03:27 PM   #14
mikedixson
LQ Newbie
 
Registered: Jul 2011
Posts: 1

Rep: Reputation: Disabled
Solved

I ran into this error after reconfiguring my keyboard layout using
Code:
sudo dpkg-reconfigure keyboard-configuration
I managed to solve it by running
Code:
sudo dpkg-reconfigure kbd
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
error activating XKB configuration fails Linux - Software 18 07-18-2010 05:41 AM
Error activating XKB configuration Pulka Linux - General 0 08-13-2004 01:42 PM
Error activating XKB configuration + 2 other questions tcn03u Fedora 9 06-28-2004 12:36 AM
Error activating XKB message on Desktop on FC2 beachkid Fedora 2 06-18-2004 07:15 AM
error activating xkb configuration in XFree86 4.3 bfay Linux - Software 0 12-29-2003 12:42 PM


All times are GMT -5. The time now is 08:37 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration