LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 10-29-2003, 05:33 AM   #1
ivanatora
Member
 
Registered: Sep 2003
Location: Bulgaria
Distribution: Ubuntu 9.10, FreeBSD 7.2
Posts: 459

Rep: Reputation: 31
Enlightment installation and Imlib


I tried to intall E from source, but the ./configure shows error.. it cannot find Imlib version 1.9.8 or newer. I went to the E home page and downloaded Imlib2. I installed it and tried to install E again. The ./configure showed that mistake again. I wrote somewhere in the Imlib docs that the version 2 is not a version upgrade, but a clean new build. Is that bad? I couldn't find Imlib version betwen 1.9.8 and 2, although there is mentioned 1.9.14 in the web site.. It doesn't exist in the download section. So, does that problem has a tricky solution, or I just have to find that 1.9.8? Does someone know where from it can be downloaded? And will I need to uninstall the version 2 of that library before installing 1.9.X (and how can be done that)?
 
Old 10-29-2003, 05:40 AM   #2
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
http://freshmeat.net/releases/14719/

Slack comes with 1.9.14. I typed 'imlib-1.9.8' into google. First result.

Imlib and imlib2 are entirely separate libs, is what it means about imlib2. You probably need both, so don't worry about that. But Pat discontinued E support because of naming conflicts regarding the libast library. Just so you know.
 
Old 10-29-2003, 10:08 AM   #3
ivanatora
Member
 
Registered: Sep 2003
Location: Bulgaria
Distribution: Ubuntu 9.10, FreeBSD 7.2
Posts: 459

Original Poster
Rep: Reputation: 31
Thanks. I found and installed imlib.. now that config cries for fnlib I found it too.. Maybe when I'm finished with E I'll have a thousands libraries that I wont need more than once
Can I ask here if I experience some more problems with E?
 
Old 10-29-2003, 10:51 AM   #4
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
Sure. Nobody can stop you but a mod. But compiling E and E-related apps is a big problem for everybody so be sure to search LQ and google first - odds are most problems have already been dsicussed. I was just posting in an Eterm thread around here and people linked to *another* E thread or two just in that one. But if you don't find anything relevant or what you do find doesn't make any sense (I know that feeling) post some followups.

(I like that sig, btw.)
 
Old 10-29-2003, 10:56 AM   #5
ivanatora
Member
 
Registered: Sep 2003
Location: Bulgaria
Distribution: Ubuntu 9.10, FreeBSD 7.2
Posts: 459

Original Poster
Rep: Reputation: 31
Urgh.. I'm beginning to hate this E.. now it is freetype. I downloaded freetype2.1.4 (E requires 1.3.1 and newer, I think) and installed it via ./configure; make; make install. Then run ldconfig. Then I tried to configure (again, and again..) E. This time the error message was:
Code:
checking for freetype.h... no
checking for freetype/freetype.h... no
checking for TT_Init_FreeType in -lttf... no
ERROR: Enlightenment needs a system with libttf.so (TrueType Font Library)
...
I have freetype.h :
Code:
# locate freetype.h
/usr/X11R6/include/fontconfig/fcfreetype.h
/usr/local/include/freetype2/freetype/freetype.h
/usr/share/texmf/doc/help/Catalogue/entries/freetype.html
/usr/include/freetype2/freetype/freetype.h
/home/ivanatora/Archives/E/freetype-2.1.4/include/freetype/freetype.h
So does that E hate me, or I just have a lot of bad luck today?
Or maybe freetype must be configured with ./configure --some options? I read INSTALL.UNX file and looked at ./configure --help but didn't see anything unusual.
Now I'm going to install 1.3.1 and see if THEN it wont compile!
Btw, I like that sig, too

Last edited by ivanatora; 10-29-2003 at 11:03 AM.
 
Old 10-29-2003, 11:15 AM   #6
slakmagik
Senior Member
 
Registered: Feb 2003
Distribution: Slackware
Posts: 4,113

Rep: Reputation: Disabled
Well, I have freetype.h on my system, too, but I don't have libttf.so. That much is in the XFree86-devel packages. It's possible there's some conflict between the one freetype and the other, kind of like ksh's libast and Eterm's libast. Or maybe it installed someplace weird. Maybe see where libttf.so went.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slackware 10.1 GDM + enlightment securitybreach Slackware 12 03-19-2005 11:57 AM
enlightenment and imlib grcunningham Linux - Software 1 04-28-2004 11:14 AM
Enlightment Installation Problem on Mandrake 9.1 Darthcoder Linux - Software 3 10-25-2003 07:32 AM
enlightment killi Slackware 10 05-13-2003 02:32 PM
imlib Neur0tek Linux - Newbie 2 04-25-2002 10:11 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration