LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 08-02-2003, 06:48 PM   #1
craigienz
LQ Newbie
 
Registered: Aug 2003
Location: Wellington, New Zealand
Distribution: Slackware
Posts: 22

Rep: Reputation: 15
Unhappy Enemy Territory Mesa issues


Hi, I installed RTCW: Enemy Territory yesterday on my Linux Red Hat box, on the off chance that it would work a damn site better than on Windows, and I would be able to get rid of windows. However, whenever I try to run this program, it comes up with the following:

ET 2.55 linux-i386 May 27 2003
----- FS_Startup -----
Current search path:
/home/craig/.etwolf/etmain
/usr/local/games/enemy-territory/etmain/pak0.pk3 (3725 files)
/usr/local/games/enemy-territory/etmain/mp_bin.pk3 (4 files)
/usr/local/games/enemy-territory/etmain

----------------------
3729 files in pk3 files
execing default.cfg
couldn't exec language.cfg
couldn't exec autoexec.cfg
Hunk_Clear: reset the hunk ok

------- Input Initialization -------
Joystick is not active.
------------------------------------
Bypassing CD checks
----- Client Initialization -----
----- Initializing Renderer ----
-------------------------------
----- Client Initialization Complete -----
----- R_Init -----
...loading libGL.so.1: Initializing OpenGL display
...setting mode 4: 800 600
Using XFree86-VidModeExtension Version 2.2
XF86DGA Mouse (Version 2.0) initialized
XFree86-VidModeExtension Activated at 800x600
Using 8/8/8 Color bits, 16 depth, 0 stencil display.
GL_RENDERER: Mesa GLX Indirect


***********************************************************
You are using software Mesa (no hardware acceleration)!
Driver DLL used: libGL.so.1
If this is intentional, add
"+set r_allowSoftwareGL 1"
to the command line when starting the game.
***********************************************************
...WARNING: could not set the given mode (4)
Initializing OpenGL display
...setting mode 3: 640 480
Using XFree86-VidModeExtension Version 2.2
XF86DGA Mouse (Version 2.0) initialized
XFree86-VidModeExtension Activated at 640x480
Received signal 11, exiting...


I am really at a loss for what to do. I have a Radeon 7500 graphics card, which I had assumed would do the openGL processing for me. I could be wrong of course.

I tried running it with the +set r_allowSoftwareGL 1 setting, but it runs slower than a dog, and is impossible to use.

If someone could help, that would be great.
 
Old 08-02-2003, 07:04 PM   #2
newbe45
Member
 
Registered: Jul 2003
Distribution: fedora, gentoo
Posts: 128

Rep: Reputation: 15
Try reinstalling your video card drivers. I had a similar error message. I reinstalled the driver and works with no problem
 
Old 08-02-2003, 11:04 PM   #3
wr3ck3d
Member
 
Registered: Dec 2002
Location: IL
Distribution: NetBSD, Slackware, Gentoo, Debian, FreeBSD
Posts: 444

Rep: Reputation: 31
You need hardware acceleration. Not sure if ATI makes a driver for that card, if not then get the DRI drivers.
 
Old 08-03-2003, 06:59 PM   #4
craigienz
LQ Newbie
 
Registered: Aug 2003
Location: Wellington, New Zealand
Distribution: Slackware
Posts: 22

Original Poster
Rep: Reputation: 15
In reply to both of you. I tried to upgrade the driver, and got totally lost. How do I uninstall the origional driver? And when trying to install the DRI drivers, it kept coming up with:

Compiling...
ERROR: Kernel modules did not compile

The DRI drivers can not be installed without the latest kernel modules.
Installation will be aborted. See the dri.log file for information on
what went wrong.

I am lost. Really. Please help!
 
Old 08-03-2003, 07:20 PM   #5
newbe45
Member
 
Registered: Jul 2003
Distribution: fedora, gentoo
Posts: 128

Rep: Reputation: 15
I have a nvidia card, I do not know what to tell you. try going to the ati site and downloading the newest driver for linux then reading all the help and read me files.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Enemy Territory Sound Issues manlief Linux - Games 3 06-08-2004 10:22 PM
Enemy Territory (You are using software Mesa (no hardware acceleration) cr0zz Linux - Games 2 04-30-2004 12:33 PM
Enemy Territory + GL_Render = Mesa Jay_highlands Linux - Games 8 04-25-2004 09:06 PM
Enemy Territory Install issues FastFeet Linux - Games 2 11-30-2003 04:27 PM
Enemy Territory Sound Issues mfarley Linux - Games 9 11-16-2003 04:35 AM


All times are GMT -5. The time now is 04:32 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration