LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 10-17-2005, 08:52 PM   #1
richcm
LQ Newbie
 
Registered: Jul 2003
Location: Tampa
Distribution: Gentoo
Posts: 21

Rep: Reputation: 15
Emerge xine-ui fails


I've been trying to emerge xine-ui so I can play dvd's, but I keep getting this error. HELP! Thanks.


checking for xine-config... /usr/bin/xine-config
checking for XINE-LIB version >= 1.0.0...
*** 'xine-config --version' returned 1.1.0, but XINE (1.0.5)
*** was found! If xine-config was correct, then it is best
*** to remove the old version of XINE. You may also be able to fix the error
*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing
*** /etc/ld.so.conf. Make sure you have run ldconfig if that is
*** required on your system.
*** If xine-config was wrong, set the environment variable XINE_CONFIG
*** to point to the correct copy of xine-config, and remove the file config.cache
*** before re-running configure
no
configure: error: *** You should install xine-lib first ***

!!! Please attach the config.log to your bug report:
!!! /var/tmp/portage/xine-ui-0.99.3/work/xine-ui-0.99.3/config.log

!!! ERROR: media-video/xine-ui-0.99.3 failed.
!!! Function econf, Line 485, Exitcode 0
!!! econf failed
!!! If you need support, post the topmost build error, NOT this status message.

>> error from config.log file

This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

It was created by configure, which was
generated by GNU Autoconf 2.59. Invocation command line was

$ ./configure --prefix=/usr --host=i686-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --enable-nls --disable-lirc

## --------- ##
## Platform. ##
## --------- ##

hostname = arcadebox
uname -m = i686
uname -r = 2.6.7-epia1
uname -s = Linux
uname -v = #43 Sat Oct 8 08:52:43 EDT 2005

/usr/bin/uname -p = VIA Nehemiah
/bin/uname -X = unknown

/bin/arch = i686
/usr/bin/arch -k = unknown
/usr/convex/getsysinfo = unknown
hostinfo = unknown
/bin/machine = unknown
/usr/bin/oslevel = unknown
/bin/universe = unknown

PATH: /usr/lib/ccache/bin
PATH: /sbin
PATH: /usr/sbin
PATH: /usr/lib/portage/bin
PATH: /bin
PATH: /usr/bin
PATH: /opt/bin
PATH: /usr/i386-pc-linux-gnu/gcc-bin/3.3
PATH: /usr/X11R6/bin
PATH: /usr/qt/3/bin
PATH: /usr/kde/3.3/sbin
PATH: /usr/kde/3.3/bin


## ----------- ##
## Core tests. ##
## ----------- ##

configure:1584: checking build system type
configure:1602: result: i686-pc-linux-gnu
 
Old 10-17-2005, 09:01 PM   #2
cyberjun
Member
 
Registered: Mar 2005
Distribution: Gentoo kernel 2.6.14
Posts: 96

Rep: Reputation: 15
Hi,
As the error says, emerge xine-lib first. So do the following.

bash# emerge xine-lib
bash# emerge xine-ui

cheers,
--cyberjun
 
Old 10-18-2005, 11:13 AM   #3
richcm
LQ Newbie
 
Registered: Jul 2003
Location: Tampa
Distribution: Gentoo
Posts: 21

Original Poster
Rep: Reputation: 15
I've tried that already but emerge xine-ui always fails. Must be some link to the xine-lib library that is wrong. In which case, I don't know which link to fix.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Stepmania 3.9-rc3 emerge fails slithy Linux - Games 1 11-22-2005 05:32 AM
Gentoo network less install emerge fails. Nz_Boy_2004 Linux - Distributions 2 09-06-2004 08:13 AM
Gentoo: emerge system fails AncAlAgoN Linux - Laptop and Netbook 2 05-23-2004 09:55 PM
Gentoo box fails to start after 'emerge -u world' satimis Linux - Distributions 0 02-10-2004 02:08 AM
kdemultimedia-3.1.5 fails to emerge...any ideas? Nu-Bee Linux - Software 2 01-19-2004 04:51 PM


All times are GMT -5. The time now is 01:07 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration