LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 03-06-2006, 02:15 PM   #1
matrixon
Member
 
Registered: Feb 2005
Location: mexico city
Distribution: 2.6.17-gentoo-r8
Posts: 127

Rep: Reputation: 15
emerge -u world problem


hihi

im using gentoo 2005.1 and last week i did an emerfe -du world
and know my gentoo is messed all up , it dont recognize de internet pro wireless card and it was working fine before that i also get an error of configuration when i log on as any user including root what did i did wrong ?
 
Old 03-06-2006, 03:51 PM   #2
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 12,117

Rep: Reputation: 985Reputation: 985Reputation: 985Reputation: 985Reputation: 985Reputation: 985Reputation: 985Reputation: 985
Pretty hard to tell. How long since you last sync'd ???. How long since you last updated ???. What profile are you running ???. Did you do etc-update ???. If so did you (always) eye-ball each individual file ???.

Check the obvious first, then see what's left.
 
Old 03-06-2006, 05:06 PM   #3
cs-cam
Senior Member
 
Registered: May 2004
Location: Australia
Distribution: Gentoo
Posts: 3,544
Blog Entries: 4

Rep: Reputation: 56
I just noticed your distro says Gentoo 2.6.11-r6. If you updated all the way from that you're going to have issues unless you are careful. Since then hotplug has been dumped for udev and your kernel will probably need an initrd unless you used genkernel in which case you'd already have one, probably without the right files in it though. Hopefully thought you're updating from something more recent...
 
Old 03-06-2006, 05:50 PM   #4
jomen
Senior Member
 
Registered: May 2004
Location: Leipzig/Germany
Distribution: Arch
Posts: 1,684

Rep: Reputation: 54
initrd is only needed IF you use genkernel - and it will be created by it - just the boot-loader might need to be updated by hand...
not syncing (emerge --sync) before doing an update and
forgetting to run etc-update after an update is the most common flaw... - before rebooting!
If you still can boot - do this (the second one) now though...
 
Old 03-06-2006, 08:24 PM   #5
matrixon
Member
 
Registered: Feb 2005
Location: mexico city
Distribution: 2.6.17-gentoo-r8
Posts: 127

Original Poster
Rep: Reputation: 15
re

the problem was that i forgot the etc-update its all working now again thnx guys
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
gentoo + emerge --update world kurrupt Linux - General 8 06-05-2005 01:18 AM
emerge -u --deep world - blockers patientzero Linux - Distributions 2 02-21-2004 08:39 PM
after emerge -u --deep world what's next? patientzero Linux - General 0 02-20-2004 04:35 PM
HELP: Problem in rebooting after running 'emerge -u world' satimis Linux - General 10 02-20-2004 10:08 AM
emerge errors during emerge -u world busbarn Linux - Distributions 6 04-23-2003 09:37 AM


All times are GMT -5. The time now is 06:33 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration