LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Emacs - changing default font size and font type? (http://www.linuxquestions.org/questions/linux-software-2/emacs-changing-default-font-size-and-font-type-489000/)

neilcpp 10-03-2006 07:28 AM

Emacs - changing default font size and font type?
 

Hello, I have tried to research this. I have found the built in help system hard to follow and cannot find where this particular problem is answered. I have also tried posting this question to usenet, with no satisfactory response.

I am using Emacs 21.3.1 under FreeBSD 6.1. I want to change the default font size AND the default font type permanently, by making a entry into the .emacs initi file.

Normally, i temporarily change the size AND type of font by holding down shift and left clicking the mouse button. I then get a menu of fonts and always select this:

courier (type)
18 (size)

MY QUESTION:

Please show me precisely what I need to write in the .emacs file in order for the courier (type) and 18 (size) to be made my default font type and size.

Currently, my .emacs file simply has the entry: (set-default-font "9x15"), which is a bit larger, but i do not like the font type. Thats why I need a specific reply to this, if possible.

Thanks

KenJackson 10-03-2006 08:34 AM

There are some shortcut names like the "9x15" you are using (also "8x13"), but normally it expects the X font name like this:
-MAKER-FAMILY-WEIGHT-SLANT-WIDTHTYPE-STYLE-PIXELS-HEIGHT-HORIZ-VERT-SPACING-WIDTH-CHARSET

You can run these commands (at least on Linux, probably on FreeBSD too) to see what fonts are on your system:
Code:

xlsfonts            ## This displays system fonts
xfd -fn fontname    ## This pops up a window displaying it

Here are some that I have tried on my Linux system:
Code:

"-*-fixed-medium-r-normal-*-16-*-*-*-*-*-fontset-standard"
"-*-Fixedsys-normal-r-*-*-*-*-*-*-c-*-*-ansi-"
"-raster-Fixedsys-normal-r-normal-normal-12-90-96-96-c-80-iso8859-1"
"-raster-Terminal-normal-r-normal-normal-16-120-96-96-c-120-ms-oemlatin"
"-*-Fixedsys-normal-r-*-*-15-112-*-*-c-80-*-ansi-"


neilcpp 10-03-2006 04:54 PM

Thanks, -I'm sure the available fonts are the same for Linux and FreeBSD...but could you help me by identifying:

1. The full name of the font type AND size for courier 18?

2. The exact wording that i need to place in the .emacs file, so it will be started automatically eash time.

Thanks 4 help

KenJackson 10-03-2006 08:48 PM

OK, I fired up FreeBSD in VMware, which I hadn't done in some time. This worked. The first line just prints to stdout so you can see you've isolated one font name. The second command pops up a window showing you the font. You can toy with the grep arguments to get different choices.
Code:

xlsfonts | grep courier-medium-r | grep .-18- | grep 59-1$
xfd -fn $(xlsfonts | grep courier-medium-r | grep .-18- | grep 59-1$)

On both Gnu/Linux and FreeBSD, one font that might interest you is:

"-adobe-courier-medium-r-normal--18-180-75-75-m-110-iso8859-1"

neilcpp 10-04-2006 06:03 AM

Thanks.. i simply put in .emacs file:

(set-default-font "-adobe-courier-medium-r-normal--18-180-75-75-m-110-iso8859-1")

and it works automatically now. thanks

iOuZo 10-04-2007 12:32 PM

thanks neilcpp, i have been searching for about a hour on how to do that... :) i used the exact same font * size as you did... nice :)

garstek 11-07-2007 12:25 PM

Thanks, neilcpp, your instructions worked. However... :)

it now takes quite a while for emacs to show text in a buffer after opening a file. How can I change this, without going back to standard font settings?

dsleb 09-10-2008 08:41 PM

try $xfontsel to experiment with font options
 
Hi... thanks for the help, just what I needed

Here is a nifty tool for finding a font you like in a format suitable syntax:

in terminal:

$ xfontsel

Thorendor 09-19-2008 04:41 PM

Quote:

Originally Posted by garstek (Post 2951208)
it now takes quite a while for emacs to show text in a buffer after opening a file. How can I change this, without going back to standard font settings?

The delay caused by set-default-font can be worked around by adding the following at the beginning of your .emacs file:
(modify-frame-parameters nil '((wait-for-wm . nil)))

See https://launchpad.net/metacity/+bug/23005 for more details.

faizlo 08-05-2009 01:31 AM

I deleted my .emacs file by mistake, and when I created a new one with the following two lines:
Code:

(set-default-font "-adobe-courier-medium-r-normal--18-180-75-75-m-110-iso8859-1")
(modify-frame-parameters nil '((wait-for-wm . nil)))

But it gives me the error below:
Code:

No fonts match `Monospace-10'
What's wrong?

I do not have a .Xresources file in my ~/ area.

Faizlo

notaddicted 01-06-2010 11:17 AM

Also:

To find out the name of a font you can do this:

1. select the font you want as you would with the mouse (shift+click and then use the font menu.)

2. type "M-x describe-font ENTER ENTER"

3. the name of the font is after "full name:".

Then you add it to .emacs.
for me:

(set-default-font "-Misc-Fixed-Medium-R-Normal--10-100-75-75-C-60-ISO8859-1")
(modify-frame-parameters nil '((wait-for-wm . nil)))

zebby12 12-08-2010 06:43 PM

Does anyone know the .emacs code for the font Monospace? I tried and all I got was LMRoman12. Definitely not what I want.

KenJackson 12-08-2010 09:02 PM

I currently use this:

(font . "9x15")

Look at my post above to see how to find others.

BTW, this is a really old thread. It wouldn't hurt to start a new one.

jrocher 01-14-2011 04:03 PM

A more visual way to do this is to click
options>set default font...
then to pick what you like and then click
options > save options
This will modify your .emacs file automatically and you don't need to know the complicated names of fonts.

hth
Jonathan

KenJackson 01-14-2011 10:07 PM

Quote:

Originally Posted by jrocher (Post 4224633)
options>set default font...

Ah! Very good.
I never would have thought of that because I never see the menu. I always have these in my .emacs file:
Code:

(menu-bar-mode -1)
(tool-bar-mode -1)


Quote:

Originally Posted by jrocher (Post 4224633)
This will modify your .emacs file automatically ...

Automatically mucking with my carefully edited configuration file won't make me happy.


All times are GMT -5. The time now is 10:55 AM.