LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 11-13-2010, 08:34 PM   #16
maverick5595
LQ Newbie
 
Registered: Nov 2010
Posts: 3

Rep: Reputation: 0

https://addons.mozilla.org/en-US/firefox/tag/ed2k

Last edited by maverick5595; 11-13-2010 at 08:43 PM.
 
Old 11-13-2010, 08:43 PM   #17
maverick5595
LQ Newbie
 
Registered: Nov 2010
Posts: 3

Rep: Reputation: 0
I got it working by adding this add-on.

https://addons.mozilla.org/en-US/firefox/tag/ed2k
 
Old 02-18-2013, 02:11 PM   #18
ntsc525
LQ Newbie
 
Registered: Feb 2013
Posts: 2

Rep: Reputation: Disabled
Solved: aMule 2.3.1, Ubuntu 12.04, Firefox 18 links not working

Wake up, old Thread! It's time to wake up and smell the changes!

Hello, everyone:

I started searching for this info recently when installing Ubuntu 12.04 LTS and aMule 2.3.1. FireFox is now at Version 18.xx, and a lot has changed. The last time I got aMule working was on a Fedora 10 build, aMule 2.2.6, and FireFox 2.x or 3.x (I don't remember because I've upgraded since then). The information commonly found on the web and info early in this thread was enough to get it working then. (Back then, *.amule.org was a working web site with a nice wiki, but it's been down for some time as of this writing.) Also, there is a reference to the FireMule addon. I don't remember if I used that back then, but it certainly is no longer available for Firefox 18.

Since I tend to just let stuff run if it's working, my laptop just suddenly woke up with a whole new Linux environment several years newer, and I had to remember and mostly relearn almost everything about getting my favorite software working again.

Hopefully what I've discovered today helps someone else and puts all the different clues and pieces together in one place. My environment is Ubuntu 12.04 LTS, aMule 2.3.1, and FireFox 18.x. I don't know what changed or when since my last clean Linux install (Fedora 10, then upgraded to 14), so it probably applies to other Linux versions, older FireFox versions past 3.x, and probably aMule going back to 2.2.6. Or, maybe it's just a bug specific to Ubuntu 12.04 and/or the aMule installation package that came with it.

With my versions of Ubuntu 12.04 LTS, aMule 2.3.1 and FireFox 18.x, we are STILL a long way from "plug and play" to get aMule working. (One would think after running apt-get install, everything would "just work", but alas, no.) In addition to the customization of FireFox, one must also learn about xdg, and the Ubuntu desktop environment, which is usually "automagically" set up when other software is installed.

By the way, I changed my desktop from Unity to XFCE because I came from Fedora 10 / 14, and didn't want to have to figure out a new interface on top of everything else. Hopefully the info below applies to Unity as well but I haven't tested it. Maybe this thread will come back alive and others will post their software versions, what desktop, etc., and let us know their experiences. I'd like to know if similar troubles were seen with other Linux versions, and how far back it goes.

I don't know how many of the steps I took are necessary on a "modern" (2012) installation, because I started with the FireFox 3.x instructions first:

FireFox 3.5 info, which can still be done in Version 18:
Go into about:config as mentioned earlier, and add the following values (including a couple extras I found in different places):

The first three settings are the standard ones most commonly given to get FireFox 3.x (some say 3.5 and later) to work:
Open about:config in a browser window. Click on the "I'll be careful, I promise" button.
Right click somewhere in the list, and select New, then select the type listed below.
Copy and paste the preference name, then the value. Try everything exactly as is first, then move on to the Desktop info below this section before returning to troubleshoot Firefox.

Preference Name Type Value
Comment
[Main 3 Preferences, widely publicized for Firefox 3.5]
network.protocol-handler.app.ed2k String /usr/bin/ed2k
(Some say just use "ed2k" without the path but full path works on Ubuntu 12.04 LTS and aMule from repositories)
network.protocol-handler.external.ed2k Boolean True
network.protocol-handler.expose.ed2k Boolean False
(FireFox 3 or 3.5 and higher. Some say it's needed to get FireFox to prompt for ed2k program)

[Preferences I found elsewhere, when the above wasn't enough to get working. Optional until you try the Desktop stuff below.]
network.protocol-handler.warn-external.ed2k Boolean True
(Some say it's needed to get a prompt for what program to use.)
extensions.torrentserver-handler.protocols String ed2k
(Some say newer versions need this to handle ed2k links. I don't remember where I found this or if it will break BitTorrent.)

For my installation, though, this was not enough, and I kept getting messages that FireFox didn't know how to handle ed2k links. I gave up and installed Google Chrome (Chromium) and tried to get that to work. (It didn't out of the box.) But it led me to...

Ubuntu Desktop Environment:

I stumbled upon information about xdg-open, while trying to get Chromium to work with ed2k links, though I haven't fully researched all of the xdg stuff. Chrome relies on the Operating System (OS) to decide how to open links (which is probably also true of other browsers as well as your File Manager, etc.), which led me to xdg-open, creating .desktop files (which creates a link in your desktop, at least for XFCE and probably Gnome, and provides the path and commands to open the URI). Again, I don't know when FireFox started needing this, but apparently it does now.

We first have to create a file with our favorite editor (I still use vi but most people use gedit so it depends on my mood):

sudo gedit /usr/share/applications/ed2k.desktop

Copy and paste the following text and save. (If you forget the "sudo", you won't be able to save.)
----------------- Copy Below --------------------
[Desktop Entry]
Name=ed2k
Exec=ed2k %u
Type=Application
Terminal=false
Categories=System;
MimeType=x-scheme-handler/ed2k;
Comment=aMule ED2K Link Parser
------------------ Copy Above --------------------

Then, enter the following commands (in my case, I didn't need sudo, they worked from the user account):
gconftool-2 -s /desktop/gnome/url-handlers/ed2k/command '/usr/bin/ed2k %s' --type String
gconftool-2 -s /desktop/gnome/url-handlers/ed2k/enabled --type Boolean true

And, finally:
sudo update-desktop-database

Then, fire up aMule or your aMule daemon plus aMule GUI, and test:

In my case, this got FireFox to work exactly how I like with single and multiple links. Chrome, however, handles single links fine, but ignores multiple links. Whatever, that's another problem, and I'm using Firefox for my aMule needs anyway.

Additional troubleshooting:
Copy an ed2k link (ed2k://|file...)

From a terminal, type:
xdg-open "<paste your link here>" (You MUST include quotes or the shell will misinterpret "/" and "|")
If this results in a new file being queued in your aMule application, then your desktop environment plus ed2k program are working.

If not, then type:
ed2k "<paste link here>" (again, in quotes)
If it works now, at least your ed2k program and aMule are working, and you still need to get xdg-open working before you can hope for Firefox or Chrome to work.

As usual with something that takes me a couple of days to get working, some of the steps I took above may no longer be needed. If you know this, then feel free to post a reply with your findings. Or, on the next build I'll only do the desktop stuff and not the FireFox customizations, and I'll try to remember to post my findings as a reply.

Hopefully this will help the next person who Googles Amule and Firefox.
 
Old 02-19-2013, 01:55 AM   #19
ntsc525
LQ Newbie
 
Registered: Feb 2013
Posts: 2

Rep: Reputation: Disabled
Update: Getting aMule ed2k links to work with Firefox 18 Ubuntu 12.04

OK, I just did another fresh install, and I did NOT have to make any changes to Firefox, only the following:

Install amule and utilities as documented elsewhere.

Ubuntu Desktop Environment:

I stumbled upon information about xdg-open, while trying to get Chromium to work with ed2k links, though I haven't fully researched all of the xdg stuff. Chrome relies on the Operating System (OS) to decide how to open links (which is probably also true of other browsers as well as your File Manager, etc.), which led me to xdg-open, creating .desktop files (which creates a link in your desktop, at least for XFCE and probably Gnome, and provides the path and commands to open the URI). Again, I don't know when FireFox started needing this, but apparently it does now.

We first have to create a file with our favorite editor (I still use vi but most people use gedit so it depends on my mood):

sudo gedit /usr/share/applications/ed2k.desktop

Copy and paste the following text and save. (If you forget the "sudo", you won't be able to save.)
----------------- Copy Below --------------------
[Desktop Entry]
Name=ed2k
Exec=ed2k %u
Type=Application
Terminal=false
Categories=System;
MimeType=x-scheme-handler/ed2k;
Comment=aMule ED2K Link Parser
------------------ Copy Above --------------------

Then, enter the following commands (in my case, I didn't need sudo, they worked from the user account):
gconftool-2 -s /desktop/gnome/url-handlers/ed2k/command '/usr/bin/ed2k %s' --type String
gconftool-2 -s /desktop/gnome/url-handlers/ed2k/enabled --type Boolean true

And, finally:
sudo update-desktop-database

Then, fire up aMule or your aMule daemon plus aMule GUI, and test:

On the second fresh install both individual links and multiple links worked in both Firefox and Chromium without tweaking either browser.

Additional troubleshooting:
Copy an ed2k link (ed2k://|file...)

From a terminal, type:
xdg-open "<paste your link here>" (You MUST include quotes or the shell will misinterpret "/" and "|")
If this results in a new file being queued in your aMule application, then your desktop environment plus ed2k program are working.

If not, then type:
ed2k "<paste link here>" (again, in quotes)
If it works now, at least your ed2k program and aMule are working, and you still need to get xdg-open working before you can hope for Firefox or Chrome to work.

As usual with something that takes me a couple of days to get working, some of the steps I took above may no longer be needed. If you know this, then feel free to post a reply with your findings. Or, on the next build I'll only do the desktop stuff and not the FireFox customizations, and I'll try to remember to post my findings as a reply.

Hopefully this will help the next person who Googles Amule and Firefox.
 
  


Reply

Tags
amule, firefox, mldonkey


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Handling Links with Firefox, Thunderbird, and Gaim apachedude Linux - Software 1 02-11-2005 08:07 AM
Xmule: How to Integrate ED2K Links into different webbrowsers. spchehe Linux - Software 0 08-18-2004 11:09 PM
ed2k:// links in kde3.2 Jelle Linux - Software 0 03-08-2004 12:19 PM
mozilla , flash and ed2k links zspirit Linux - Software 0 10-07-2003 03:28 AM
How do you get xmule 1.6.0 to take ed2k links automatically??? Evilnewbie Linux - Newbie 0 09-17-2003 06:51 AM


All times are GMT -5. The time now is 08:21 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration