LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 12-10-2009, 05:09 AM   #1
Devilslord
LQ Newbie
 
Registered: Dec 2009
Distribution: Ubuntu 8.04 (Wubi)
Posts: 5

Rep: Reputation: 0
Question Ed2k links handling with Firefox and aMule


Hi. I'm a happy Ubuntu user and a new forum member, so first of all I take the opportunity to say hullo to everybody.

I need my aMule to handle ed2k links on Firefox 3, but, because of more than a reason, I've to start the p2p software as root while the browser as normal user, so my /usr/bin/ed2k.bin (included into amule-utils package just for this purpose) obviously doesn't open any link though I set up Firefox properly (following these instructions). In fact, if I start aMule as normal user, everything goes all right.

I thought also that Ubuntu Gconf-Editor might solve my problem, perhaps adding some key in desktop → gnome → url-handlers, but I don't know exactly how I could do this.

Could someone help me? Thanks.
 
Old 12-10-2009, 05:57 AM   #2
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,038

Rep: Reputation: 373Reputation: 373Reputation: 373Reputation: 373
I use this plugin, which works ok in firefox and seamonkey:
http://www.informatik.uni-oldenburg.de/~dyna/mldonkey/

I don't use amule though. Instead I use mldonkey which runs in another machine. The plugin is supposed to have some support for amule/emule, but I haven't ever tested it. So I can't be sure it will work. But you can give it a try.
 
Old 12-10-2009, 07:12 AM   #3
Devilslord
LQ Newbie
 
Registered: Dec 2009
Distribution: Ubuntu 8.04 (Wubi)
Posts: 5

Original Poster
Rep: Reputation: 0
I've set up into your addon preferences my aMule TCP as "Web Port", "aMule Mode" and lived localhost as "Host Address", without any password (I hope this is correct), but the problem still remains: I try to open, when prompted, the link both with /usr/bin/ed2k.bin and /usr/bin/amule.bin, but nothing happens...

The problem is that Firefox (started as normal user) doesn't see any aMule interface enabled, as unfortunately I've to start it as root. It would be necessary a way to "persuade" the root-aMule to work after a normal user-Firefox instance, so that I thought to Gconf...
 
Old 12-10-2009, 08:04 AM   #4
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,038

Rep: Reputation: 373Reputation: 373Reputation: 373Reputation: 373
I am not that sure this is an issue with user privileges.

As far as I know, it's just a server/daemon listening to a given port, it really doesn't understand about system users as such. AS long as you provide the right login info to that port (4080 usually) you should be fine. It could be an issue with your firewall though, or simply a misconfiguration in the amule server. Unfortunately I know not much about amule at all. It's been years since the last time I used it.
 
Old 12-10-2009, 08:07 AM   #5
craigevil
Senior Member
 
Registered: Apr 2005
Location: OZ
Distribution: Debian Sid
Posts: 4,732
Blog Entries: 12

Rep: Reputation: 456Reputation: 456Reputation: 456Reputation: 456Reputation: 456
Actually, it's quite easy. Type about:config at the address bar and press ENTER. Right click your mouse and add two values:

name:network.protocol-handler.app.ed2k
type: string
value: /usr/bin/ed2k

(this value varies on different Linux distributions, maybe /usr/local/bin/ed2k or some place else.)

name: network.protocol-handler.external.ed2k
type: boolean
value: true
 
0 members found this post helpful.
Old 12-10-2009, 10:04 AM   #6
Devilslord
LQ Newbie
 
Registered: Dec 2009
Distribution: Ubuntu 8.04 (Wubi)
Posts: 5

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by i92guboj View Post

I am not that sure this is an issue with user privileges.

As far as I know, it's just a server/daemon listening to a given port, it really doesn't understand about system users as such. AS long as you provide the right login info to that port (4080 usually) you should be fine. It could be an issue with your firewall though, or simply a misconfiguration in the amule server. Unfortunately I know not much about amule at all. It's been years since the last time I used it.
I think you're right, it doesn't work also with a normal user-started aMule... In both cases, Firefox asks me what program I want to open footer.php (what is this???): I try ed2k.bin, amule.bin, amulecmd.bin, but nothing happens, unless the browser tells me that a file was downloaded (I don't know which one or where, since my download directory appears empty, though I think it refers to footer.php again...). I tried with the firewall disabled too, but it's the same.

Do you think I have to change the Host Address in the addon preferences?

Quote:
Originally Posted by craigevil View Post

Actually, it's quite easy. Type about:config at the address bar and press ENTER. Right click your mouse and add two values:

name:network.protocol-handler.app.ed2k
type: string
value: /usr/bin/ed2k

(this value varies on different Linux distributions, maybe /usr/local/bin/ed2k or some place else.)

name: network.protocol-handler.external.ed2k
type: boolean
value: true
It was the first way I tried (from the link I've posted), unfortunately it doesn't work.
 
Old 12-10-2009, 10:20 AM   #7
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,038

Rep: Reputation: 373Reputation: 373Reputation: 373Reputation: 373
For the host address you should use whatever name your machine has. For a local machine, either localhost or 127.0.0.1 should work, for remote machines you might need to configure your local DNS server or yourt /etc/hosts file, or use whatever IP is correct for that machine.

However, it doesn't seem like that plugin I told you is managing the URL at all. When there's a handler for that protocol, and provided that the url is correct, Firefox shouldn't ask you what program to use to manage the file. It should just handle it, like it handles http://, https://, ftp:// or whatever other supported protocol.

I am not sure if the problem you are experiencing is due to something odd in your firefox setup or due to some problem with the plugin communicating with amule. As said, I never used it with amule, only mldonkey.

I guess that, as a quick test, you could create a clean user, install the plugin with that user and test it without doing any extra modification (only the configuration of the plugin itself, of course). If that doesn't work is problem some problem between the plugin and Firefox. If it works, then it's probably some protocol stuff broken in your Firefox configuration.
 
Old 12-10-2009, 02:56 PM   #8
Devilslord
LQ Newbie
 
Registered: Dec 2009
Distribution: Ubuntu 8.04 (Wubi)
Posts: 5

Original Poster
Rep: Reputation: 0
I've tried to create a new profile, and the result is the same... So, you say that the problem is in the addon... Thank you, anyway!

Another idea?
 
Old 12-10-2009, 03:51 PM   #9
i92guboj
Gentoo support team
 
Registered: May 2008
Location: Lucena, Córdoba (Spain)
Distribution: Gentoo
Posts: 4,038

Rep: Reputation: 373Reputation: 373Reputation: 373Reputation: 373
So I think, but I can't really be sure. You could always try mldonkey. It shouldn't be too hard to set it up for a test, and at least you would know if the plugin is working correctly.
 
Old 01-26-2010, 05:25 PM   #10
hsiang_canada
LQ Newbie
 
Registered: Jan 2010
Posts: 1

Rep: Reputation: 0
Install amule-gnome-support will solve the problem.

Enjoy
 
0 members found this post helpful.
Old 02-02-2010, 12:45 PM   #11
Devilslord
LQ Newbie
 
Registered: Dec 2009
Distribution: Ubuntu 8.04 (Wubi)
Posts: 5

Original Poster
Rep: Reputation: 0
I have Hardy Heron, and your package is for Jaunty Jackalope. Just the same, I've tried and it apparently doesn't work on my system... Thanks, anyway.
 
Old 11-04-2010, 03:59 PM   #12
apogarte
LQ Newbie
 
Registered: Jul 2009
Posts: 20

Rep: Reputation: 1
still manually starting ed2k links on sid

hi**

i've been applying the changes to the "about:config" page of iceweasel
to get ed2k protocole launching amule, and it still is not working...

iceweasel is 3.5.13 runing on kde 4

amule is just installed (with gui and with amule-utils", amule-ed2k is
said not found by apt) so last release

about:config contains for "ed2k" :

network.protocol-handler.app.ed2k : ed2k (or /usr/bin/ed2k same result)
network.protocol-handler.external.ed2k : ed2k (or /usr/bin/ed2k same result)
network.protocol-handler.warn-external.ed2k : true

still answering protocol not associated to any program....???
*

any clue ?


thanks !

Last edited by apogarte; 11-04-2010 at 04:02 PM.
 
Old 11-12-2010, 03:29 AM   #13
maverick5595
LQ Newbie
 
Registered: Nov 2010
Posts: 3

Rep: Reputation: 0
Problem with firefox opening with amule

I am trying to get amule to work with firefox. I have tried the below method but still getting error message like "Firefox doesn't know how to open this address, because the protocol (ed2k) isn't associated with any program."



* Insert about:config in the address bar

* Right click on the list, select New, then Boolean; insert network.protocol-handler.external.ed2k as Preference Name and true as Value

* Now another right click, select New and String; insert network.protocol-handler.app.ed2k as Preference Name and /path/to/ed2k (path to where the file is installed on your system) as Value.

For Ubuntu Lucid users, you should set the Value to just "ed2k" instead of "/usr/bin/ed2k".

For Firefox 3 and higher only, you should also:

* Right click on the list, select New, then Boolean; insert network.protocol-handler.expose.ed2k as Preference Name and false as Value

After that, click over an ed2k link, and Firefox should ask which app you want to use to open the link. Choose /usr/bin/ed2k and it should work.
 
Old 11-13-2010, 03:27 PM   #14
apogarte
LQ Newbie
 
Registered: Jul 2009
Posts: 20

Rep: Reputation: 1
same prob maverick

hello

thank you for your propositions, it is still not working

i've added the line you suggested (network.protocol-handler.expose.ed2k false)with no success, although iceweasel asked me now with what openning, after choosing the /usr/bin.ed2k nothing happened, i switched to the also existing /usr/bin/amule, idem... I click the link, and now that the action is defined, well simply nothing is happening...

thanks anyways...

apog
 
Old 11-13-2010, 03:35 PM   #15
apogarte
LQ Newbie
 
Registered: Jul 2009
Posts: 20

Rep: Reputation: 1
ed2k still

when i put the pointer on an ed2k link here is the result displayed in the bottom bar of iceweasel :
ed2k://|file|Le%20Canard%20enchain%C3%A9%20-%202010.10.27%20-%20Google%20champion%20de%20la%20recherche%20fiscale%20(de%20l'optimisation%20fiscale,%20pour%20ne%2 0pas%20dire%20de%20l'%C3%A9vasion%20fiscale).pdf|605850|6BA39E3712A803A156AEC7EBEE81C4A6|h=5BWHGCGOE V5LKVIYE6TMTYY3XJ4ZUSQX|/

i suppose the %20 are just spaces

still searching...

thanks again...

apog
 
  


Reply

Tags
amule, firefox, mldonkey


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Handling Links with Firefox, Thunderbird, and Gaim apachedude Linux - Software 1 02-11-2005 08:07 AM
Xmule: How to Integrate ED2K Links into different webbrowsers. spchehe Linux - Software 0 08-18-2004 11:09 PM
ed2k:// links in kde3.2 Jelle Linux - Software 0 03-08-2004 12:19 PM
mozilla , flash and ed2k links zspirit Linux - Software 0 10-07-2003 03:28 AM
How do you get xmule 1.6.0 to take ed2k links automatically??? Evilnewbie Linux - Newbie 0 09-17-2003 06:51 AM


All times are GMT -5. The time now is 01:41 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration