LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   dvd -> avi and audio sync (http://www.linuxquestions.org/questions/linux-software-2/dvd-avi-and-audio-sync-621035/)

FunkyRes 02-14-2008 04:35 AM

dvd -> avi and audio sync
 
Hi -

I'm trying to back up all my stargate DVDs to divx.

Right now I'm working on the pilot.
With dvd::rip - the resultive avi file has audio sync problems. In some parts of the film, it seems perfect - but in other parts, the video definitely lags behind the audio.

I went to

http://www.linuxquestions.org/linux/..._to_DVD5_guide

and did the following from that page:

cat *.vob > movie.vob
tcextract -i movie.vob -t vob -x mpeg2 > movie.m2v
tcextract -i movie.vob -a 0 -x ac3 -t vob > movie.ac3

(I did not resize)

mplex -f 8 -o final.mpg movie.m2v movie.ac3

The result - final.mpg - has perfect audio sync.

I'm not sure what is causing the difference when transcoded to avi (using xvid) but somehow - whether it be using the dvd::rip gui or using transcode from the command line - I'd like to make proper avi files with proper audio sync.

The goal is to put a season's worth of avi files onto a DVD-R so I can watch those when I get a stargate craving, rather than my DVDs. But I don't want to be stuck with poor audio sync.

Any tips at all with respect to how to get to avi with proper audio would be greatly appreciated.

Emerson 02-14-2008 08:27 AM

Just back it up into one MPEG-2 file: mplayer dvd://1 -dumpstream -dumpfile rippeddvd.mpg
You can play with mplayer options to strip unneeded audio tracks.

Edit: Didn't read your whole post. I'd recommend using Avidemux2 for transcoding. It will give you full control over sync.

FunkyRes 02-15-2008 08:46 AM

I got it to work - I took the transcode command that dvd::rip was using and changed -M 2 to -M 4 on the command line - it took a lot longer, but the audio matches the lips now.


All times are GMT -5. The time now is 11:38 AM.