LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-18-2001, 02:25 AM   #1
happy hippo
LQ Newbie
 
Registered: May 2001
Posts: 16

Rep: Reputation: 0
Question


Hello,

I've installed Win2000 and red Hat succesfully. But I can't get linux in the boot.ini file.
I boot Linux with the bootdisk and then I get:

[root@cable-XXX-XXX-XXX-XX /root]#

(my internet connection & ip I presume)
I login as root, no problem so far
then the boot configuration file:

dd if=/devhda7 of=/tmp/LiLoBoot.bin bs=512 count=1

I know hda7 is correct, I get:

1+0 records in
1+0 records out

I want to copy the LiloBoot.bin file to a floppy:

mcopy LiloBoot.bin a:

and I get:

bash: mcopy: command not found ????????

Can anybody give me a clear answer how to solve this??

Thanks

 
Old 05-18-2001, 06:53 AM   #2
Dweezil
LQ Newbie
 
Registered: Apr 2001
Posts: 15

Rep: Reputation: 0
Hello!

Use cp instead.

Good luck,
 
Old 05-18-2001, 07:32 AM   #3
jharris
Senior Member
 
Registered: May 2001
Location: Bristol, UK
Distribution: Slackware, Fedora, RHES
Posts: 2,243

Rep: Reputation: 46
Using cp directly won't work. You'll need to mount your floppy first (mount /dev/fd0 /someDir) then use cp (cp LiloBoot.bin /someDir).

I've just posted to http://www.linuxquestions.org/questi...?threadid=2594
if you want more details, a very similar question.

Cheers!

Jamie...
 
Old 05-18-2001, 01:29 PM   #4
Phillip Hess
LQ Newbie
 
Registered: Apr 2001
Location: Vancouver WA
Posts: 10

Rep: Reputation: 0
I just went through this on my machine. I am running a dual hard drive setup I don't what your setup is so if this helps great. Install Windows 2000 on your first drive. Then install Red Hat. When you do it will overwrite the MBR of Windows 2000. This is okay, let Linux start and log in as root. Once there edit the loli.conf file and add the following: other=/dev/hda1
label=Windows_2000
image=/dev/hda

When you boot your machine a linux boot loader screen will open and give the option of booting to linux or windows_2000. If you need more help do a search on the internet for lilo. It's well documented how to do this.
 
Old 05-22-2001, 04:18 PM   #5
happy hippo
LQ Newbie
 
Registered: May 2001
Posts: 16

Original Poster
Rep: Reputation: 0
Well, I got it all installed...I thought.
Red Hat is in the Winboot loader, only when I select it I get a blackscreen with the underscore blinking in the top left of the screen..and that's it.
I haven't got any install problems soooo......??
Any ideas anyone??

Thanks

ps: win2000 runs fine but that's not what I was hoping for.
 
Old 05-22-2001, 05:05 PM   #6
Phillip Hess
LQ Newbie
 
Registered: Apr 2001
Location: Vancouver WA
Posts: 10

Rep: Reputation: 0
The only thing I can think of is check your lilo.conf file. Make sure that it is pointing to the correct location on your drive. Make sure you edit the lilo.conf file as root and run lilo -v before you restart.
 
Old 05-22-2001, 05:07 PM   #7
Phillip Hess
LQ Newbie
 
Registered: Apr 2001
Location: Vancouver WA
Posts: 10

Rep: Reputation: 0
Also unless you can boot from a floppy to get to linux you may need to reinstall Red Hat again before you can edit it.
 
Old 05-23-2001, 07:29 AM   #8
unSpawn
Moderator
 
Registered: May 2001
Posts: 29,354
Blog Entries: 55

Rep: Reputation: 3541Reputation: 3541Reputation: 3541Reputation: 3541Reputation: 3541Reputation: 3541Reputation: 3541Reputation: 3541Reputation: 3541Reputation: 3541Reputation: 3541
u *can* edit linux from within W2K with ExploreFS (if u know what ure doin)...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Dual boot 2000 server (NTFS) & RH7.x Stevelsd Linux - Software 1 12-23-2002 01:32 AM
RH 7 & Win2000 Dual Boot Pimple Linux - Software 6 07-02-2002 10:06 PM
Dual Boot Win2000 & RedHat 7.2 Savedadogs Linux - General 3 03-30-2002 12:30 PM
WinXP & RH7.1 > WinXp &RH7.2 Dual Boot Jondalar Linux - Software 14 01-25-2002 12:47 PM
Dual boot, Win98 & RH7.1 Hachaso Linux - Software 7 05-18-2001 04:59 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Software

All times are GMT -5. The time now is 07:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration