LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 09-27-2001, 12:12 PM   #1
trianon
LQ Newbie
 
Registered: Sep 2001
Location: IL
Distribution: Redhat, Mandrake
Posts: 5

Rep: Reputation: 0
Dual-boot W2K/Redhat


I am trying to setup dual-boot without floppy on following config:
IDE0 master (hda)- Redhat, IDE2,3(AMI MegaRaid 100) RAID0(stripe) - W2K. I can boot from RAID100 no problem, I also can install Redhat with MBR and boot of IDE0 or install LILO to hda1 header and boot into Redhat with floppy. I tried copying hda1 header to use Win2k dualboot, (dd if=/dev/hda1 bs=512 count=1 of=/mnt/floppy/linux.bin - add linux.bin path to boot.ini), but it would not work (selecting LINUX option leads to display "LI" and stop). Kernel 2.4 does not support AMI RAID controller on Iwill KA-266R, so it sees two drives in stripe as separate corrupte drives.
And it seems to me that this would prevent me from dual-booting with LILO. Did anyone try something like this and is there solution, if I don't want to install W2K on IDE0? Thanks!
 
Old 09-27-2001, 03:51 PM   #2
trianon
LQ Newbie
 
Registered: Sep 2001
Location: IL
Distribution: Redhat, Mandrake
Posts: 5

Original Poster
Rep: Reputation: 0
bump? Anyone?
 
Old 09-27-2001, 07:44 PM   #3
trianon
LQ Newbie
 
Registered: Sep 2001
Location: IL
Distribution: Redhat, Mandrake
Posts: 5

Original Poster
Rep: Reputation: 0
Hurray

I got it to work, persistance finally paid off.
I followed dual boot mini-HOW-TO to a point, tried program "bootpart", still no-go.
So I followed http://www.linuxdoc.org/HOWTO/mini/Linux+NT-Loader.html
installed Redhat to IDE0 , the section that talks about copying first 512 bytes of hda1 didn't work for me, but for some reason the this one did:
"Run lilo with a diskette inserted. Now try to boot from the diskette. If your Linux on /dev/hdb1 can't be started, the NT OS loader will also fail to start it. If you see a lot of 01 01 01 01, your root-disk is not accessible. Check whether all your disks are known by the bios. If the floppy boots your Linux partition, you can peel of your boot-sector for the NT OS loader with:

# dd if=/dev/fd0 of=/bootsect.lnx bs=512 count=1

You can keep this diskette as your rescue-diskette just in case your Windows NT installation breaks.

I hope this will help somebody else
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Dual boot question W2K H2O-linux Debian 17 11-25-2005 06:04 AM
Dual-Boot with W2k? Boc_Mage Ubuntu 1 09-04-2005 01:40 AM
Dual boot - need it to default to W2k johngregor Linux - Newbie 4 06-17-2004 10:46 PM
RedHat 9 / W2K Dual Boot system locking up frequently... Very strange... ? pistonhonda Linux - General 3 11-08-2003 12:01 AM
cannot install M8.2 as dual boot with w2k arsenic Linux - Newbie 3 09-16-2002 05:17 PM


All times are GMT -5. The time now is 07:23 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration