LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 07-25-2006, 10:40 AM   #1
wahaha
Member
 
Registered: Jul 2006
Posts: 130

Rep: Reputation: 15
downgrade g++


halo...I am currently using fedora core 4, 2.6.11-1.1369_FC4 of gcc version 4.0.2 20051125 (Red Hat 4.0.2-8).

Due to a software i want to install that required the compiler gcc-2.96, so did anyone know how to downgrade from gcc-4.0.2-8 to gcc-2.96??

Please drop your message here if you have any ideas, thanks!
 
Old 07-25-2006, 02:08 PM   #2
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
No you do not want to do this, it will cause more problems then you are aware of. A better solution is to install the compat-gcc lib rpm packages;

yum -y install compat-gcc compat-libgcc compat-libstdc++
 
Old 07-25-2006, 09:12 PM   #3
wahaha
Member
 
Registered: Jul 2006
Posts: 130

Original Poster
Rep: Reputation: 15
halo Lenard

I did as u suggested on previous message, but it still cannot as the message shown:

[root@localhost kokchin]# yum -y install compat-gcc compat-libgcc compat-libstdc ++
Setting up Install Process
Setting up repositories
updates-released 100% |=========================| 951 B 00:00
extras 100% |=========================| 1.1 kB 00:00
base 100% |=========================| 1.1 kB 00:00
Reading repository metadata in from local files
Parsing package install arguments
No Match for argument: compat-gcc
No Match for argument: compat-libgcc
No Match for argument: compat-libstdc++
Nothing to do


Did you have any ideas about this ?
 
Old 07-25-2006, 09:29 PM   #4
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
You can always try installing the old fashioned way, by loading them from the media or downloading them.

Check if they are installed first; rpm -qa 'compat*' | sort
Example;
$ rpm -qa 'compat*' | sort
compat-db-4.2.52-2
compat-gcc-32-3.2.3-47.3
compat-gcc-32-c++-3.2.3-47.3
compat-glibc-2.3.2-95.30
compat-glibc-headers-2.3.2-95.30
compat-libcom_err-1.0-5
compat-libcom_err-1.0-5
compat-libgcc-296-2.96-132.7.2
compat-libstdc++-296-2.96-132.7.2
compat-libstdc++-33-3.2.3-47.3
compat-libstdc++-33-3.2.3-47.3
compat-readline43-4.3-2

Do not worry about the double rpm package names, I'm running a mixed mode environment.
 
Old 07-25-2006, 09:46 PM   #5
wahaha
Member
 
Registered: Jul 2006
Posts: 130

Original Poster
Rep: Reputation: 15
halo Lenard

Below are the message after i typed it :

rpm -qa 'compat*' | sort
compat-db-4.2.52-2
compat-gcc-32-3.2.3-47.fc4
compat-gcc-32-c++-3.2.3-47.fc4
compat-gcc-32-g77-3.2.3-47.fc4
compat-libf2c-32-3.2.3-47.fc4
compat-libgcc-296-2.96-132.fc4
compat-libstdc++-296-2.96-132.fc4
compat-libstdc++-33-3.2.3-47.fc4
compat-openldap-2.2.23_2.1.30-5
compat-readline43-4.3-2
compat-slang-1.4.5-10


From the above message, there shown one of the sentence "compat-libgcc-296-2.96-132.fc4", is that mean this package is inside my fedora core 4,2.6.11-1.1369_FC4 ??

Or is that you mean have to download those package as shown above ?
 
Old 07-26-2006, 07:32 AM   #6
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Yes, now you need to use these libs to build your app, review the documentation for the application to find out how.

What old app that requires gcc-2.96 are you attempting to build anyway???
 
Old 07-27-2006, 12:16 PM   #7
wahaha
Member
 
Registered: Jul 2006
Posts: 130

Original Poster
Rep: Reputation: 15
I want to install mobile mesh software which are required gcc-2.96 as stated on the link below :
http://wirelessafrica.meraka.org.za/...hp/Mobile_Mesh

May i know those package appears in terminal after i typed "rpm -qa 'compat*' | sort" show that they are inside my fedora core 4 now ??
 
Old 07-27-2006, 07:58 PM   #8
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Yes the rpm packages are installed, which is why you used the command to see if they are installed.

Now you have a problem according to your URL this software is old and not designed for the 2.6 kernel series(which Fedora Core 4 uses), but rather the 2.2 kernel series.

Quoting from the URL;

Requirements
The Mobile Mesh software was developed for a Linux 2.2.X kernel. It's quite possible that it may run under 2.3.X kernels as well, but, the author has not tested this.

This is somewhat old also but should provide you the basic information needed;

http://oob.freeshell.org/nzwireless/LWAP-HOWTO.html
 
Old 07-28-2006, 02:28 AM   #9
wahaha
Member
 
Registered: Jul 2006
Posts: 130

Original Poster
Rep: Reputation: 15
I tried to install mobile mesh software into fedora core 4 becauses there was someone able to install the software into fedora core 2, which the kernel i think is also 2.6.X. and the compiler of fedora core 2 is 2.96 if i am not mistaken with it.

So, I think the major problem now is the compiler version problem when i try to install it but still fail.

I did posted this problem on this link: http://www.linuxquestions.org/questi...d.php?t=462328

If you have any ideas about the problem please leave your message there. Thanks.

Sorry, one more question to ask:
Since the package " compat-libstdc++-296-2.96-132.fc4 " is insde my fedora now after i typed " rpm -qa 'compat*' | sort " in terminal, may i know is that I have to
do any setting to use the compiler gcc-2.96 ??

Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
DOWNgrade gcc. How? KDel Linux - Software 25 10-29-2009 01:53 AM
how to downgrade from 9.2 to 9.1 netsurf Suse/Novell 10 04-10-2005 12:44 PM
Downgrade from current to 9.1? nivek7 Slackware 3 04-14-2004 11:42 PM
kernel downgrade Pleun Linux - Newbie 3 12-16-2003 06:09 AM
Downgrade redhat? redhatnoob Linux - Software 2 12-02-2003 06:37 PM


All times are GMT -5. The time now is 10:50 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration