LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 05-15-2010, 02:52 PM   #1
NewKubuntuGuy
LQ Newbie
 
Registered: Mar 2010
Posts: 14

Rep: Reputation: 1
Double Clicking on Open Office files leads to very slow opening


Has anyone had this problem?

I upgraded from Kubuntu 9.10 to 10.04. It was a fresh install of kubuntu, although I did leave a windows partition on there elsewhere. Grub messed up but I fixed that with a small text edit.

Anyway, when I click on a file, i.e. Open Office writer or Calc, the computer thinks about it for like 60 seconds and then finally Open Office (version 3.2.0)finishes opening the file. It also does this while saving some files. It did not do this this version 9.10 which really amazes me.

I have deleted OOo and reinstalled it several times and nothing helps. All other file handling seems normal, and it is a fast newer computer with a lot of memory.

(please bear with me, I know almost no command line)
 
Old 05-16-2010, 09:06 AM   #2
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,524
Blog Entries: 27

Rep: Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175
It could be caused by slow name resolution for the local system as in this LQ thread. To test, run tcpdump -nnl -i eth0 -s 1536 dst port 53 at a command line (may need to be root or use sudo -- whatever hoops ubuntu is making users jump through to assume rootly powers) and then open an OOo document.
 
1 members found this post helpful.
Old 05-16-2010, 02:43 PM   #3
NewKubuntuGuy
LQ Newbie
 
Registered: Mar 2010
Posts: 14

Original Poster
Rep: Reputation: 1
I have determined it is very slow to start, but if I unplug the ethernet cable it loads fast.

Weird
 
Old 05-17-2010, 12:05 AM   #4
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,524
Blog Entries: 27

Rep: Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175
Quote:
Originally Posted by NewKubuntuGuy View Post
I have determined it is very slow to start, but if I unplug the ethernet cable it loads fast.

Weird
That's progress So it is definitely network related. The tcpdump command above (with the network connected) would give more information about what is happening and will hopefully lead to a solution.
 
1 members found this post helpful.
Old 05-17-2010, 06:27 AM   #5
NewKubuntuGuy
LQ Newbie
 
Registered: Mar 2010
Posts: 14

Original Poster
Rep: Reputation: 1
Thank you Catkin

Why does OOo.org need to access the internet and why is this a new problem since I upgraded from 9.10 to 10.04? It seems like a terrible feature that will put off many new users... Open office was getting better and better and now this which is way above my head.

me@galaxy:~$ sudo tcpdump -nnl -i eth0 -s 1536 dst port 53
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on eth0, link-type EN10MB (Ethernet), capture size 1536 bytes
15:20:56.441074 IP 10.6.4.67.33208 > 79.173.80.17.53: 46450+ A? galaxy.(none). (31)
15:21:01.446119 IP 10.6.4.67.34026 > 212.58.194.17.53: 46450+ A? galaxy.(none). (31)
15:21:06.448097 IP 10.6.4.67.33208 > 79.173.80.17.53: 46450+ A? galaxy.(none). (31)
15:21:11.451968 IP 10.6.4.67.34026 > 212.58.194.17.53: 46450+ A? galaxy.(none). (31)
15:21:16.454174 IP 10.6.4.67.44831 > 79.173.80.17.53: 42780+ A? galaxy.(none).gtn.ru. (38)
15:21:21.459447 IP 10.6.4.67.38844 > 212.58.194.17.53: 42780+ A? galaxy.(none).gtn.ru. (38)
15:21:26.463775 IP 10.6.4.67.44831 > 79.173.80.17.53: 42780+ A? galaxy.(none).gtn.ru. (38)
15:21:31.469038 IP 10.6.4.67.38844 > 212.58.194.17.53: 42780+ A? galaxy.(none).gtn.ru. (38)
^C
8 packets captured
8 packets received by filter
0 packets dropped by kernel
me@galaxy:~$
 
Old 05-17-2010, 08:43 AM   #6
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,524
Blog Entries: 27

Rep: Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175
Quote:
Originally Posted by NewKubuntuGuy View Post
Why does OOo.org need to access the internet and why is this a new problem since I upgraded from 9.10 to 10.04? It seems like a terrible feature that will put off many new users... Open office was getting better and better and now this which is way above my head.
"Why" I cannot answer but "what" is that OOo is trying to resolve the local hostname, galaxy, to an IP address. You may be able to let it do so quickly by adding galaxy to the /etc/hosts file. Here's mine for local hostname CW8
Code:
192.168.1.47            CW8.localdomain CW8
 
1 members found this post helpful.
Old 05-17-2010, 09:37 AM   #7
NewKubuntuGuy
LQ Newbie
 
Registered: Mar 2010
Posts: 14

Original Poster
Rep: Reputation: 1
see below

Last edited by NewKubuntuGuy; 05-17-2010 at 10:07 AM.
 
Old 05-17-2010, 10:02 AM   #8
NewKubuntuGuy
LQ Newbie
 
Registered: Mar 2010
Posts: 14

Original Poster
Rep: Reputation: 1
Solved

OK, it is solved, but I am really confused why 10.04 and or OOo made this so difficult. Checking the DNS seems extremely stupid for an office app for basic everyday use.

1) use Alt-F2 and then typed kdesu kate
2) OPEN /etc/hosts
3) notice the old entry:
127.0.0.1 localhost
127.0.1.1 galaxy
4) and add a line so it looks like this:
127.0.0.1 localhost
127.0.1.1 galaxy
127.0.0.1 galaxy localhost galaxy.(none)
5) save
6 now OpenOffice.org Writer and Calc open fast when the network connection is attached.

For anyone new reading this. replace "galaxy" with whatever you have named your computer.

I sincerely hope this helps someone else. I don't understand this bug. It may be that there is a disconnect between the developers working on the Kubuntu IP specs and the OpenOffice developers?

Thank you for Catkin for your help. I even learned about Alt-F2 kdesu !

Last edited by NewKubuntuGuy; 05-17-2010 at 10:07 AM.
 
1 members found this post helpful.
Old 05-17-2010, 03:23 PM   #9
jefro
Guru
 
Registered: Mar 2008
Posts: 10,982

Rep: Reputation: 1354Reputation: 1354Reputation: 1354Reputation: 1354Reputation: 1354Reputation: 1354Reputation: 1354Reputation: 1354Reputation: 1354Reputation: 1354
Thanks for that.

Guess we can assume OO is going web.
 
Old 05-17-2010, 11:57 PM   #10
catkin
LQ 5k Club
 
Registered: Dec 2008
Location: Tamil Nadu, India
Distribution: Servers: Debian Squeeze and Wheezy. Desktop: Slackware64 14.0. Netbook: Slackware 13.37
Posts: 8,524
Blog Entries: 27

Rep: Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175Reputation: 1175
Quote:
Originally Posted by NewKubuntuGuy View Post
It may be that there is a disconnect between the developers working on the Kubuntu IP specs and the OpenOffice developers?
Glad you found a solution

I had the same problem on my Slackware system so chances are it's an OOo thing, nothing to do with kubuntu. I share your view that there seems little point in an office suite resolving its hostname to an IP address especially as one of the poor usability features of OOo compared with similar products is the long time taken to open documents (especially the first).

Threads can be marked SOLVED via the Thread Tools menu.
 
Old 05-19-2010, 07:38 AM   #11
NewKubuntuGuy
LQ Newbie
 
Registered: Mar 2010
Posts: 14

Original Poster
Rep: Reputation: 1
Quote:
Originally Posted by catkin View Post
Glad you found a solution


Threads can be marked SOLVED via the Thread Tools menu.
DONE
 
Old 06-19-2010, 05:57 AM   #12
tugger
LQ Newbie
 
Registered: Jul 2006
Posts: 1

Rep: Reputation: 0
Thumbs up Thanks.

Thanks, it really makes a world (maybe two) of difference.
 
Old 02-06-2011, 09:43 PM   #13
tractor
LQ Newbie
 
Registered: Mar 2009
Posts: 12

Rep: Reputation: 1
Works well in Ubuntu also.

This is a wonderful fix for the problem. LibreOffice seemed a little slower than OpenOffice to open when the final 3.3 came out, but the last few days it has been terribly slow. With this fix it now opens in about a second!!!!!!!!!! Thank you so much.
 
Old 05-16-2011, 08:29 AM   #14
enid
Member
 
Registered: May 2009
Posts: 40

Rep: Reputation: 2
I had this problem too, in LibreOffice 3.3.2 on Ubuntu 11.04, (after doing a dist-upgrade) and I solved my problem by adding my 127.0.0.1 <hostname> on /etc/hosts which I was missing, just like above.

And now it openes very quickly.

Thank you all.
 
Old 09-30-2011, 10:34 AM   #15
Woodsman
Senior Member
 
Registered: Oct 2005
Distribution: Slackware 14.0
Posts: 3,470

Rep: Reputation: 519Reputation: 519Reputation: 519Reputation: 519Reputation: 519Reputation: 519
I ran into this bug yesterday when my ISP connection was interrupted during a storm. Suddenly LibreOffice (3.4.3) seemed not to start, but eventually I discovered there was a long delay with starting. I discovered that LibreOffice was trying to resolve the host name of my computer.

My hosts file has always had a 127.0.0.1 localhost localhost.localdomain entry. Yet LibreOffice is trying to resolve to the specific host name rather than localhost with a hard-coded domain name of (none).

As mentioned previously, a new entry in my hosts files solved the problem.

I don't see any need for this name resolution business. Further, without that information in the hosts file, the name resolution process means using an external domain name server to help resolve the local host name. That is a security concern because the computer name gets registered at the domain name server that was used.

Strangely, there is almost no information on the web about this peculiar behavior.

If this behavior is not a bug but a "feature," then there should be a way to disable this behavior. Why does LibreOffice need to resolve the host name? I don't have a copy of the source code to perform a cursory inspection of where this behavior takes place or why. Perhaps somebody with the source code can add to this thread with that information.

I'm looking into filing a bug report and appreciate any further information.
 
  


Reply

Tags
doubleclick, kde, kubuntu, openoffice.org


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Opening Office 2007 files in Openoffice mganesh30 Linux - Newbie 10 07-19-2009 08:21 AM
Cant open .dat files (video) by double clicking though I can open it by openwith.. ravi_npatty Linux - Newbie 17 07-31-2007 08:19 PM
opening open office hari78 Linux - Software 2 03-10-2005 09:14 AM
mozilla not opening on double clicking..? metoome Linux - Newbie 1 03-11-2004 06:37 PM
Opening MS Publisher files in Open Office bigredmed Linux - Software 1 10-25-2003 06:48 PM


All times are GMT -5. The time now is 07:15 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration