LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Double Clicking on Open Office files leads to very slow opening (http://www.linuxquestions.org/questions/linux-software-2/double-clicking-on-open-office-files-leads-to-very-slow-opening-808048/)

NewKubuntuGuy 05-15-2010 03:52 PM

Double Clicking on Open Office files leads to very slow opening
 
Has anyone had this problem?

I upgraded from Kubuntu 9.10 to 10.04. It was a fresh install of kubuntu, although I did leave a windows partition on there elsewhere. Grub messed up but I fixed that with a small text edit.

Anyway, when I click on a file, i.e. Open Office writer or Calc, the computer thinks about it for like 60 seconds and then finally Open Office (version 3.2.0)finishes opening the file. It also does this while saving some files. It did not do this this version 9.10 which really amazes me.

I have deleted OOo and reinstalled it several times and nothing helps. All other file handling seems normal, and it is a fast newer computer with a lot of memory.

(please bear with me, I know almost no command line)

catkin 05-16-2010 10:06 AM

It could be caused by slow name resolution for the local system as in this LQ thread. To test, run tcpdump -nnl -i eth0 -s 1536 dst port 53 at a command line (may need to be root or use sudo -- whatever hoops ubuntu is making users jump through to assume rootly powers) and then open an OOo document.

NewKubuntuGuy 05-16-2010 03:43 PM

I have determined it is very slow to start, but if I unplug the ethernet cable it loads fast.

Weird

catkin 05-17-2010 01:05 AM

Quote:

Originally Posted by NewKubuntuGuy (Post 3970719)
I have determined it is very slow to start, but if I unplug the ethernet cable it loads fast.

Weird

That's progress :) So it is definitely network related. The tcpdump command above (with the network connected) would give more information about what is happening and will hopefully lead to a solution.

NewKubuntuGuy 05-17-2010 07:27 AM

Thank you Catkin

Why does OOo.org need to access the internet and why is this a new problem since I upgraded from 9.10 to 10.04? It seems like a terrible feature that will put off many new users... Open office was getting better and better and now this which is way above my head.

me@galaxy:~$ sudo tcpdump -nnl -i eth0 -s 1536 dst port 53
tcpdump: verbose output suppressed, use -v or -vv for full protocol decode
listening on eth0, link-type EN10MB (Ethernet), capture size 1536 bytes
15:20:56.441074 IP 10.6.4.67.33208 > 79.173.80.17.53: 46450+ A? galaxy.(none). (31)
15:21:01.446119 IP 10.6.4.67.34026 > 212.58.194.17.53: 46450+ A? galaxy.(none). (31)
15:21:06.448097 IP 10.6.4.67.33208 > 79.173.80.17.53: 46450+ A? galaxy.(none). (31)
15:21:11.451968 IP 10.6.4.67.34026 > 212.58.194.17.53: 46450+ A? galaxy.(none). (31)
15:21:16.454174 IP 10.6.4.67.44831 > 79.173.80.17.53: 42780+ A? galaxy.(none).gtn.ru. (38)
15:21:21.459447 IP 10.6.4.67.38844 > 212.58.194.17.53: 42780+ A? galaxy.(none).gtn.ru. (38)
15:21:26.463775 IP 10.6.4.67.44831 > 79.173.80.17.53: 42780+ A? galaxy.(none).gtn.ru. (38)
15:21:31.469038 IP 10.6.4.67.38844 > 212.58.194.17.53: 42780+ A? galaxy.(none).gtn.ru. (38)
^C
8 packets captured
8 packets received by filter
0 packets dropped by kernel
me@galaxy:~$

catkin 05-17-2010 09:43 AM

Quote:

Originally Posted by NewKubuntuGuy (Post 3971296)
Why does OOo.org need to access the internet and why is this a new problem since I upgraded from 9.10 to 10.04? It seems like a terrible feature that will put off many new users... Open office was getting better and better and now this which is way above my head.

"Why" I cannot answer but "what" is that OOo is trying to resolve the local hostname, galaxy, to an IP address. You may be able to let it do so quickly by adding galaxy to the /etc/hosts file. Here's mine for local hostname CW8
Code:

192.168.1.47            CW8.localdomain CW8

NewKubuntuGuy 05-17-2010 10:37 AM

see below

NewKubuntuGuy 05-17-2010 11:02 AM

Solved
 
OK, it is solved, but I am really confused why 10.04 and or OOo made this so difficult. Checking the DNS seems extremely stupid for an office app for basic everyday use.

1) use Alt-F2 and then typed kdesu kate
2) OPEN /etc/hosts
3) notice the old entry:
127.0.0.1 localhost
127.0.1.1 galaxy
4) and add a line so it looks like this:
127.0.0.1 localhost
127.0.1.1 galaxy
127.0.0.1 galaxy localhost galaxy.(none)
5) save
6 now OpenOffice.org Writer and Calc open fast when the network connection is attached.

For anyone new reading this. replace "galaxy" with whatever you have named your computer.

I sincerely hope this helps someone else. I don't understand this bug. It may be that there is a disconnect between the developers working on the Kubuntu IP specs and the OpenOffice developers?

Thank you for Catkin for your help. I even learned about Alt-F2 kdesu !

jefro 05-17-2010 04:23 PM

Thanks for that.

Guess we can assume OO is going web.

catkin 05-18-2010 12:57 AM

Quote:

Originally Posted by NewKubuntuGuy (Post 3971517)
It may be that there is a disconnect between the developers working on the Kubuntu IP specs and the OpenOffice developers?

Glad you found a solution :)

I had the same problem on my Slackware system so chances are it's an OOo thing, nothing to do with kubuntu. I share your view that there seems little point in an office suite resolving its hostname to an IP address especially as one of the poor usability features of OOo compared with similar products is the long time taken to open documents (especially the first).

Threads can be marked SOLVED via the Thread Tools menu.

NewKubuntuGuy 05-19-2010 08:38 AM

Quote:

Originally Posted by catkin (Post 3972299)
Glad you found a solution :)


Threads can be marked SOLVED via the Thread Tools menu.

DONE

tugger 06-19-2010 06:57 AM

Thanks.
 
Thanks, it really makes a world (maybe two) of difference.

tractor 02-06-2011 10:43 PM

Works well in Ubuntu also.
 
This is a wonderful fix for the problem. LibreOffice seemed a little slower than OpenOffice to open when the final 3.3 came out, but the last few days it has been terribly slow. With this fix it now opens in about a second!!!!!!!!!! Thank you so much.

enid 05-16-2011 09:29 AM

I had this problem too, in LibreOffice 3.3.2 on Ubuntu 11.04, (after doing a dist-upgrade) and I solved my problem by adding my 127.0.0.1 <hostname> on /etc/hosts which I was missing, just like above.

And now it openes very quickly. :cool:

Thank you all.

Woodsman 09-30-2011 11:34 AM

I ran into this bug yesterday when my ISP connection was interrupted during a storm. Suddenly LibreOffice (3.4.3) seemed not to start, but eventually I discovered there was a long delay with starting. I discovered that LibreOffice was trying to resolve the host name of my computer.

My hosts file has always had a 127.0.0.1 localhost localhost.localdomain entry. Yet LibreOffice is trying to resolve to the specific host name rather than localhost with a hard-coded domain name of (none).

As mentioned previously, a new entry in my hosts files solved the problem.

I don't see any need for this name resolution business. Further, without that information in the hosts file, the name resolution process means using an external domain name server to help resolve the local host name. That is a security concern because the computer name gets registered at the domain name server that was used.

Strangely, there is almost no information on the web about this peculiar behavior.

If this behavior is not a bug but a "feature," then there should be a way to disable this behavior. Why does LibreOffice need to resolve the host name? I don't have a copy of the source code to perform a cursory inspection of where this behavior takes place or why. Perhaps somebody with the source code can add to this thread with that information.

I'm looking into filing a bug report and appreciate any further information.


All times are GMT -5. The time now is 07:12 PM.