LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 11-13-2003, 08:51 AM   #1
falcon56215
Member
 
Registered: Jan 2002
Location: Tennessee
Distribution: Xubuntu Natty on Lenovo R61i Thinkpad
Posts: 108

Rep: Reputation: 16
Does a Rage Mobility Graphics Card support DRI?


I have been unable to get the Direct Rendering Interface to work. I have made the appropriate changes to XF86Config-4 to enable dri. When I run xdpyinfo as root, I can see extensions for GLX, SGI-GLX, but not for XFree86-DRI. And i get

Xlib: extension "XFree86-DRI" missing on display ":0.0".

when I try to run glxgears. It runs, just slow, like 100 FPS.

Does anyone know if a Mobility Card supports Direct Rendering?
 
Old 11-13-2003, 02:31 PM   #2
tricky_linux
Member
 
Registered: Jul 2003
Distribution: Red Hat Linux 9.0; Old and Solid
Posts: 674

Rep: Reputation: 30
tell you what, go to http://www.schneider-digital.de/html...nload_ati.html to download the driver for you XFree86. which was version 3.2.8
then install it using
rpm -i --force <*.rpm>
fglrxconfig
during fglrxconfig's process it will ask you do you want to internal or external agp, then you must say external.
or N
then add /sbin/modprobe agpgart; /sbin/modprobe fglrx; to your /etc/rc.local file
then you should get glxgears runs at around 3000 fps.
 
Old 11-13-2003, 11:20 PM   #3
falcon56215
Member
 
Registered: Jan 2002
Location: Tennessee
Distribution: Xubuntu Natty on Lenovo R61i Thinkpad
Posts: 108

Original Poster
Rep: Reputation: 16
Will this work for a Rage Mobility-C card in a Laptop? I don't see any mention of Rage Mobility for supported cards..?
 
Old 11-14-2003, 11:44 AM   #4
tricky_linux
Member
 
Registered: Jul 2003
Distribution: Red Hat Linux 9.0; Old and Solid
Posts: 674

Rep: Reputation: 30
That's correct.
ON ati.com, they didn't say nothing about supporting your card at all. However, by the fact that ATI's hardwares were almost alike. SO, there is no trouble of getting your card working.
It still don't believe it. Then just gave it a try to see what the system says.
But what driver are using right now?
VESA or r128?
If you want to me to make sure that it will work, tell me what kind chipset do you have for your motherboard and you video card.
 
Old 11-15-2003, 01:11 PM   #5
falcon56215
Member
 
Registered: Jan 2002
Location: Tennessee
Distribution: Xubuntu Natty on Lenovo R61i Thinkpad
Posts: 108

Original Poster
Rep: Reputation: 16
Here are the contents from my XF86Config-4 File:

# File generated by XFdrake.

# **********************************************************************
# Refer to the XF86Config man page for details about the format of
# this file.
# **********************************************************************

Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
Option "XkbCompat" ""
Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/usbmouse"
Option "ZAxisMapping" "6 7"
Option "Buttons" "7"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Generic"
ModelName "1024x768 @ 70 Hz"
HorizSync 31.5-57.0
VertRefresh 50-70

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
VendorName "ATI"
BoardName "ATI Rage Mobility"
Driver "ati"
Option "DPMS"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubsection

Subsection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubsection

Subsection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubsection

Subsection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1"
EndSection

My manual gives this info about the Graphics Card:

*********

Video Controller:

ATI Mobility-C graphics controller, 64-bit data bus width; BitBLT hardware; AGP, Alpha-blending, Direct3D and OpenGL support, 4 MB external video memory.

*********

So I use the FireGL driver on my Mobility Card? I tried before and everything seemed to work, except when I ran fglrx, I got a message saying something about the kernel being tainted, and then it said it couldn't find the device ( presumably the FireGL graphics card? ), and it would not load the fglrx module.

Ideas?
 
Old 11-15-2003, 01:59 PM   #6
tricky_linux
Member
 
Registered: Jul 2003
Distribution: Red Hat Linux 9.0; Old and Solid
Posts: 674

Rep: Reputation: 30
I see that you wasn't using fglrxconfig's Xfree86Config at all.
Do head using fglrxconfig to creat a good XFree86Config and use external agpgart.
then add "/sbin/modprobe agpgart" and /sbin/modprobe fglrx" to your rc.local under /etc/

That'll help you get dri and 3d acceleration.
To see what it says
 
Old 11-16-2003, 12:22 AM   #7
falcon56215
Member
 
Registered: Jan 2002
Location: Tennessee
Distribution: Xubuntu Natty on Lenovo R61i Thinkpad
Posts: 108

Original Poster
Rep: Reputation: 16
When I compile the modules for fglrx, everything seems to go smoothly. Then when I switch directories as directed and run ./make_install.sh, I get the following output:

fglrx]# ./make_install.sh
- creating symlink
- recreating module dependency list
- trying a sample load of the kernel module
Warning: loading /lib/modules/2.4.21-0.13mdk/kernel/drivers/char/drm/fglrx.o will taint the kernel: non-GPL license - Proprietary. (C) 2002 - ATI Technologies, Starnberg, GERMANY
See http://www.tux.org/lkml/#export-tainted for information about tainted modules
/lib/modules/2.4.21-0.13mdk/kernel/drivers/char/drm/fglrx.o: init_module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
modprobe: insmod /lib/modules/2.4.21-0.13mdk/kernel/drivers/char/drm/fglrx.o failed
modprobe: insmod fglrx failed
failed.

When performing fglrxconfig, I get the following output at the end:

Probing PCI bus for a supported graphics device...
unable to find any of the subsequent graphics boards:

- ATI Radeon 8500 / 9100
- ATI FireGL 8700 / 8800
- ATI FireGL E1
- ATI FireGL T2
- ATI Radeon 9000
- ATI Radeon 9200
- ATI Radeon 9500
- ATI Radeon 9600
- ATI Radeon 9700
- ATI Radeon 9800
- ATI FireGL Z1 / X1 / X2
- ATI Mobility M9
- ATI Mobility FireGL 9000
- ATI Mobility M9PLUS

When starting X11 then auto-detection will take place.

If you want forced binding to a specific PCI bus slot at a later time
then you have to edit the fglrx-BusID entry in your XF86Config-4 file.

Press [Enter] to continue, press 'q'&[Enter] or [Ctrl]+'c' to abort.

??

Last edited by falcon56215; 11-16-2003 at 06:26 AM.
 
Old 11-16-2003, 04:57 PM   #8
tricky_linux
Member
 
Registered: Jul 2003
Distribution: Red Hat Linux 9.0; Old and Solid
Posts: 674

Rep: Reputation: 30
please post the output of "lspci"
 
Old 11-16-2003, 07:59 PM   #9
falcon56215
Member
 
Registered: Jan 2002
Location: Tennessee
Distribution: Xubuntu Natty on Lenovo R61i Thinkpad
Posts: 108

Original Poster
Rep: Reputation: 16
00:00.0 Host bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX Host bridge (rev 03)
00:01.0 PCI bridge: Intel Corp. 440BX/ZX/DX - 82443BX/ZX/DX AGP bridge (rev 03)
00:04.0 CardBus bridge: Texas Instruments PCI1420
00:04.1 CardBus bridge: Texas Instruments PCI1420
00:07.0 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ISA (rev 02)
00:07.1 IDE interface: Intel Corp. 82371AB/EB/MB PIIX4 IDE (rev 01)
00:07.2 USB Controller: Intel Corp. 82371AB/EB/MB PIIX4 USB (rev 01)
00:07.3 Bridge: Intel Corp. 82371AB/EB/MB PIIX4 ACPI (rev 03)
00:08.0 Multimedia audio controller: Cirrus Logic Crystal CS4281 PCI Audio (rev 01)
00:10.0 Communication controller: Lucent Microelectronics LT WinModem
01:00.0 VGA compatible controller: ATI Technologies Inc Rage Mobility P/M AGP 2x (rev 64)
 
Old 11-16-2003, 09:48 PM   #10
tricky_linux
Member
 
Registered: Jul 2003
Distribution: Red Hat Linux 9.0; Old and Solid
Posts: 674

Rep: Reputation: 30
Somebody on other forum said something about a driver at www.sourceforge.org.
Just do a search, but probably doesn't support your card in 3d. I have an laptop with Rage Mobiel 4. but still i got to use r128.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
No 3D acceleration on ATI Rage Mobility P/M 2x shortname Linux - Hardware 3 01-28-2006 05:08 AM
ATI Rage Mobility M1 TV OUT Parcye Linux - Hardware 1 11-17-2005 03:11 PM
Cannot get Crisp Display on Laptop with ATi Mobility Radeon 9700 128 MB Graphics card vishalchavda Linux - Hardware 3 06-04-2005 11:18 AM
Cannot get Crisp Display on Laptop with ATi Mobility Radeon 9700 128 MB Graphics card vishalchavda Linux - Laptop and Netbook 3 06-03-2005 02:02 PM
Rage Mobility M3 Resolution Problems? corfe Linux - Laptop and Netbook 2 03-20-2005 06:40 PM


All times are GMT -5. The time now is 08:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration