LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   DNS Zone Records - MX Records (http://www.linuxquestions.org/questions/linux-software-2/dns-zone-records-mx-records-556355/)

ddzc 05-24-2007 09:30 AM

DNS Zone Records - MX Records
 
Hello all,

Is this the correct formation on how to add MX record to a dns zone file.


;linuxquestions.org. IN MX 10 mail.linuxquestions.org.


Thanks

routers 05-24-2007 11:22 AM

Code:

@              IN MX  10      mail
Code:

mail          IN A    64.179.4.148

------------

hope this right for mail.linuxquestions.org/zone file

FMC 05-24-2007 11:52 AM

Do not setup your MX record to an IP address, change if for a hostname.

Take a look at http://www.dnsstuff.com/ to be sure you setted up everything correctly!

[]īs, FMC!

ddzc 05-24-2007 12:02 PM

thanks

i'm concerned about this part ;linuxquestions.org.

Is the ; normal before the hostname along with the perod after org?

thanks

FMC 05-24-2007 12:06 PM

Quote:

Originally Posted by ddzc
thanks

i'm concerned about this part ;linuxquestions.org.

Is the ; normal before the hostname along with the perod after org?

thanks

A line starting with ";" is a comment in bind.

The "." after "linuxquestion.org" is correct. When you put an IP address you do not put the dot, but with a hostname you have to put the dot!

[]īs, FMC!

ddzc 05-24-2007 12:39 PM

what do you mean by a comment in bind

FMC 05-24-2007 01:42 PM

Quote:

Originally Posted by ddzc
what do you mean by a comment in bind

A line that is commented, ignored by bind when it reads the file.

Sorry, my english is terrible!

[]īs, FMC!

ddzc 05-24-2007 01:55 PM

Thats what I thought at first, thank you.

If I want to enable that line, do I just remove the ; or do I have to remove the ; and insert the @ symbol?

Thanks

FMC 05-24-2007 02:26 PM

Quote:

Originally Posted by ddzc
Thats what I thought at first, thank you.

If I want to enable that line, do I just remove the ; or do I have to remove the ; and insert the @ symbol?

Thanks

Just remove the ";" and reload zones (usualy: /etc/init.d/bind reload)

[]īs, FMC!


All times are GMT -5. The time now is 07:25 AM.