LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 06-11-2007, 10:11 PM   #1
srikrishna
LQ Newbie
 
Registered: Jun 2007
Posts: 1

Rep: Reputation: 0
DLINK DWL-G122 REV B - openSuSE 10.2


I'm trying to configure a DLink-DWL-G122 Rev(B) USB wireless card with a Toshiba Laptop.

I've installed the rt2570-cvs-2007060620 driver and the LED next to Link is on.

When I run iwlist wlan0 scan it shows the following output

wlan0 Scan completed :
Cell 01 - Address: 00:14:BF:F3:40:EA
ESSID:"WLAN"
Mode:Master
Frequency:2.437 GHz
Encryption keyff
Extra:tsf=00000012f150f8c4

ifconfig -a shows the following output

wlan0 Link encap:Ethernet HWaddr 00:11:95:FB:5C:B6
inet6 addr: fe80::211:95ff:fefb:5cb6/64 Scope:Link
UP RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:28 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:0 (0.0 b) TX bytes:10880 (10.6 Kb)
Base address:0x4000

ifconfig wlan0 up or iwconfig wlan0 essid WLAN commands run smoothly and looks like they are bringing up the wireless card as expected.

Even though it looks like my wireless card is configured correctly, I'm still unable to browse internet.

Any ideas?

Thanks
Srikrishna Kalavacharla
 
Old 08-20-2007, 06:46 PM   #2
dissident_goodchild
Member
 
Registered: Feb 2007
Location: Spain
Distribution: OPENSUSE 10.3 64-BIT WITH GNOME
Posts: 229

Rep: Reputation: 30
You continue with the problem?

You don't have an IP. E.g. ifconfig:

Code:
Link encap:Ethernet  HWaddr 00:15:E9:F8:FD:83  
inet addr:192.168.0.11  Bcast:192.168.0.255  Mask:255.255.255.0
inet6 addr: fe80::215:e9ff:fef8:fd83/64 Scope:Link
UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
RX packets:53692 errors:0 dropped:0 overruns:0 frame:0
TX packets:10751 errors:0 dropped:1 overruns:0 carrier:0
collisions:0 txqueuelen:1000 
RX bytes:9166514 (8.7 MiB)  TX bytes:1387410 (1.3 MiB)
Throws iwconfig and something should give you seemed to this:

Code:
RT73 WLAN  ESSID:"MySSID"  Nickname:""
Mode:Managed  Frequency=2.422 GHz  Access Point: 00:18:F3:9A:3D:D9   
Bit Rate=18 Mb/s   
RTS thr:off   Fragment thr:off
Link Quality=63/100  Signal level:-76 dBm  Noise level:-115 dBm
Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
Tx excessive retries:0  Invalid misc:0   Missed beacon:0
You should revise if assign an IP and the DNS charged to be able to surf the net.

Last edited by dissident_goodchild; 08-20-2007 at 06:51 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
openSUSE 10.2 w/ D-Link DWL G122 Rev.B - Cannot use network although connected Kronoz Linux - Wireless Networking 11 03-21-2008 04:28 PM
dlink DWL-G122 A2 sk8trf Linux - Wireless Networking 2 05-14-2007 07:50 AM
Dwl G122 Rev C linuxn00ber Linux - Wireless Networking 23 12-03-2006 04:55 PM
D-Link DWL-G122 Rev D1 on Fedora Core 5 deesto Linux - Wireless Networking 0 09-07-2006 08:31 PM
FC 4 + DWL-G122 Rev. A1 question cyyz Linux - Wireless Networking 1 01-17-2006 08:07 PM


All times are GMT -5. The time now is 04:25 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration