LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 12-14-2003, 04:14 PM   #1
The_fuzzy_cow
Member
 
Registered: Oct 2003
Location: Fidalgo Island
Distribution: SuSe 9.2 x86_64
Posts: 35

Rep: Reputation: 15
Divx Ripping: "MP3 Support" in MPlayer error from AcidRip


Hey y'all linux peoples.

I'm trying to get a program that will rip & encode dvds to Xvid or Divx. I looked around and decided that AcidRip looked good. AcidRip, if you don't know, is simply a frontend GUI for Mencoder. For that reason I think that MPlayer (the bace program that comes w/ Mencoder) is likly the problem.
Here it is... the problem!!! I installed LAME and compiled MPlayer. All of it looked good. Next when I compiled AcidRip and tried to run it, it gives me a error. The error says that MPlayer does not have MP3 support, and AcidRip needs it.
Ok, so what's up? why does MPlayer (and Mencoder) have no MP3 support? or why does AcidRip think it doesn't?

If ya have no idea, that's cool too. But if ya have names or links to other Xvid or Divx rippers I'd like it if ya tell me,so I could basically bypass this problem.

Thank you,
Phillip
 
Old 12-14-2003, 04:27 PM   #2
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,176
Blog Entries: 4

Rep: Reputation: 430Reputation: 430Reputation: 430Reputation: 430Reputation: 430
On the MPlayer homepage there are links to the encoders to be installed. It may be that you just need to add the encoder. It is a pretty simple task (I have done it ), in fact I just grabbed all of them and made MPlayer the only player needed on my system.
 
Old 12-14-2003, 04:30 PM   #3
fancypiper
Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
# Mandrake links
Mandrake home page
Mandrake Users website
Easy urpmi config for Mandrake
urpmi mini-HOWTO
All You Ever Wanted to Know About Urpmi But Never Dared Asking Before
Easy software management: Red Carpet
Maximum RPM
rpmfind
You didn't install the developmental packages? As root, command:
urpmi gcc
An Introduction to the Midnight Commander. You can install it by commanding:
urpmi mc
Midnight Commander home page

Last edited by fancypiper; 12-15-2003 at 12:05 AM.
 
Old 12-14-2003, 11:04 PM   #4
The_fuzzy_cow
Member
 
Registered: Oct 2003
Location: Fidalgo Island
Distribution: SuSe 9.2 x86_64
Posts: 35

Original Poster
Rep: Reputation: 15
Okey dokey. XavierP, I _think_ I already installed them. But It won't even play mp3s
fancypiper, I'm on MDK 9. I need to change my profile. NTL the link is dead.
 
Old 12-15-2003, 06:00 AM   #5
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,176
Blog Entries: 4

Rep: Reputation: 430Reputation: 430Reputation: 430Reputation: 430Reputation: 430
I forget where the encoder are installed - but you should end up with a list of about 20.

Is there anything on the Acidrip website about this?
 
Old 12-15-2003, 03:58 PM   #6
The_fuzzy_cow
Member
 
Registered: Oct 2003
Location: Fidalgo Island
Distribution: SuSe 9.2 x86_64
Posts: 35

Original Poster
Rep: Reputation: 15
Ok. I've found some errors (yey!). When I try to play a mp3 file in MPlayer, it says that is can't load codec.inf then it _tries_ to use the built-in codecs. then It plays, but no sound is emitted. Hope that helped!

-Phillip
 
Old 12-16-2003, 03:10 PM   #7
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,176
Blog Entries: 4

Rep: Reputation: 430Reputation: 430Reputation: 430Reputation: 430Reputation: 430
Oooookay - it sounds as if either it can't find the codec or that the codec is not working. When you say that codec.inf can't be loaded, is that the full message? Could you copy and paste the full message for us.

In a console (I assume you are using the GUI) could you type in gmplayer and then post any errors. Or type in 'mplayer <filename.mp3>' and let us know the results.

Thanks
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
error: "cannot find libjpeg support" Lokathor Debian 3 11-04-2005 07:12 PM
add "Artist" and "Album Title" to mp3 files powah Linux - Software 2 04-05-2005 04:04 AM
Mplayer (PLF) install gives me "Signature Verfication Error" john_walsh54 Mandriva 16 09-21-2003 05:11 AM
Mplayer (PLF) install gives me "Signature Verfication Error" john_walsh54 Linux - Software 1 09-09-2003 10:54 AM
i just finished typing "./configure" and "make" in mplayer directory... kublador Linux - General 4 02-22-2003 04:12 PM


All times are GMT -5. The time now is 10:05 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration