LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Display Settings (http://www.linuxquestions.org/questions/linux-software-2/display-settings-17898/)

admanis 04-06-2002 07:59 PM

Display Settings
 
OK, I am just getting into Linux but I can't seem to, I have uploaded it to my second hard drive but the display is wrong! with windows I can specify 800 x 600 or 1024 x768 pixels, in linux i seem to be restricted to 640 x480, how do i change this using KDE or Gnome?

Aussie 04-06-2002 11:00 PM

You can edit the modes in the screen section of your XFree86 config, for XFree86-3.x.x edit /etc/X11/XF86Config and for XFree86-4.x.x edit /etc/X11/XF86config-4. The modes are read from left to right so put the prefered mode first. Here is mine for comparison,
Code:

# **********************************************************************
# Screen sections
# **********************************************************************

# Any number of screen sections may be present.  Each describes
# the configuration of a single screen.  A single specific screen section
# may be specified from the X server command line with the "-screen"
# option.
Section "Screen"
    Identifier  "Screen 1"
    Device      "NVIDIA GeForce"
    Monitor    "My Monitor"
    DefaultDepth 24

    Subsection "Display"
        Depth      8
        Modes      "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth      16
        Modes      "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
    Subsection "Display"
        Depth      24
        Modes      "1024x768" "800x600" "640x480"
        ViewPort    0 0
    EndSubsection
EndSection


admanis 04-07-2002 11:19 AM

Thanks for your help, I managed to get to the XF86config and edit it but now i can't log on to linux!!!! at the Lilo prompt when i type in linux the computer just blinks continously. Also, It would seem that the only video card that i am allowed to use is the generic vga16 which limits the modes that i can use to 640 x 480. My video card is SiS 3D AGPwhich is on the list of Xconfigurator but whenever i try using it i get an error message. Obviously i am doing something wrong but what???? please help.
:smash:

Aussie 04-07-2002 11:50 AM

Post the output of "XFree86 -version" and the video card details from "cat /proc/pci".

admanis 04-07-2002 08:10 PM

Thanks for your help, but i am for now giving up on linux, it is proving too difficult to master, i am a firm believer in the 'anything but microsoft ' philosophy but for now i cannot understand it. I would post a response but cannot copy from hdb to c: why can't linux be as easy as windows? i built my own computer,...to build a linux machine from scratch what do i need? For Linux to break new grounds it needs to be easily integratable.


All times are GMT -5. The time now is 11:53 AM.