LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Disappearing mail fetched with fetchmail (http://www.linuxquestions.org/questions/linux-software-2/disappearing-mail-fetched-with-fetchmail-770334/)

simjii 11-19-2009 07:38 PM

Disappearing mail fetched with fetchmail
 
I have been using fetchmail to download mails from gmail on Suse 10.3.
I recently installed Suse 11.2 and having a problem with downloaded mail.
All mails are disappearing. Fetchmail successfully download mails but they disappear. I am running postfix as a mail agent.
I would appreciate if anybody can explain what is wrong.

Here are my ~/.fetchmailrc for user'voyager'

# Configuration created Tue Sep 26 18:13:41 2006 by fetchmailconf
set postmaster "voyager"
set nobouncemail
set no spambounce
set properties ""
set daemon 600

poll pop.gmail.com with proto POP3 and options no dns
user 'gamil_id_here' there with password 'gmail_pass_here' is 'voyager' here options fetchall ssl sslcertck sslcertpath '/home/voyager/.certificate'

Following is my /etc/hosts
::1 localhost ipv6-localhost ipv6-loopback
127.0.0.1 voyager voyager
127.0.0.2 voyager.cosmos.net voyager

And here is the log in /var/log/mail.info
The domain name cosmos.net is a fake given to network setting.

Nov 19 18:15:11 voyager postfix/smtpd[16358]: connect from localhost[::1]
Nov 19 18:15:11 voyager postfix/smtpd[16358]: 7E8C34E7: client=localhost[::1]
Nov 19 18:15:11 voyager postfix/cleanup[16362]: 7E8C34E7: message-id=<683125.5070.qm@web58605.mail.re3.yahoo.com>
Nov 19 18:15:11 voyager postfix/qmgr[3544]: 7E8C34E7: from=<TEST MAIL ACCOUNT>, size=3126, nrcpt=1 (queue active)
Nov 19 18:15:11 voyager postfix/local[16363]: 7E8C34E7: to=<voyager@localhost.cosmos.net>, orig_to=<voyager@localhost>, relay=local, delay=0.12, delays=0.09/0/0/0.03, dsn=2.0.0, status=sent (delivered to maildir)
Nov 19 18:15:11 voyager postfix/qmgr[3544]: 7E8C34E7: removed
Nov 19 18:15:12 voyager postfix/smtpd[16358]: disconnect from localhost[::1]


Again any help is appreciated.

simjii 11-19-2009 08:58 PM

I am answering to myself hoping this can help someone who has the same problem.
It seems that fetchmail does not work well with postfix. Fetchmail FAQ does not mention about postfix either so I guess it is not supported by fetchmail.
Problem is solved by replacing postfix with sendmail. It is kind of disappointment that open Suse is shipping uncooperative packages together as a default.

dtsw 12-02-2009 03:23 AM

try IPv4 instead of IPv6
 
had a similar problem on MacOS X. Just make sure fetchmail uses IPv4 when hand over the mail to postfix.

You could comment out IPv6 entries in /etc/hosts if you do not need IPv6 for any purpose.

Or add an entry to /etc/hosts for example:

127.0.0.1 ipv4loopback

and configure fetchmail to use that server with
-S ipv4loopback or --smtphost ipv4loopback
see Manual Page under "Delivery Control Options"


All times are GMT -5. The time now is 04:57 AM.