LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Disabling xscreensaver for Xfce VNC display (http://www.linuxquestions.org/questions/linux-software-2/disabling-xscreensaver-for-xfce-vnc-display-205995/)

tawalker 07-16-2004 05:55 PM

Disabling xscreensaver for Xfce VNC display
 
This week, I installed Xfce on my RH9 desktop, specifically to replace twm as the environment for the VNC display. It works fine, and I definitely prefer the new look - I also run GNOME on my main (local) display.

At the same time, I'm getting increasingly addicted to BZFlag ( :) ), but the last couple of evenings I found the movement on-screen would start getting very jerky after a few minutes of play. The 'ps aux' command showed xscreensaver modules (mostly 'barcode' and 'halftone') running, even though they weren't running on my local display. I'd kill them and start playing again, only to repeat the process a few minutes later.

You've probably figured out what took two days to dawn on me: the modules are running on the VNC display (where I can't see them), and stealing CPU cycles which I need for BZFlag (not to mention the OpenGL savers on my main display!).

Is it possible to disable xscreensaver for the VNC display only, and leave it enabled on the local display? If so, how would you suggest doing this?

Thanks,
Tim.


All times are GMT -5. The time now is 08:18 PM.