Share your knowledge at the LQ Wiki.
Go Back > Forums > Linux Forums > Linux - Software
User Name
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.


  Search this Thread
Old 11-01-2003, 07:14 PM   #1
LQ Guru
Registered: Feb 2003
Location: Colorado Springs, CO
Distribution: Gentoo
Posts: 2,018

Rep: Reputation: 48
Disabling virtual screen mouse scrolling in X?

OK, so you probably all know how if you run X at a low resolution, and you have a larger virtual desktop, you can scroll the screen around by moving your mouse to the edge. The virtual screen can be sort of disabled by commenting out the "Virtual" lines in XF86Config, or by setting only one screen resolution (1600x1200) in the "Modes" section (though it's still there, at the max resolution listed in "Modes"). Anyhow, to the point:

I want to run some games in Wine at full-screen, 800x600, say. They run at lower resolution than my only "Mode" in XF86Config; they fill the screen, but once again, moving the mouse to the edge causes X to scroll around the 1600x1200 desktop, and my game to go off the edge. The "DXGrab" wine config option does not prevent this from happening, nor do any other settings I've tried. I've determined with near-certainty that there are no wine configuration options that will fix it; presumably DXGrab is broken for some situations, so it's time to find a workaround.

From what I can tell, there's no way to completely disable the presence of a virtual screen; it's going to be there, at whatever the highest resolution listed in "Modes" is. All I need to do is find a way to disable the scrolling that occurs when the mouse hits the edge. Anyone know of a way to do this?
Old 11-05-2003, 11:20 PM   #2
Bensoft Kill MS
Registered: Jul 2003
Location: KY
Distribution: Red Hat 9
Posts: 65

Rep: Reputation: 15
Have you tried ctrl alt + or - ? I haven't used wine, but as this has to do with x, and ctrl alt +/- works in x, it might do something.
Old 11-06-2003, 12:19 PM   #3
LQ Guru
Registered: Feb 2003
Location: Colorado Springs, CO
Distribution: Gentoo
Posts: 2,018

Original Poster
Rep: Reputation: 48
Well, ctrl-alt-+/- will switch the screen resolution, but the virtual resolution (as they call it) stays the same, at 1600x1200, so I'm afraid I still get the scrolling with that. It was a nice thought though
Old 11-06-2003, 12:49 PM   #4
Registered: Oct 2003
Distribution: Debian/unstable
Posts: 85

Rep: Reputation: 15
I believe this is a function of your window manager. You should be able to enable/disable it there.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Mouse Scrolling nin881 Slackware 2 06-02-2005 11:46 PM
scrolling the mouse ilnli Slackware 6 01-03-2005 12:42 PM
Gnome Virtual Desktop scrolling Crowebert Linux - General 1 08-12-2004 11:45 AM
scrolling mouse Ipolit Linux - Newbie 2 12-03-2003 03:27 PM
screen scrolling? stateq2 Debian 3 06-26-2003 04:44 PM

All times are GMT -5. The time now is 06:39 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration