LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices


Reply
  Search this Thread
Old 05-08-2003, 05:59 PM   #1
digsby0007
Member
 
Registered: Jan 2003
Posts: 94

Rep: Reputation: 15
disabling telnet


How do I stop telnet from running? I have stop it in services, comented out of the services file, and re-ran xinetd but i can still telnet to my localhost. one more question, I tried looking in lokkit and the stock firewall, but I dont see where to ban an IP address

Any Thoughts?
Digsby
 
Old 05-08-2003, 06:02 PM   #2
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,066
Blog Entries: 11

Rep: Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910Reputation: 910
Check the file
/etc/xinted.d/telnet (or similar - assuming you're on RH)


Cheers,
Tink
 
Old 05-08-2003, 06:53 PM   #3
acid_kewpie
Moderator
 
Registered: Jun 2001
Location: UK
Distribution: Gentoo, RHEL, Fedora, Centos
Posts: 43,417

Rep: Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974Reputation: 1974
or... just remove telnet from your system... always a good idea!
 
Old 05-09-2003, 07:49 AM   #4
digsby0007
Member
 
Registered: Jan 2003
Posts: 94

Original Poster
Rep: Reputation: 15
Ok in etc/xinet.d/telnet i set disable = yes and log out, and back in, but I can still telnet to my machine. I would just delete telnet, but I need it to play muds. Im trying to find a mud client right now, but I know I can disable telnet without deleting it.

Thanks,
Digsby
 
Old 05-09-2003, 07:58 AM   #5
Paul Johnson
LQ Newbie
 
Registered: Mar 2003
Location: Chelmsford, Essex, UK.
Distribution: Red Hat
Posts: 15

Rep: Reputation: 0
Logging out and logging in isn't going to restart xinetd.

Here is how things work:

xinetd is configured to listen to the telnet port (amongst a long list of others). When someone tries to connect it fires up telnetd (note the 'd') and stands back.

xinetd is started at boot time. People logging in and out makes no difference to it at all.

You can restart xinetd by logging in as root and saying

service xinetd restart

Paul.
 
Old 05-09-2003, 08:08 AM   #6
digsby0007
Member
 
Registered: Jan 2003
Posts: 94

Original Poster
Rep: Reputation: 15
problem solved

Thanks a Ton!
Digsby
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How do I setup telnet on Fedorac1 so I can telnet to it from winxp? mman49 Fedora 6 05-02-2004 01:40 PM
can not telnet localhost 25 but telnet dowell.exper.dynserv.com 25 exper Linux - Software 0 02-25-2004 06:13 AM
disabling telnet anf ftp nelly_boy Solaris / OpenSolaris 4 08-01-2003 08:52 AM
disabling su to root from telnet subhasis_ray Linux - Security 6 02-11-2003 07:04 AM
disabling telnet ! anoop_chandran Linux - Networking 2 11-13-2001 08:09 AM


All times are GMT -5. The time now is 01:53 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration