LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 03-13-2013, 09:13 AM   #1
P5music
Member
 
Registered: Nov 2010
Posts: 59

Rep: Reputation: 0
boot issue [solved]: disabling ACPI before shutdown with a command


Hello,
I have a serious problem with ACPI. I think this is a known bug of kernel and I found some users with this issue too: after shutdown of a Linux (any distro) system on certain notebooks (like my Acer Aspire model) the system doesn't boot, it doesn't even start bios loading; after an electric discharge procedure boot is again possible. This issue doesn't affect Windows on the same system.
I cannot wait for this strange kernel issue being solved because I think there is some serious problem underlying so I ask:
Is it possible to run a command before shutdown to disable any ACPI action? I see an ACPI error message at shutdown so I think that some parameter is written in some register at that time and I am looking for a command that stops any ACPI action or register updating before it does something that creates the boot issue.
Thank you in advance

Last edited by P5music; 03-25-2013 at 12:27 PM.
 
Old 03-13-2013, 02:46 PM   #2
jefro
Guru
 
Registered: Mar 2008
Posts: 11,323

Rep: Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386
I think it has to do with the newer systems and their ability to use windows' hybrid sleep.

Since bios is part of this acpi, you may be able to stop some parts on linux but others may not be changed I'd think.

Why not boot without acpi if possible?

On shutdown, how do you tell it to shutdown? Try logging off the user and from main splash, do a shutdown.
 
Old 03-13-2013, 03:44 PM   #3
P5music
Member
 
Registered: Nov 2010
Posts: 59

Original Poster
Rep: Reputation: 0
Do you know some command I could issue before shutdown about stopping ACPI functions? I mean, a command with no permanent effect. Any suggestion is welcomed so I can try. Who knows, maybe it works and I have somehow solved. Thank you.

Last edited by P5music; 03-13-2013 at 03:46 PM.
 
Old 03-14-2013, 04:34 PM   #4
jefro
Guru
 
Registered: Mar 2008
Posts: 11,323

Rep: Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386
See this down the page for acpi stop. http://pc-freak.net/blog/disable-acp...-fan-lifespan/
 
Old 03-18-2013, 04:36 AM   #5
P5music
Member
 
Registered: Nov 2010
Posts: 59

Original Poster
Rep: Reputation: 0
Hello, thank you for the response.
When I try to stop acpid I get this error:
Code:
stop: Rejected send message, 1 matched rules; type="method_call", sender=":1.53" (uid=1000 pid=2620 comm="stop acpid ") interface="com.ubuntu.Upstart0_6.Job" member="Stop" error name="(unset)" requested_reply="0" destination="com.ubuntu.Upstart" (uid=0 pid=1 comm="/sbin/init")
What does it mean?
 
Old 03-18-2013, 02:25 PM   #6
jefro
Guru
 
Registered: Mar 2008
Posts: 11,323

Rep: Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386
Post exact command you tried.
 
Old 03-18-2013, 02:50 PM   #7
P5music
Member
 
Registered: Nov 2010
Posts: 59

Original Poster
Rep: Reputation: 0
various commands yield that message:
acpid stop
stop acpid
service acpid stop
because alternative forms are suggested
 
Old 03-25-2013, 12:26 PM   #8
P5music
Member
 
Registered: Nov 2010
Posts: 59

Original Poster
Rep: Reputation: 0
sudo service acpid stop
was the right command.
If I issue it before shutting down my Linux Mint system the notebook boots without any problem next time.
 
Old 03-25-2013, 03:37 PM   #9
jefro
Guru
 
Registered: Mar 2008
Posts: 11,323

Rep: Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386Reputation: 1386
Thanks for the update.

You might be able to get that to run in shutdown scripts, maybe even have to put in a pause to be sure it ends.

Last edited by jefro; 03-25-2013 at 03:38 PM.
 
Old 04-11-2013, 04:40 AM   #10
P5music
Member
 
Registered: Nov 2010
Posts: 59

Original Poster
Rep: Reputation: 0
@jefro
Would you be so kind to help me on this topic:
http://www.linuxquestions.org/questi...175456837-new/
because nobody seems to be able to answer my question about specific Fedora 18 environment. Thank you in advance.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Gutsy freeze during shutdown while disabling eth# CyberInfantry Ubuntu 0 11-28-2007 01:02 AM
Disabling shutdown service shankarbrnair Fedora 4 10-26-2007 10:28 AM
Issues with OpenSuSE install and disabling ACPI treydock Linux - Software 1 02-28-2007 12:16 PM
USB Printer fails to initialize after disabling ACPI DragonWisard Linux - Hardware 0 04-21-2006 11:46 PM
disabling shutdown? kj6loh Fedora 4 02-21-2006 02:27 AM


All times are GMT -5. The time now is 07:44 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration