LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Disable NVidia PoweMizer on a Linux Desktop (Why's it there in the first place?) (http://www.linuxquestions.org/questions/linux-software-2/disable-nvidia-powemizer-on-a-linux-desktop-whys-it-there-in-the-first-place-4175461980/)

thebombzen 05-14-2013 05:59 PM

Disable NVidia PoweMizer on a Linux Desktop (Why's it there in the first place?)
 
If I sound irritated, it's because I am! So be warned.

I recently learned that NVidia's power-saving feature, PowerMizer, is enabled on my desktop and this irks me as anyone with any brains should realize that power saving is not really a high priority for desktop users as desktops are always plugged into AC power and have good cooling compared to laptops.

That being said, here's a screenshot of my NVidia X Server's PowerMizer settings:

http://i.imgur.com/A7LbLm5.png

Notice that adaptive clocking is enabled, performance level is 0, and the PowerMizer settings dropdown is set to "Adaptive."

What's even more egregious is these settings won't save. If I change the dropdown to "Prefer Maximum Performance," when I restart NVidia X Server Settings, it just sets right back to adaptive. I can't figure out how to turn off a power-saving setting on my desktop. :mad:

After searching this problem on Google, and tried many of the fixes, none of them seem to work, but maybe that's because most fixes seemed targeted at laptops. I tried this:
Quote:

Create a file called /etc/modprobe.d/nvidia.conf with this in it:

options nvidia NVreg_RegistryDwords="PerfLevelSrc=0x2222"
I tried adding all these to my xorg.conf under "Display" (at different times of course):
Quote:

Option "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x3322; PowerMizerDefaultAC=0x1"
Option "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x2222; PowerMizerDefaultAC=0x1"
Option "RegistryDwords" "PowerMizerEnable=0x1; PowerMizerLevel=0x1; PowerMizerLevelAC=0x1"
Option "RegistryDwords" "PowerMizerEnable=0x1; PerfLevelSrc=0x3322; PowerMizerDefaultAC=0x1; PowerMizerLevel=0x1; PowerMizerLevelAC=0x1"
Option "RegistryDwords" "PowerMizerEnable=0x0; PerfLevelSrc=0x3322; PowerMizerDefaultAC=0x1; PowerMizerLevel=0x1; PowerMizerLevelAC=0x1"
Option "RegistryDwords" "PowerMizerEnable=0x0"
But none of these worked. Performance level was still locked at 0, and adaptive clocking enabled with settings set to "Adaptive."

Does anyone know how I can fix this stupid stupid power-saving load of garbage for my desktop? Thanks in advance for your reply.

273 05-14-2013 06:27 PM

What issues is it causing you, may I ask? I've not noticed any problems leaving it on "Adaptive".
However, one thing you could try adding
Code:

Option "Coolbits" "1"
to your xorg.conf since this enabled overclocking it may also make your choice stick.
The other thing to try is to "Save Current Configuration" before closing nvidia-settings.
By the way, running your card at full speed if you leave your PC on for hours could get very, very hot and cost you a few dollars more in electricity. The 8600 probably isn't a fast enough card to burst into flames like its stablemates have been known to but I would still be even more careful about dust buildup if you're running it at 100% constantly.

thebombzen 05-15-2013 02:02 PM

Quote:

Originally Posted by 273 (Post 4951239)
What issues is it causing you, may I ask? I've not noticed any problems leaving it on "Adaptive".

I think it's slowing down the graphics on my machine. However, I don't know the alternative because apparently this has been on the whole time.

Quote:

Originally Posted by 273 (Post 4951239)
However, one thing you could try adding
Code:

Option "Coolbits" "1"
to your xorg.conf since this enabled overclocking it may also make your choice stick.
The other thing to try is to "Save Current Configuration" before closing nvidia-settings.

I tried both of these, to no avail.

Quote:

Originally Posted by 273 (Post 4951239)
By the way, running your card at full speed if you leave your PC on for hours could get very, very hot and cost you a few dollars more in electricity. The 8600 probably isn't a fast enough card to burst into flames like its stablemates have been known to but I would still be even more careful about dust buildup if you're running it at 100% constantly.

I'm not interested in running my card at full speed, I'm just interested in having it not shut down when I'm doing less-intensive stuff.

273 05-15-2013 02:09 PM

I'm not sure that the card slowing down would affect anything. If you're running something using the card then it should stay at full speed until you stop running that, if it's not I would call that a fault. If you're not running games or high-definition video then you won't need the card and so it will run slow.
I don't see a use case where it slowing down would cause problems.

thebombzen 05-17-2013 03:41 PM

I did a quick Google images search on "NVidia X Server Settings PowerMizer" and I got others' images of the screen, which appear to have multiple performance levels. My screen only has one performance level, which reads at my GPU's clock speed, so it's possible I've been an idiot, it's been disabled this entire time, and the setting Adaptive/Maximum Performance does nothing because I only have one performance level. Is this likely?

273 05-17-2013 03:47 PM

That is entirely possible, yes. Just check that the clock speed your card is rated at is the one it is shown to be running at. I'm not sure when the nVIDIA power settings came in but thinking about it my 9800 makes a big deal of it so perhaps that was the first generation to have it in desktop cards.

10110111 05-18-2013 09:44 AM

You indeed have only one level of performance. See how it looks on my card with 4 levels: link. If I change from adaptive to max performance, then it goes to level 3 and will keep there. And on adaptive there's some jumpy moving windows on window drag, which then goes better when level goes higher.

thebombzen 05-18-2013 11:43 AM

Quote:

Originally Posted by 10110111 (Post 4953705)
You indeed have only one level of performance. See how it looks on my card with 4 levels: link. If I change from adaptive to max performance, then it goes to level 3 and will keep there. And on adaptive there's some jumpy moving windows on window drag, which then goes better when level goes higher.

Well now I just feel stupid. Anyway, marked as solved.

273 05-18-2013 11:46 AM

The GUI, being the same for all cards, isn't all that clear on the point. I think it would have taken me a while to work it out.


All times are GMT -5. The time now is 08:58 PM.