LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 04-30-2011, 03:39 PM   #1
m.s
LQ Newbie
 
Registered: Apr 2011
Location: Czech Republic
Distribution: Debian, Fedora
Posts: 1

Rep: Reputation: 0
Direct playback with PulseAudio


Hello. I've tried to search the web but I haven't been able to find anything useful, so I'm asking.

There is a setting for PulseAudio which resampling method to choose. But what if I want to completely disable resampling, since my soundcard is probably capable of playing all rates? I have some music in higher frequency and it would be somehow stupid to convert it to a lower rate.

I'm using Debian testing and Fedora 15 if it is of any relevance.
My soundcard is: "00:1b.0 Audio device: Intel Corporation 82801JI (ICH10 Family) HD Audio Controller"
 
Old 05-01-2011, 04:07 AM   #2
Prehistorik
LQ Newbie
 
Registered: Oct 2006
Location: St. Petersburg, Russia
Distribution: Fedora
Posts: 16

Rep: Reputation: 1
I'm afraid it's not possible in PulseAudio because it mixes audio streams from applications in software. It means that all streams must be converted to the same sample rate before mixing.

I guess you've already seen this: http://linux.die.net/man/5/pulse-daemon.conf

If you want quality, try setting default-sample-rate=96000. I don't think your sound card supports rates higher than 96k.

If you want speed, try resample-method=trivial, resample-method=src-sinc-fastest, resample-method=speex-float-0 and resample-method=speex-float-3, in that order. Stop when you get acceptable sound quality. (I suggest using 44,1 kHz audio for quality testing if you've set the default sample rate to 96k.)

As an alternative, try switching to ALSA. Consult your distribution's manual or wiki on how to do this. It will mix audio streams in hardware if your sound card supports this. You can check if it does by running a command:

Code:
aplay -l
If you see more than one line like the following:

Code:
  Subdevice #0: subdevice #0
then your sound card is likely to have hardware mixing. (But I'm afraid it's not, because my laptop comes with a card similar to yours ("82801H (ICH8 Family)") and it has only one subdevice.)

Last edited by Prehistorik; 05-01-2011 at 04:09 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Squeeze + Pulseaudio + Alsa and USB Midi device causes Pulseaudio crash mad4linux Debian 1 01-26-2011 04:57 AM
Winecfg crashes on sound tab with Pulseaudio and no 'sounddrivers' without pulseaudio William (Dthdealer) Linux - Software 5 06-13-2010 08:30 AM
no sound playback or video playback..on ubuntu 8.10 thelastquincy Linux - Newbie 3 04-21-2009 12:14 AM
KsCD, no sound, even with direct digital playback headly21 Linux - Software 0 10-29-2005 09:20 AM
blue line at the top of TV playback, DIVX playback spiderworm Linux - Software 0 01-31-2005 03:33 PM


All times are GMT -5. The time now is 06:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration