LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   digikam no compile (http://www.linuxquestions.org/questions/linux-software-2/digikam-no-compile-704138/)

micder 02-12-2009 06:31 AM

digikam no compile
 
Got Slack-12.1 and KDE-3.5.9.
Tried to install digikam.
./configure went OK
Code:

checking for Qt... libraries /usr/lib/qt-3.3.8b/lib, headers /usr/lib/qt/include using -mt

-- digiKam configure results -------------------
-- libsqlite3 library found....... YES
-- libgphoto2 library found....... YES
-- libkipi library found.......... YES
-- libtiff library found..... .... YES
-- libpng library found........... YES
-- libjasper library found........ YES
-- liblcms library found.......... YES
-- libkexiv2 library found........ YES
-- libkdcraw library found........ YES
------------------------------------------------

Good - your configure finished. Start make now

make fails with
Code:

grep: /usr/lib/qt-3.3.8/lib/libqt-mt.la: No such file or directory
/usr/bin/sed: can't read /usr/lib/qt-3.3.8/lib/libqt-mt.la: No such file or directory
libtool: link: `/usr/lib/qt-3.3.8/lib/libqt-mt.la' is not a valid libtool archive

Searching on linuxquestions brought me to ~alien/slackbuilds.
Installation of Bob's packages gave me digikam.:)
I'l keep that site in mind, it's fantastic!

However, it keeps nagging me that my compilation did not succeed.
Anybody any ideas why?

jdkaye 02-12-2009 07:18 AM

That's an easy one! :-)
You need to install the libqt3-mt dev package.
Cheers,
jdk

micder 02-12-2009 09:06 AM

Thank you.

Discovered that I posted under Linux general i.s.o. Slackware.
Can't find libqt3-mt dev in Slack
Will post under Slackware


All times are GMT -5. The time now is 11:23 AM.