LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 08-18-2005, 06:35 PM   #1
EllieJ
LQ Newbie
 
Registered: Aug 2005
Location: Manchester, England
Posts: 7

Rep: Reputation: 0
Question Digikam 0.7.2 problem


Hello - digikam has auto-detected my HP camera but when i try to get pics it says 'Cannot connect. Ensure camera is connected properly and switched on' It is, I checked (have been known to overlook that one in the past!)

As a complete newbie who barely knows how to find a command line, much less type anything into it, is there an easy way for me to sort this out?

I changed to linux because of ridiculous amounts of virii on MS but find it difficult to negotiate with my limited knowledge (ie 12 DOS commands!) 'part from that it's super!

Thanks for reading

 
Old 08-18-2005, 06:59 PM   #2
PeterRJG
Member
 
Registered: Jun 2005
Location: Northern NSW, Australia
Distribution: Distro Astro 1.02, Windows 7
Posts: 123

Rep: Reputation: 15
This site --> http://www.gphoto.org/ helped me immensely getting my camera to work.
 
Old 08-18-2005, 08:44 PM   #3
EllieJ
LQ Newbie
 
Registered: Aug 2005
Location: Manchester, England
Posts: 7

Original Poster
Rep: Reputation: 0
Thank you johnnycab. I would prefer to make my current application work, but thought - if it's beyond help I will try this link. Of course I don't know how to make an application work once I have downloaded it ...but worth a try. Then firefox crashed because I don't have enough RAM (128 - how bad is that on a reasonably new pc?)
Time to get some sleep and try again tomorrow (it's 2.40am UK time)
 
Old 08-19-2005, 07:25 AM   #4
auditek747
Member
 
Registered: Feb 2004
Location: Ohio, USA
Distribution: Arch Linux
Posts: 464

Rep: Reputation: 30
EllieJ

Johnnycab recomended that link because DigiKam is a "front end" for
GPhoto. GPhoto is what does the work for Digikam.

Anyhow... It looks like a permission problem.
Since your using Digikam, is it safe to assume that you are running KDE ?

If that is the case, from the start menu select:

Run Command

From that dialog select:

Options

Then:

check the box for "Run as a different user"

The user name should be root
the password should be your root password

In the "command" form type:

digikam

Now try your camera. If it works, you have a permission problem.
Fixing that will depend on the distribution that your running,
so tell us what it is. (Mandrake, Suse, Debian, or whatever)

Last edited by auditek747; 08-19-2005 at 07:32 AM.
 
Old 08-19-2005, 08:30 AM   #5
EllieJ
LQ Newbie
 
Registered: Aug 2005
Location: Manchester, England
Posts: 7

Original Poster
Rep: Reputation: 0
Thumbs up

Thanks - it works!
I have Debian. I did Applications/System tools/Root terminal (changed the user name, it was debian, not mine) then typed digikam.

All my pics downloaded fine, so I don't need to know what this means but I put it in anyway. Thanks again for help :-)

HERE'S WHAT HAPPENED:
enterprise:/home/elliej# digikam
Session management error: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
Link points to "/tmp/ksocket-root"
QPixmap: Cannot create a QPixmap when no GUI is being used
QPixmap: Cannot create a QPixmap when no GUI is being used
Link points to "/tmp/kde-root"
kbuildsycoca running...
Reusing existing ksycoca

THEN THIS LINE ABOUT 100 TIMES FOR VARIOUS APPLICATIONS
kbuildsycoca: WARNING: '/usr/share/applications/themus-theme-applier.desktop' specifies undefined mimetype/servicetype 'application/x-gnome-theme-installed'

THEN:
DCOP Cleaning up dead connections.
enterprise:/home/emma# Session management error: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
digikam: WARNING: [void AlbumFolderView::loadAlbumState()] Failed to open albumtreestate.bin
QImage:ixel: x=0 out of range
Session management error: Authentication Rejected, reason : None of the authentication protocols specified are supported and host-based authentication failed
Launched ok, pid = 6709
OggS-SEEK: at 832 want 47096 got 45248 (diff-requested 46264)
OggS-SEEK: at 47296 want 1032 got 0 (diff-requested -46264)
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 20
Minor opcode: 0
Resource id: 0x2800328
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 20
Minor opcode: 0
Resource id: 0x2800328
X Error: BadWindow (invalid Window parameter) 3
Major opcode: 18
Minor opcode: 0
Resource id: 0x2800328
OggS-SEEK: at 832 want 47096 got 45248 (diff-requested 46264)
OggS-SEEK: at 47296 want 1032 got 0 (diff-requested -46264)
OggS-SEEK: at 0 want 122872 got 83904 (diff-requested 122872)
OggS-SEEK: at 122816 want 520 got 0 (diff-requested -122296)
digikam: WARNING: [void DirSelectDialog:penNextDir(KFileTreeViewItem*)] Could not find item for urlfile:/data/Photographs/NewCameraPics
unsupported file format.
sh: dcraw: command not found
kio (KMimeType): WARNING: KServiceType:ffers : servicetype ThumbCreator not found
kio_digikamthumbnail: WARNING: Cannot create thumbnail for /data/Photographs/NewCameraPics/autprint.mrk
unsupported file format.
sh: dcraw: command not found
kio (KMimeType): WARNING: KServiceType:ffers : servicetype ThumbCreator not found
kio_digikamthumbnail: WARNING: Cannot create thumbnail for /data/Photographs/NewCameraPics/im000278.avi
unsupported file format.
sh: dcraw: command not found
kio_digikamthumbnail: WARNING: Cannot create thumbnail for /data/Photographs/NewCameraPics/autprint.mrk
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Digikam problem in 2006 apostate Mandriva 2 11-21-2005 12:57 PM
Problem running digikam adityavpratap Slackware 3 10-30-2005 06:24 AM
digikam problem (usb thing??) specialized Linux - Hardware 2 10-27-2005 11:06 AM
X problem when installing Digikam SuperRunt Linux - Software 3 06-13-2005 12:43 AM
digikam problem dukeinlondon Linux - Software 2 10-15-2004 10:11 AM


All times are GMT -5. The time now is 08:05 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration