LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 01-06-2008, 06:12 PM   #31
Drakeo
Senior Member
 
Registered: Jan 2008
Location: Urbana IL
Distribution: Slackware, Slacko,
Posts: 2,658
Blog Entries: 3

Rep: Reputation: 222Reputation: 222Reputation: 222

well It is the installer that is unable to place the pre built bionaries in to the /usr/lib/your browser/plugins you could just copy them manualy to the corect place.
 
Old 01-06-2008, 07:31 PM   #32
saak.stepi
Member
 
Registered: Dec 2007
Posts: 88

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Lenard View Post
Use the one that matches your OS version;

rpm -Uvh http://apt.sw.be/packages/rpmforge-r....rf.x86_64.rpm

Once more in order to install the 32-bit packages one needs to specify the 32-bit version;

yum install mplayer.i386 mplayerplug-in.i386 mplayer-skins mplayer-fonts --enablerepo=rpmforge
This does not work ...

# yum install mplayer.i386 mplayerplug-in.i386 mplayer-skins mplayer-fonts --enablerepo=rpmforge
Setting up Install Process
Setting up repositories
update 100% |=========================| 951 B 00:00
rpmforge 100% |=========================| 1.1 kB 00:00
base 1.1 kB 00:00
addons 100% |=========================| 951 B 00:00
adobe-linux-i386 100% |=========================| 951 B 00:00
extras 100% |=========================| 1.1 kB 00:00
Reading repository metadata in from local files
Parsing package install arguments
No Match for argument: mplayer.i386
No Match for argument: mplayerplug-in.i386
Nothing to do
 
Old 01-07-2008, 06:33 AM   #33
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
Then do this manually, get the list of rpm packages needed;

rpm -e mplayer mplayerplug-in --test

Download the replacement 32-bit rpm packages into one common location then install all at once after uninstalling the other packages;

rpm -e mplayer mplayerplug-in mplayer-skins mencoder
rpm -Uvh *.rpm
 
Old 01-07-2008, 09:22 AM   #34
saak.stepi
Member
 
Registered: Dec 2007
Posts: 88

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Lenard View Post
Then do this manually, get the list of rpm packages needed;

rpm -e mplayer mplayerplug-in --test

Download the replacement 32-bit rpm packages into one common location then install all at once after uninstalling the other packages;

rpm -e mplayer mplayerplug-in mplayer-skins mencoder
rpm -Uvh *.rpm
I'll try to do this. One more question:
I noticed that in the libraries repositories
there are "devel" files
example:
aalib-devel-1.4.0-0.rc5.dag.rh62.i386.rpm

What are these files ?


Some files have "dag" and others have "rf" extensions

examples:
aalib-1.4.0-5.1.fc2.dag.x86_64.rpm
aalib-1.4.0-5.1.fc3.rf.i386.rpm

what these "dag" and "rf" extensions stand for ?


Thanks,
John
 
Old 01-07-2008, 09:30 AM   #35
Lenard
Senior Member
 
Registered: Dec 2005
Location: Indiana
Distribution: RHEL/CentOS/SL 5 i386 and x86_64 pata for IDE in use
Posts: 4,790

Rep: Reputation: 56
dag == Dag Wieers (the guy that is a major part of rpmforge and owns the site)
rf == rpmforge
 
Old 01-07-2008, 10:40 AM   #36
saak.stepi
Member
 
Registered: Dec 2007
Posts: 88

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by Lenard View Post
Then do this manually, get the list of rpm packages needed;

rpm -e mplayer mplayerplug-in --test

Download the replacement 32-bit rpm packages into one common location then install all at once after uninstalling the other packages;

rpm -e mplayer mplayerplug-in mplayer-skins mencoder
rpm -Uvh *.rpm
I tried to do this manually, but failed, plese see below:

rpm -Uvh *.rpm
warning: package libmpcdec = 1.2-1.2.el4.rf was already added, replacing with libmpcdec <= 1.2.6-1.el4.rf
warning: mplayer-codecs-20061022-1.i386.rpm: V3 DSA signature: NOKEY, key ID b6d6aef5
Preparing... ########################################### [100%]
package libsndfile-1.0.17-1.el4.rf (which is newer than libsndfile-1.0.11-1.2.el4.rf) is already installed
package lame-3.97-1.el4.rf (which is newer than lame-3.96.1-2.2.el4.rf) is already installed
file /usr/share/man/man1/lame.1.gz from install of lame-3.96.1-2.2.el4.rf conflicts with file from package lame-3.97-1.el 4.rf
file /usr/bin/dfbdump from install of directfb-0.9.25.1-1.el4.rf conflicts with file from package directfb-0.9.25.1-1.el4 .rf
file /usr/bin/dfbg from install of directfb-0.9.25.1-1.el4.rf conflicts with file from package directfb-0.9.25.1-1.el4.rf
file /usr/bin/dfbinfo from install of directfb-0.9.25.1-1.el4.rf conflicts with file from package directfb-0.9.25.1-1.el4 .rf
file /usr/bin/dfbinput from install of directfb-0.9.25.1-1.el4.rf conflicts with file from package directfb-0.9.25.1-1.el 4.rf
file /usr/bin/dfblayer from install of directfb-0.9.25.1-1.el4.rf conflicts with file from package directfb-0.9.25.1-1.el 4.rf
file /usr/bin/dfbpenmount from install of directfb-0.9.25.1-1.el4.rf conflicts with file from package directfb-0.9.25.1-1 .el4.rf
file /usr/bin/dfbscreen from install of directfb-0.9.25.1-1.el4.rf conflicts with file from package directfb-0.9.25.1-1.e l4.rf
file /usr/bin/dfbsummon from install of directfb-0.9.25.1-1.el4.rf conflicts with file from package directfb-0.9.25.1-1.e l4.rf
 
Old 01-07-2008, 10:57 AM   #37
saak.stepi
Member
 
Registered: Dec 2007
Posts: 88

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by saak.stepi View Post
I tried to do this manually, but failed, plese see below:

rpm -Uvh *.rpm
warning: package libmpcdec = 1.2-1.2.el4.rf was already added, replacing with libmpcdec <= 1.2.6-1.el4.rf
warning: mplayer-codecs-20061022-1.i386.rpm: V3 DSA signature: NOKEY, key ID b6d6aef5
Preparing... ########################################### [100%]
package libsndfile-1.0.17-1.el4.rf (which is newer than libsndfile-1.0.11-1.2.el4.rf) is already installed
package lame-3.97-1.el4.rf (which is newer than lame-3.96.1-2.2.el4.rf) is already installed
file /usr/share/man/man1/lame.1.gz from install of lame-3.96.1-2.2.el4.rf conflicts with file from package lame-3.97-1.el 4.rf
file /usr/bin/dfbdump from install of directfb-0.9.25.1-1.el4.rf conflicts with file from package directfb-0.9.25.1-1.el4 .rf
file /usr/bin/dfbg from install of directfb-0.9.25.1-1.el4.rf conflicts with file from package directfb-0.9.25.1-1.el4.rf
file /usr/bin/dfbinfo from install of directfb-0.9.25.1-1.el4.rf conflicts with file from package directfb-0.9.25.1-1.el4 .rf
file /usr/bin/dfbinput from install of directfb-0.9.25.1-1.el4.rf conflicts with file from package directfb-0.9.25.1-1.el 4.rf
file /usr/bin/dfblayer from install of directfb-0.9.25.1-1.el4.rf conflicts with file from package directfb-0.9.25.1-1.el 4.rf
file /usr/bin/dfbpenmount from install of directfb-0.9.25.1-1.el4.rf conflicts with file from package directfb-0.9.25.1-1 .el4.rf
file /usr/bin/dfbscreen from install of directfb-0.9.25.1-1.el4.rf conflicts with file from package directfb-0.9.25.1-1.e l4.rf
file /usr/bin/dfbsummon from install of directfb-0.9.25.1-1.el4.rf conflicts with file from package directfb-0.9.25.1-1.e l4.rf


I think I figure out this on my own. By some reason
rpm did not uninstall some x86_64 libraries. I uninstalled them
manually.
After that I was able to install all 32-bit packages.

rpm -qa --qf="%{n}-%{v}-%{r}.%{arch}\n" firefox 'mplayer*' | sort
firefox-1.5.0.12-0.3.el4.centos.i386
mplayer-1.0-0.38.rc1try2.el4.rf.i386
mplayer-codecs-20061022-1.i386
mplayer-codecs-extra-20061022-1.i386
mplayer-fonts-1.1-3.0.rf.noarch
mplayerplug-in-3.50-1.el4.rf.i386
mplayer-skins-1.8-1.nodist.rf.noarch




Alas video does not work ....
I just do not know what to do ...

Could you help me ?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Installing Adobe Flash Player on Konqueror, Epiphany and Other Browsers rm_-rf_windows Linux - Software 9 09-07-2007 06:26 PM
adobe flash played for RHEL -4 Update 5 ( 64bit) abhi019 LinuxQuestions.org Member Intro 3 08-13-2007 09:37 PM
Install Adobe Flash Player ankz.upadhyay Linux - Newbie 3 03-31-2007 06:37 AM
trying to install adobe flash player mwade38 Linux - Newbie 2 01-11-2007 11:13 AM
Looking for information on installing Flash Player & Adobe in CentOS4 ga.solutions Linux - Desktop 1 12-20-2006 04:45 AM


All times are GMT -5. The time now is 02:39 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration