LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   difficulty installing lighttpd+php5+fastcgi on Ubuntu 10.04 (http://www.linuxquestions.org/questions/linux-software-2/difficulty-installing-lighttpd-php5-fastcgi-on-ubuntu-10-04-a-807446/)

walterbyrd 05-12-2010 02:36 PM

difficulty installing lighttpd+php5+fastcgi on Ubuntu 10.04
 
Most tutorials do not mention anything about editing the lighttpd.conf file.

As I understand it, the following need to be modified:

The mod_fastcgi module needs to be loaded.

Code:

server.modules              = (
            "mod_access",
            "mod_alias",
            "mod_accesslog",
            "mod_compress",
            "mod_fastcgi",
#          "mod_rewrite",


And this code needs to be added - BTW: this keeps giving me an error. And most tutorials do not mention adding anything like this.
Code:

# fastcgi
fastcgi.server = ( ".php" => ((
                    "bin-path" => "/usr/bin/php-cgi",
                    "socket" => "/tmp/php.socket"
                )))


AlucardZero 05-12-2010 03:40 PM

What's your question? What have you done? What isn't working?

walterbyrd 05-13-2010 09:46 AM

Installed and tested lighttpd, it worked.

Code:

sudo apt-get install lighttpd
Installed php5-cgi

Code:

sudo apt-get install php5-cgi
Edited php.ini

Code:

sudo vi /etc/php5/cgi/php.ini

# put this line at the end of the file
cgi.fix_pathinfo = 1

Editited lighttpd.conf


Code:

sudo vi /etc/lighttpd/lighttpd.conf

# included mod_fastcgi

server.modules = (
“mod_access”,
“mod_alias”,
“mod_accesslog”,
“mod_fastcgi”,


# put the following code in the file
# the following seems to cause the parser error

fastcgi.server = ( “.php” => ((
“bin-path” => “/usr/bin/php5-cgi”,
“socket” => “/tmp/php.socket”
)))


Restart lighttpd,

Code:

# /etc/init.d/lighttpd restart
Duplicate config variable in conditional 0 global: fastcgi.server
2010-05-13 08:35:13: (configfile.c.907) source: /etc/lighttpd/conf-enabled/10-fastcgi.conf line: 27 pos: 1 parser failed somehow near here: (EOL)
2010-05-13 08:35:13: (configfile.c.907) source: /usr/share/lighttpd/include-conf-enabled.pl line: 2 pos: 1 parser failed somehow near here: (EOL)
2010-05-13 08:35:13: (configfile.c.907) source: /etc/lighttpd/lighttpd.conf line: 165 pos: 1 parser failed somehow near here: (EOL)


AlucardZero 05-13-2010 09:48 AM

Your quotes are wrong. Use regular quotes ("") not smart quotes (“”). You also seem to have two fastcgi.server directives. Inspect /etc/lighttpd/conf-enabled/10-fastcgi.conf and perhaps remove the one in lighttpd.conf. What's around line 165 in lighttpd.conf?

walterbyrd 05-13-2010 10:03 AM

Never mind, I got it. I found, and followed, this tutorial.

http://amselgrunwald.wordpress.com/2...-ubuntu-10-04/


All times are GMT -5. The time now is 10:28 AM.