LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 01-29-2004, 09:35 AM   #1
wmeler
Member
 
Registered: Dec 2003
Distribution: Linux Mint 15 (Cinnamon)
Posts: 215

Rep: Reputation: 18
DHCP problems and cable modem


Just made the leap to a cable modem through Earthlink (installed by Time Warner Cable...the guy told me it's the same as RoadRunner). Anyway, it's working fine for my Windoze laptop with DHCP. Trying to get my SuSE 8.1 Professional box running as well (in terms of a network connection via eth0 through the cable modem).

I know the hardware is working fine because I have ftp'ed (in my home network) to and from the Linux box many times on eth0 (using the same cables).

When I do an "ifup eth0" I get the following message:
"Starting DHCP Client Daemon on eth0... . . . . . . . . . . . . . . . no IP address yet... backgrounding"

Then if I try to do a ping, I get:
"connect: Network is unreachable"

Any help would be greatly appreciated
Thoughts of what's wrong--but no idea really:
1)DNS
2)DHCP configured wrong
3)Firewall on my machine is causing problems

Here's what I see if I do an ifconfig:

eth0 Link encap:Ethernet HWaddr 00:0C:F1:88:33:E2
UP BROADCAST NOTRAILERS RUNNING MULTICAST MTU:1500 Metric:1
RX packets:1034 errors:0 dropped:0 overruns:0 frame:0
TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:67167 (65.5 Kb) TX bytes:3564 (3.4 Kb)
Interrupt:18 Base address:0xddc0 Memory:fe9e0000-0

Then something similar for lo (Local Loopback).

Here's my /etc/sysconfig/network/dhcp file (without the comments):
DHCLIENT_BIN=""
DHCLIENT_DEBUG="no"
DHCLIENT_SET_HOSTNAME="no"
DHCLIENT_MODIFY_RESOLV_CONF="no"
DHCLIENT_SET_DEFAULT_ROUTE="yes"
DHCLIENT_MODIFY_NTP_CONF="no"
DHCLIENT_MODIFY_NIS_CONF="no"
DHCLIENT_SET_DOMAINNAME="yes"
DHCLIENT_KEEP_SEARCHLIST="no"
DHCLIENT_LEASE_TIME=""
DHCLIENT_TIMEOUT="999999"
DHCLIENT_REBOOT_TIMEOUT=""
DHCLIENT_HOSTNAME_OPTION="AUTO"
DHCLIENT_CLIENT_ID=""
DHCLIENT_VENDOR_CLASS_ID=""
DHCLIENT_RELEASE_BEFORE_QUIT="no"
DHCLIENT_SCRIPT_EXE=""
DHCLIENT_ADDITIONAL_OPTIONS=""
DHCLIENT_SLEEP="0"

Here's my /etc/sysconfig/network/ifcfg-eth0: (I have NO idea if any of these
are right or necessary):
BOOTPROTO='dhcp'
BROADCAST='24.136.225.255'
IPADDR='24.136.225.67
NETMASK='255.255.254.0'
NETWORK='24.136.224.0'
REMOTE_IPADDR=''
STARTMODE='onboot'
UNIQUE='60go.ZReZuYIS34D'
WIRELESS='no'
 
Old 01-29-2004, 09:52 AM   #2
qwijibow
Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
Whats your actuall network look like ?

if you want linux to access the internet, and your lan you must have 2 NIC's
the cable modem MUST be have its own dedicated NIC or the lan will not work.

to me, it looks like the dhcp client is looking for a dhcp server on the lan ?

anyway, How many NIC's does the linux machine have ?
do you have a hardware router ?
if not is the linux machine acting as the router ?
if not have you configured your gateway IP correctly ?
if the linux box is NOT acting as the router, is there a dhcp server running on the lan ?
if not you should configure static ip's.
 
Old 01-29-2004, 10:45 AM   #3
wmeler
Member
 
Registered: Dec 2003
Distribution: Linux Mint 15 (Cinnamon)
Posts: 215

Original Poster
Rep: Reputation: 18
I have one NIC. It's a gigabit ethernet card. I have it connected directly to the cable modem box.

I do not have a router and have done NO home networking.
I do not think the linux machine is acting as a router. I do not know though.
I think I set the gateway properly. I put the same gateway as for DHCP on the Windoze laptop (which is totally disconnected, by the way...I don't mean to confuse you).

Any ideas or anything I should check?
 
Old 01-29-2004, 10:45 AM   #4
wmeler
Member
 
Registered: Dec 2003
Distribution: Linux Mint 15 (Cinnamon)
Posts: 215

Original Poster
Rep: Reputation: 18
(Oops...didn't mean to say "for DHCP" in that last reply...disregard that.)
 
Old 01-29-2004, 12:16 PM   #5
wmeler
Member
 
Registered: Dec 2003
Distribution: Linux Mint 15 (Cinnamon)
Posts: 215

Original Poster
Rep: Reputation: 18
Also, for clarification, when I said "if I try to do a ping"...I was referring to pinging something on the internet, like the gateway.
 
Old 01-29-2004, 12:39 PM   #6
coolamit78
Member
 
Registered: Aug 2003
Location: New Delhi, India
Distribution: RHEL AS 3/4, Windows XP
Posts: 546

Rep: Reputation: 31
well, if your ISP has given you a dynamic IP address, then you do not need to manually assign it.

What i recommend is,

1. as root, use the 'netconfig' command to open the network configuration window. { In Redhat linux, we also have a command called 'neat' that does the same job }

2. now select 'DHCP' or 'Dynamic IP' whatever is the option in that menu.

3. Now Select 'OK'

All the rest of the information for your machine, for eg, the netmask, the gateway etc will be automatically filled in that file.

4. Now after making changes, give the command

ifup eth0

Note - > Compare the values in the file /etc/sysconfig/network/ifcfg-eth0 after following above steps with the previous settings....

{Add Network Address, Broadcast address to it in case you arent successful even after following the above-mentioned steps. }

Regards,

amit
 
Old 01-29-2004, 04:49 PM   #7
wmeler
Member
 
Registered: Dec 2003
Distribution: Linux Mint 15 (Cinnamon)
Posts: 215

Original Poster
Rep: Reputation: 18
Fixed it...a friend helped me...posting this for completeness in case someone else has this problem

I wrote what I did below...you can see the response that got me on track as well.

Thanks for all your help everyone!
wmeler

-------MY RESPONSE TO THE PROBLEM GETTING SOLVED----

Thanks...you were dead on with #3! As soon as I set it to yes...boom...I could ping the gateway. (My gut was the firewall too, but I would have never guessed why, so thanks again.)

Two more things I had to fix after that though...
1. I set the hostname to what I call my machine and the domain to "local". I then clicked OFF the "Change hostname via DHCP." I clicked ON the "Update name servers and search list via DHCP."

Also, I set the router Gateway to xxx.yyy.xxx.1

(Trying to be complete for the archive.)

wmeler

-----SUGGESTION THAT GOT ME ON THE RIGHT TRACK---------
> > Thoughts of what's wrong--but no idea really:
> > 1)DNS
>
> If you can't get a network connection the DNS isn't
> going to work anyway
> - the problem is unlikely to lie there at this stage
>
> > 2)DHCP configured wrong
>
> Hmmm maybe... Some cablemodem services (SFAIUI)
> 'lock' onto a single MAC
> address - you could try getting your NIC to spoof
> the MAC address of
> the NIC on the Win box
>
> > 3)Firewall on my machine is causing problems
>
> In YaST>System>Editor for SuSE config files -
> network - firewall make
> sure the FW_SERVICES_DHCLIENT setting is "yes" and
> try again
>
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
cable modem and dhcp dead_p00l Linux - Networking 3 11-30-2003 02:29 AM
Redhat 9 ntl cable modem dhcp problems Bamber Linux - Networking 7 08-22-2003 10:24 AM
Problems with DHCP and Comcast cable modem Internet access tomdkat Linux - Networking 2 07-23-2003 01:17 PM
Cable Modem - How-to DHCP ? iraysyvalo Linux - Networking 17 07-16-2003 09:28 AM
DHCP set-up for cable-modem iraysyvalo Debian 5 07-16-2003 08:34 AM


All times are GMT -5. The time now is 06:25 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration