LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Device eth0 has a mac address xx:xx instead of configured xx:xx . Ignoring . (http://www.linuxquestions.org/questions/linux-software-2/device-eth0-has-a-mac-address-xx-xx-instead-of-configured-xx-xx-ignoring-894573/)

sethusubbiah 07-29-2011 09:15 PM

Device eth0 has a mac address xx:xx instead of configured xx:xx . Ignoring .
 
hi ,

I am trying to perform VM cloning using KVM in a centos 5.6 machines. I copy the memory contents of a running vm to an external state file and try to use that to start another VM in a different machine. While starting the cloned VM I provide a different mac address but once it resumes it has the old one . I tried changing the mac address in ifcfg-eth0 but I get the error :

Device eth0 has a mac address xx:xx instead of configured xx:xx . Ignoring .

Is there some way to change the ip/mac of the cloned vm without the need to restart the VM ( Then the purpose of cloning will be defeated). Thanks a lot for the info .

- Sethu

sethusubbiah 07-29-2011 09:34 PM

I found the solution. Sorry for posting this question. I solved it using :

ifconfig eth0 hw ether XX:XX

and

service network restart.

ifconfig eth0 , I found the new ip address there !!

Thanks !!

bgraves 12-13-2013 03:23 PM

Finally, some help. Thanks!

I found that your fix works until I reboot, then I have the same problem again. A fix that seems to persist after a reboot is to instead edit the mac address in the ifcfg-eth0 file to match the one shown for eth0 with "ifconfig -a", like this:

1) ifconfig -a
2) Get the "HWaddr" setting.
3) vi /etc/sysconfig/network-scripts/ifcfg-eth0
4) Change the "HWADDR" setting to the one found in step 2).
5) service network restart


All times are GMT -5. The time now is 07:57 PM.