LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 01-15-2011, 11:52 AM   #1
hellocatfood
LQ Newbie
 
Registered: Apr 2010
Distribution: Ubuntu
Posts: 6

Rep: Reputation: 0
/dev/fb0: No such file or directory


I'm attempting to use fbgrab and fbcat, but it requires /dev/fb0 to exist. I've checked in /dev/ and it unfortunately doesn't exist

How can I create this file? My computer specs are in my signature and I'm using the proprietary ATI Radeon 4500 graphics driver
 
Old 01-15-2011, 11:56 AM   #2
stress_junkie
Senior Member
 
Registered: Dec 2005
Location: Massachusetts, USA
Distribution: Ubuntu 10.04 and CentOS 5.5
Posts: 3,873

Rep: Reputation: 331Reputation: 331Reputation: 331Reputation: 331
Did you look at the Frambuffer HowTo page that is linked from the fbgrab home page?
http://hem.bredband.net/gmogmo/fbgrab/

http://www.tldp.org/HOWTO/Framebuffer-HOWTO/
 
Old 01-15-2011, 12:01 PM   #3
hellocatfood
LQ Newbie
 
Registered: Apr 2010
Distribution: Ubuntu
Posts: 6

Original Poster
Rep: Reputation: 0
I've tried reading up on the part specific to ATI cards but I don't trust instructions that are untested.
 
Old 01-15-2011, 02:15 PM   #4
adamk75
Senior Member
 
Registered: May 2006
Posts: 3,091

Rep: Reputation: 397Reputation: 397Reputation: 397Reputation: 397
You will want to use the vesa framebuffer if you are going to stick with the proprietary drivers. Assuming your kernel has support for it, you'll need to pass vga=somemode to the kernel. Check the "What VESA modes are available to me?" part of the document you were looking at.

Adam
 
Old 01-17-2011, 08:16 AM   #5
vonbiber
Member
 
Registered: Apr 2009
Distribution: slackware
Posts: 299

Rep: Reputation: 50
1. first check that framebuffer is enabled in your kernel
Execute this command
Code:
zcat /proc/config.gz | grep -v '^#' | grep FB
It should return something like
Code:
...
CONFIG_FB=y
CONFIG_FB_BOOT_VESA_SUPPORT=y
...
2. If the answer is yes you should have in your boot options
(your grub menu or lilo menu) something like
Code:
vga=791
or vga=792, etc. according to your screen size and resolution
(If you have a 15-inch, 791 should be fine)

If framebuffer is not enabled in your kernel you'll have to
rebuild the kernel by enabling these options first
 
  


Reply

Tags
ati, xorg


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
/dev/fb0: No such device but i can see it marius_c Linux - Software 5 02-18-2010 12:58 AM
/dev/fb0 Not found when first running X CD1212 Linux From Scratch 4 01-17-2010 08:56 PM
mplayer: Can't open /dev/fb0: Permission denied jojoii Linux - Software 2 09-21-2008 06:56 PM
/dev/fb0: No such file or directory mukeshj Linux - Software 2 09-04-2005 12:15 PM
udev : framebuffer device (/dev/fb0) default permissions keefaz Slackware 6 07-04-2004 07:54 PM


All times are GMT -5. The time now is 09:41 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration