LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   /dev/fb0: No such file or directory (http://www.linuxquestions.org/questions/linux-software-2/dev-fb0-no-such-file-or-directory-856496/)

hellocatfood 01-15-2011 10:52 AM

/dev/fb0: No such file or directory
 
I'm attempting to use fbgrab and fbcat, but it requires /dev/fb0 to exist. I've checked in /dev/ and it unfortunately doesn't exist

How can I create this file? My computer specs are in my signature and I'm using the proprietary ATI Radeon 4500 graphics driver

stress_junkie 01-15-2011 10:56 AM

Did you look at the Frambuffer HowTo page that is linked from the fbgrab home page?
http://hem.bredband.net/gmogmo/fbgrab/

http://www.tldp.org/HOWTO/Framebuffer-HOWTO/

hellocatfood 01-15-2011 11:01 AM

I've tried reading up on the part specific to ATI cards but I don't trust instructions that are untested.

adamk75 01-15-2011 01:15 PM

You will want to use the vesa framebuffer if you are going to stick with the proprietary drivers. Assuming your kernel has support for it, you'll need to pass vga=somemode to the kernel. Check the "What VESA modes are available to me?" part of the document you were looking at.

Adam

vonbiber 01-17-2011 07:16 AM

1. first check that framebuffer is enabled in your kernel
Execute this command
Code:

zcat /proc/config.gz | grep -v '^#' | grep FB
It should return something like
Code:

...
CONFIG_FB=y
CONFIG_FB_BOOT_VESA_SUPPORT=y
...

2. If the answer is yes you should have in your boot options
(your grub menu or lilo menu) something like
Code:

vga=791
or vga=792, etc. according to your screen size and resolution
(If you have a 15-inch, 791 should be fine)

If framebuffer is not enabled in your kernel you'll have to
rebuild the kernel by enabling these options first


All times are GMT -5. The time now is 07:11 AM.