LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 01-19-2010, 11:21 AM   #1
hudsonryde
LQ Newbie
 
Registered: Dec 2009
Location: Oklahoma
Distribution: Ubuntu 9.10
Posts: 28

Rep: Reputation: 15
Desktop Effects used to work now they don't!


k, I've been running Karmic for awhile now, and I had all my desktop effects and eye candy set up perfectly, and then i made the mistake of thinking I knew things about linux.... haha

my flash was running slow, and i was attempting various fixes i found online, including mussing in the xorg.conf. well i somehow managed to disable my laptop's ability to run any sort of eye candy, I know it's capable since i've done it before.

i have the standard Intel integrated graphics card that a million other people have, yadda yadda. the main problem(i believe) is getting to where i can select "Normal" under Visual Effects, but when i try all I get is the lovely "Desktop effects could not be enabled" message. hoorah. any help would be GREATLY appreciated.
 
Old 01-19-2010, 03:08 PM   #2
manwichmakesameal
Member
 
Registered: Aug 2006
Distribution: Slackware
Posts: 800

Rep: Reputation: 100Reputation: 100
You should probably post your xorg.conf since you edited it.
 
Old 01-19-2010, 08:54 PM   #3
hudsonryde
LQ Newbie
 
Registered: Dec 2009
Location: Oklahoma
Distribution: Ubuntu 9.10
Posts: 28

Original Poster
Rep: Reputation: 15
well, when I tried to edit the xorg.conf, it was blank, so i tried adding what i needed and it messed stuff up, so deleted the changes i made, so now, as far as I can tell, I still have a blank xorg.conf
 
Old 01-20-2010, 02:18 AM   #4
Vampirite
Member
 
Registered: Apr 2005
Location: England
Distribution: Arch Linux
Posts: 223

Rep: Reputation: 30
Delete your xorg.conf completely, X may just autodetect everything and it should be fine, otherwise run this:
Code:
dpkg-reconfigure xserver-xorg
 
Old 01-20-2010, 11:07 AM   #5
hudsonryde
LQ Newbie
 
Registered: Dec 2009
Location: Oklahoma
Distribution: Ubuntu 9.10
Posts: 28

Original Poster
Rep: Reputation: 15
hmm...I'm not entirely sure how to delete the xorg.conf haha, any help that would be appreciated.

and as far as reconfiguring it, that was one of the first things i tried, but i did it again just now, for measure, and still get the fun little "Desktop effects could not be enabled." message
 
Old 01-21-2010, 07:21 AM   #6
kalaka
LQ Newbie
 
Registered: Jul 2008
Posts: 2

Rep: Reputation: 1
The new release of X (which comes with Karmic) no longer requires an xorg.conf. Integrated Intel cards should be autoconfigured (I have one on my laptop, which also runs Karmic).

My advice to you is to delete xorg.conf with
Code:
sudo rm /etc/X11/xorg.conf
and then reinstall the intel driver (called xserver-xorg-video-intel)
Code:
sudo apt-get install xserver-xorg-video-intel
If you get a message saying "program already installed" you can download the .deb file from one of these links and select the "reinstall package" option.


I hope I helped, good luck!
 
Old 01-22-2010, 09:45 AM   #7
pjeeanah
LQ Newbie
 
Registered: Dec 2006
Posts: 13

Rep: Reputation: 1
I think the problem is with with the intel driver. I have a link for jaunty, but exactly the same instructions work for karmic. Here's the link:



https://wiki.ubuntu.com/ReinhardTart...telDriverTo2.4


Cheers
 
Old 01-22-2010, 10:46 AM   #8
pjeeanah
LQ Newbie
 
Registered: Dec 2006
Posts: 13

Rep: Reputation: 1
NB: If you dont know how to configure your firewall, just skip the keyserver step. You will get a security warning, but go ahead and say yes to install the package.
 
Old 02-22-2010, 02:15 PM   #9
hudsonryde
LQ Newbie
 
Registered: Dec 2009
Location: Oklahoma
Distribution: Ubuntu 9.10
Posts: 28

Original Poster
Rep: Reputation: 15
awesome thank you all, sorry I've been a bit out of the loop but I shall try this today!
 
  


Reply

Tags
compiz, desktop, effects


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
5.4 - scientific linux enabling desktop effects does not work pcandpc Linux - Enterprise 5 12-05-2009 06:36 AM
Can't get desktop effects to work outside of root user mothergoose729 Slackware 17 11-23-2009 08:40 PM
Dell Inspiron 1525 (Cant get desktop effects to work!?!?!?!) cornelp Linux - Newbie 3 07-30-2008 12:34 AM
screen reso for gutsy's desktop effects to work gonzolono Linux - Newbie 0 12-03-2007 12:34 PM
[FC6]Chipbench via Desktop Effects won't work gedanken Fedora 0 11-28-2006 10:17 AM


All times are GMT -5. The time now is 07:04 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration