LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 05-15-2008, 11:26 PM   #1
SirTristan
Member
 
Registered: Feb 2006
Distribution: GNU/Linux
Posts: 54

Rep: Reputation: 15
Dependency problems with 'yum' installing xorg-x11-tools


I'm trying to install xorg-x11-tools (on GNU/Linux 2.6.9-55.ELsmp), but "yum install xorg-x11-tools" gives the following error:
Code:
...
--> Finished Dependency Resolution
Error: Missing Dependency: xorg-x11-libs = 6.8.2-1.EL.13.37.2 is needed by package xorg-x11
Error: Missing Dependency: xorg-x11-libs = 6.8.2-1.EL.13.37.2 is needed by package xorg-x11-xfs
However "yum install xorg-x11-libs" says:
Code:
Finished
Parsing package install arguments
Nothing to do
And "yum list" says:
Code:
xorg-x11-Mesa-libGL.i386                 6.8.2-1.EL.33.0.2      installed       
xorg-x11-devel.i386                      6.8.2-1.EL.33.0.2      installed       
xorg-x11-libs.i386                       6.8.2-1.EL.33.0.2      installed
And "yum check-update" doesn't list any x11 packages as needing an update.

What's the issue here? Why is it saying I need dependency packages that I already have newer versions for? Am I using yum wrong?
 
Old 05-17-2008, 09:29 AM   #2
bigrigdriver
LQ Addict
 
Registered: Jul 2002
Location: East Centra Illinois, USA
Distribution: Debian Squeeze
Posts: 5,805

Rep: Reputation: 324Reputation: 324Reputation: 324Reputation: 324
There is a difference between *update* and *upgrade*.

Your xorg.x11-libs may be up-to-date, but the version needs to be upgraded to a higher version for the xorg-x11-tools package you want to install.

Run yum update to get your repository information up-to-date, then run yum upgrade xorg-x11-libs to upgrade the package to a higher version number.

Last edited by bigrigdriver; 05-17-2008 at 09:30 AM.
 
Old 05-17-2008, 02:39 PM   #3
SirTristan
Member
 
Registered: Feb 2006
Distribution: GNU/Linux
Posts: 54

Original Poster
Rep: Reputation: 15
I ran 'yum update' (bash was the only package needing an update, that updated fine), then ran updgrade, but it said:
Code:
# yum upgrade xorg-x11-libs           
Repository dell-testing is listed more than once in the configuration
Setting up Upgrade Process
Setting up repositories
Reading repository metadata in from local files
Excluding Packages in global exclude list
Finished
Could not find update match for xorg-x11-libs
No Packages marked for Update/Obsoletion
I think my xorg-x11-libs is already up to date. I think the version 'yum list installed' gives, 6.8.2-1.EL.33.0.2, is higher than the 6.8.2-1.EL.13.37.2 version that yum says is needed.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to install xorg-x11 via yum guarriman Fedora 2 07-02-2007 08:49 AM
Problems installing mozilla-devel, strange yum dependency error Fegenbush Linux - Software 1 02-01-2007 01:38 PM
xorg-x11-devel dependant on old version of xorg-x11-libs thetawaverider Linux - Software 1 11-09-2006 08:22 AM
updating xorg-x11 with yum on FC3 volvogga Linux - Newbie 6 06-01-2005 01:28 AM
xorg-x11-libs required by xorg-x11-devel darknails Fedora 1 01-13-2005 03:34 PM


All times are GMT -5. The time now is 08:51 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration