LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 10-19-2002, 05:06 PM   #1
wafyellow
LQ Newbie
 
Registered: Oct 2002
Distribution: mandrake 9.0 (with KDE 3.0)
Posts: 3

Rep: Reputation: 0
dependency problem installing openh323 to run gnomemeeting


G'day,

I'm running Mandrake 9.0. I want to run gnomemeeting. To run it you need to install openh323 and pwlib. When I try to install both, I get the same dependency problem message--I need libstdc++.so.5(glibcpp_3.1).

OK, so I found a mandrake rpm (libstdc++5-3.2-1mdk.i586.rpm) and installed it. But I still get the same dependency error when trying to install openh323. I've run ldconfig and updatedb (I don't really know what they do but I have read elsewhere that they can fix some dependency problems), but that didn't work either.

So how can I get libstdc++.so.5 installed and recognized?

Thanks,

wafyellow
 
Old 10-20-2002, 04:45 AM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,535

Rep: Reputation: 148Reputation: 148
You should install the libstdc++ package for your system (Mandrake 9.0). Then the other ones should install, too. In case you can't get it running use --force option of RPM.
 
Old 10-20-2002, 05:43 PM   #3
wafyellow
LQ Newbie
 
Registered: Oct 2002
Distribution: mandrake 9.0 (with KDE 3.0)
Posts: 3

Original Poster
Rep: Reputation: 0
Hi Mara,

Still no luck.

>You should install the libstdc++ package for your system (Mandrake 9.0).

I tried that, no luck.

>In case you can't get it running use >--force option of RPM.

I also tried that (by unchecking check dependencies in Kpackage), no luck.

I even tried reinstalling linux with many of the development packages installed - the gnuc++ libraries, etc., in case that worked. No luck.

libstdc++.s05 is *definitely* there, I can see it, but nothing will recognise it.

Any other ideas?

Wafyellow
 
Old 10-23-2002, 12:11 PM   #4
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,535

Rep: Reputation: 148Reputation: 148
Are you trying to install the right version for gnomemeeting package (for your version of Mandrake)?
BTW
rpm -i gromemeetingpackagename --force
will always install it. The problem is that it may not be working, but you can always try this method.

Last edited by Mara; 10-23-2002 at 12:15 PM.
 
Old 10-23-2002, 03:42 PM   #5
wafyellow
LQ Newbie
 
Registered: Oct 2002
Distribution: mandrake 9.0 (with KDE 3.0)
Posts: 3

Original Poster
Rep: Reputation: 0
Hi Mara,

Just before I received notification of your post I managed to get it installed by deleting everything about it--it and its dependent packages, the glib and libstdc devel libraries--and then reinstalling it by checking for it on my mandrake distro disks. It installed itself and the two dependent libaries, with no mention of libstdc++.so5, and seems to be working fine.

What worries me now is that I was sure I got the mandrake rpms (e.g. gnomemeeting-0.93-2mdk.i586.rpm and the two others), but it didn't work, and yet when I installed the version on my distro disks, it did. I guess it's a compile thing--that the version out there was released before mandrake 9.0 and so isn't quite compiled right?

One question, though, about your last message. Is installing through Kpackage and unchecking the dependency requirement is *not* quite the same as using the --force variable? Is it better to install via the command line - more information? (Sorry, that was two questions).

Thankyou for your help,

wafyellow
 
Old 10-24-2002, 12:23 PM   #6
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,535

Rep: Reputation: 148Reputation: 148
Mandrake 9.0 uses other gcc version than older Mandrakes. The thing is that libstdc++ is directly connected with the compiler. With a new compiler you have a newer version. The rpm you had was compiled for older libstdc++. That's why there was a dependency problem. In most cases it doesn't matter, programs work whichever version you have, but rpm format is quite strict and....

Kpackage + unchecking dependencies is nearly the same as --force option. It's your choice which method you prefer. When you like Kpackage, it's absolutely OK. I prefer console tools.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Could not open sound device Pwlib OPenh323 ohphone problem branens Linux - General 3 11-22-2009 10:42 AM
Dependency problem installing gnomemeeting: libsoup belga Linux - Software 1 07-28-2004 11:47 AM
Installing backport of Firefox on woody - dependency problem wolfpeach Debian 3 06-24-2004 02:38 AM
Problems Installing openh323 JonyKyte Linux - Newbie 0 02-14-2004 12:02 PM
dependency problem by installing j2sdk-1_4_2-linux-i586.rpm linuxJaver Slackware 8 07-05-2003 12:04 PM


All times are GMT -5. The time now is 07:26 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration