LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 11-21-2004, 05:34 PM   #1
canyon289
Member
 
Registered: Sep 2004
Posts: 125

Rep: Reputation: 15
dependency problem


when i try to run yum upgrade i get this
Password:
[root@localhost ravin]# yum upgrade
Setting up Upgrade Process
Setting up Repo: dag
repomd.xml 100% |=========================| 951 B 00:00
Setting up Repo: updates-released
repomd.xml 100% |=========================| 951 B 00:00
Setting up Repo: base
repomd.xml 100% |=========================| 1.1 kB 00:00
Setting up Repo: atrpms-stable
repomd.xml 100% |=========================| 951 B 00:00
Setting up Repo: newrpms
repomd.xml 100% |=========================| 1.1 kB 00:00
Setting up Repo: freshrpms
repomd.xml 100% |=========================| 843 B 00:00
Reading repository metadata in from local files
dag : ################################################## 1178/1178
updates-re: ################################################## 222/222
base : ################################################## 2622/2622
atrpms-sta: ################################################## 622/622
newrpms : ################################################## 226/226
freshrpms : ################################################## 442/442
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package librpm4.3.i386 0:4.3.2-21_34.rhfc3.at set to be updated
---> Package perl-XML-Parser.i386 0:2.34-5_2.rhfc3.at set to be updated
---> Package tvtime.i386 0:0.9.15-1.1.fc3.rf set to be updated
---> Package rpm.i386 0:4.3.2-21_34.rhfc3.at set to be updated
---> Package libdvdread.i386 0:0.9.4-5.1.fc3.rf set to be updated
---> Package aalib.i386 0:1.4.0-5.1.fc3.rf set to be updated
---> Package alsa-lib-devel.i386 0:1.0.7-17.rhfc3.at set to be updated
---> Package meanwhile.i386 0:0.3-1.1.fc3.rf set to be updated
---> Package libacl.i386 0:2.2.23-5_11.rhfc3.at set to be updated
---> Package libxml2-devel.i386 0:2.6.16-3_15.rhfc3.at set to be updated
---> Package ogle.i386 0:0.9.2-4.1.fc3.rf set to be updated
---> Package libfame.i386 0:0.9.1-4.1.fc3.rf set to be updated
---> Package apt.i386 1:0.5.15cnc6-53.1.rhfc3.at set to be updated
---> Package libxml2-python.i386 0:2.6.16-3_15.rhfc3.at set to be updated
---> Package gnupg.i386 0:1.2.6-1_22.rhfc3.at set to be updated
---> Package gamin.i386 0:0.0.17-1.FC3 set to be updated
---> Package mutt.i386 5:1.4.2-0_10.rhfc3.at set to be updated
---> Package gamin-devel.i386 0:0.0.17-1.FC3 set to be updated
---> Package wxGTK.i386 0:2.4.2-5.1.fc3.rf set to be updated
---> Package docbook-utils-pdf.noarch 0:0.6.14-4_6.at set to be updated
---> Package faac.i386 0:1.24-1.1.fc3.rf set to be updated
---> Package xrestop.i386 0:0.3-1.1.fc3.rf set to be updated
---> Package yum.noarch 0:2.1.11-3_42.rhfc3.at set to be updated
---> Package rpm-devel.i386 0:4.3.2-21_34.rhfc3.at set to be updated
---> Package docbook-style-dsssl.noarch 0:1.78-4_6.at set to be updated
---> Package popt.i386 0:1.9.1-21_34.rhfc3.at set to be updated
---> Package docbook-dtds.noarch 0:1.0-25_9.at set to be updated
---> Package libpostproc.i386 4:1.0-36_pre5.rhfc3.at set to be updated
---> Package fetchmail.i386 0:6.2.5-6_3.rhfc3.at set to be updated
---> Package mplayer.i386 4:1.0-36_pre5.rhfc3.at set to be updated
---> Package Gtk-Perl.i386 0:0.7008-37.1.fc3.rf set to be updated
---> Package pan.i386 1:0.14.2.91-2.1.fc3.rf set to be updated
---> Package ffmpeg.i386 0:0.4.9-0.20041110.1.1.fc3.fr set to be updated
---> Package audacity.i386 0:1.2.2-1.1.fc3.rf set to be updated
---> Package libdv.i386 0:0.103-4.rhfc3.at set to be updated
---> Package libmpeg3.i386 0:1.5.4-3.1.fc3.rf set to be updated
---> Package a52dec.i386 0:0.7.4-7.1.fc3.rf set to be updated
---> Package mjpegtools.i386 0:1.6.2-8.rhfc3.at set to be updated
---> Package dvgrab.i386 0:1.6-1.1.fc3.rf set to be updated
---> Package alsa-lib.i386 0:1.0.7-17.rhfc3.at set to be updated
---> Package flac.i386 0:1.1.1-6.rhfc3.at set to be updated
---> Package transcode.i386 0:0.6.14-0.pre1.1.1.fc3.fr set to be updated
---> Package xmlto.i386 0:0.0.18-4_4.rhfc3.at set to be updated
---> Package beecrypt.i386 0:3.1.0-6_5.rhfc3.at set to be updated
---> Package libmad.i386 0:0.15.1b-3.1.fc3.rf set to be updated
---> Package docbook-style-xsl.noarch 0:1.65.1-2_8.at set to be updated
---> Package lm_sensors.i386 0:2.8.8-0_35.rhfc3.at set to be updated
---> Package alsa-utils.i386 0:1.0.7-11.rhfc3.at set to be updated
---> Package libsamplerate.i386 0:0.1.2-1.1.fc3.rf set to be updated
---> Package sgml-common.noarch 0:0.6.3-17_11.at set to be updated
---> Package lftp.i386 0:3.0.11-18.rhfc3.at set to be updated
---> Package dosbox.i386 0:0.63-1.rhfc3.nr set to be updated
---> Package spamassassin.i386 0:3.0.1-0_19.rhfc3.at set to be updated
---> Package libdvdcss.i386 0:1.2.8-4.1.fc3.rf set to be updated
---> Package apt-devel.i386 0:0.5.15cnc6-3.1.fc3.rf set to be updated
---> Package pyxf86config.i386 0:0.3.19-1_4.rhfc3.at set to be updated
---> Package planner.i386 0:0.12.1-1.1.fc3.rf set to be updated
---> Package perl-XML-Twig.noarch 0:3.15-0_8.rhfc3.at set to be updated
---> Package rpm-build.i386 0:4.3.2-21_34.rhfc3.at set to be updated
---> Package libsndfile.i386 0:1.0.11-6.rhfc3.at set to be updated
---> Package libid3tag.i386 0:0.15.1b-3.1.fc3.rf set to be updated
---> Package libxml2.i386 0:2.6.16-3_15.rhfc3.at set to be updated
---> Package lzo.i386 0:1.08-3.1.fc3.rf set to be updated
---> Package libgcrypt.i386 0:1.2.0-9.rhfc3.at set to be updated
---> Package faad2.i386 0:2.0-2.20040923.1.fc3.rf set to be updated
---> Package lame.i386 0:3.96.1-10.rhfc3.at set to be updated
---> Package rpm-python.i386 0:4.3.2-21_34.rhfc3.at set to be updated
---> Package xvidcore.i386 0:1.0.2-6.rhfc3.at set to be updated
---> Package imlib2.i386 0:1.1.2-3.rhfc3.at set to be updated
---> Package freeglut.i386 0:2.2.0-14_7.rhfc3.at set to be updated
---> Package xml-common.noarch 0:0.6.3-17_11.at set to be updated
---> Package acl.i386 0:2.2.23-5_11.rhfc3.at set to be updated
---> Package libxslt.i386 0:1.1.12-2_7.rhfc3.at set to be updated
---> Package perl-XML-LibXML.i386 0:1.58-2.rhfc3.at set to be updated
---> Package diffstat.i386 0:1.34-0_5.rhfc3.at set to be updated
---> Package libacl-devel.i386 0:2.2.23-5_11.rhfc3.at set to be updated
---> Package perl-HTML-Parser.i386 0:3.36-0_2.rhfc3.at set to be updated
---> Package openjade.i386 0:1.3.2-14_7.1.rhfc3.at set to be updated
---> Package libxslt-devel.i386 0:1.1.12-2_7.rhfc3.at set to be updated
---> Package mplayer-fonts.noarch 4:1.0-6.at set to be updated
---> Package libraw1394.i386 0:0.10.1-3_3.rhfc3.at set to be updated
---> Package syslinux.i386 0:2.11-2.1.fc3.rf set to be updated
---> Package ogmtools.i386 0:1.5-1.1.fc3.rf set to be updated
---> Package subtitleripper.i386 0:0.3.4-1.1.fc3.rf set to be updated
---> Package unrar.i386 0:3.4.3-1.1.fc3.rf set to be updated
---> Package docbook-utils.noarch 0:0.6.14-4_6.at set to be updated
---> Package synaptic.i386 0:0.55.1-1.1.fc3.rf set to be updated
--> Running transaction check
--> Processing Dependency: libFLAC++.so.2 for package: k3b
--> Processing Dependency: libasound.so.2(ALSA_0.9.0rc4) for package: pwlib
--> Processing Dependency: libxml2.so.2 for package: libxklavier
--> Processing Dependency: libxml2.so.2 for package: gnome-kerberos
--> Processing Dependency: libxml2.so.2 for package: libsoup
--> Processing Dependency: libasound.so.2 for package: kdeaddons
--> Processing Dependency: libxml2.so.2 for package: rhn-applet
--> Processing Dependency: libxslt.so.1 for package: abiword
--> Processing Dependency: libasound.so.2 for package: mplayer
--> Processing Dependency: libxml2.so.2 for package: libgnomeprint22
--> Processing Dependency: libxslt1= 1.1.12 for package: libxslt-devel
--> Processing Dependency: libxml2.so.2 for package: eog
--> Processing Dependency: libxml2.so.2 for package: libwpd
--> Processing Dependency: libsndfile1= 1.0.11 for package: libsndfile
--> Processing Dependency: libxml2.so.2 for package: gnome-utils
--> Processing Dependency: libxml2.so.2 for package: gnome-bluetooth
--> Processing Dependency: libsndfile.so.1 for package: libsamplerate
--> Processing Dependency: libSDL_sound-1.0.so.1 for package: dosbox
--> Processing Dependency: libxml2.so.2 for package: bluez-pin
--> Processing Dependency: /etc/apt/sources.list for package: apt
--> Processing Dependency: libxml2.so.2 for package: dasher
--> Processing Dependency: libsndfile.so.1(libsndfile.so.1.0) for package: audacity
--> Processing Dependency: libexslt.so.0 for package: kdewebdev
--> Processing Dependency: libxml2.so.2 for package: ggv
--> Processing Dependency: libxml2.so.2 for package: libgsf
--> Processing Dependency: libasound.so.2 for package: gnome-libs
--> Processing Dependency: libxml2.so.2 for package: gnome-session
--> Processing Dependency: libxml2_2= 2.6.16 for package: libxml2
--> Processing Dependency: libxml2.so.2 for package: gnome-panel
--> Processing Dependency: libasound.so.2(ALSA_0.9) for package: control-center
--> Processing Dependency: libasound.so.2 for package: kdenetwork
--> Processing Dependency: libasound.so.2 for package: koffice
--> Processing Dependency: libxml2.so.2 for package: gtkhtml2
--> Processing Dependency: libxml2.so.2 for package: vino
--> Processing Dependency: libxml2.so.2 for package: gok
--> Processing Dependency: libasound.so.2 for package: gdk-pixbuf-gnome
--> Processing Dependency: libxml2.so.2 for package: xfce4-systray
--> Processing Dependency: libasound.so.2(ALSA_0.9) for package: pwlib
--> Processing Dependency: libxml2.so.2 for package: gnome-terminal
--> Processing Dependency: libxml2.so.2 for package: libbonobo
--> Processing Dependency: libxml2.so.2 for package: gstreamer-plugins
--> Processing Dependency: libasound.so.2 for package: SDL_image
--> Processing Dependency: libxml2.so.2 for package: yelp
--> Processing Dependency: libXvMCNVIDIA_dynamic.so.1 for package: mplayer
--> Processing Dependency: libxml2.so.2 for package: nautilus-cd-burner
--> Processing Dependency: libxml2.so.2 for package: NetworkManager-gnome
--> Processing Dependency: libxml2.so.2 for package: libgal2
--> Processing Dependency: libxslt.so.1 for package: kdewebdev
--> Processing Dependency: libxml2.so.2 for package: shared-mime-info
--> Processing Dependency: libxslt.so.1 for package: yelp
--> Processing Dependency: libasound.so.2 for package: libgnomeprint15
--> Processing Dependency: libasound.so.2 for package: gnome-print
--> Processing Dependency: libxml2.so.2 for package: scrollkeeper
--> Processing Dependency: libsndfile.so.1 for package: libsndfile
--> Processing Dependency: libxml2.so.2 for package: pygtk2-libglade
--> Processing Dependency: libxslt.so.1 for package: koffice
--> Processing Dependency: libasound.so.2 for package: control-center
--> Processing Dependency: libasound.so.2 for package: kdepim
--> Processing Dependency: libasound.so.2(ALSA_0.9.0rc8) for package: alsa-lib
--> Processing Dependency: libxslt.so.1 for package: alchemist
--> Processing Dependency: libdv.so.4 for package: transcode
--> Processing Dependency: libFLAC.so.4 for package: kdemultimedia
--> Processing Dependency: libasound.so.2(ALSA_0.9.5) for package: alsa-lib
--> Processing Dependency: libxml2.so.2 for package: eel2
--> Processing Dependency: libxml2.so.2 for package: gdm
--> Processing Dependency: atrpms-perl-module-helper for package: perl-XML-Twig
--> Processing Dependency: libxml2.so.2 for package: libgnomecanvas
--> Processing Dependency: libxml2.so.2 for package: gnome-games
--> Processing Dependency: libxml2.so.2 for package: gstreamer
--> Processing Dependency: libasound2= 1.0.7 for package: alsa-lib
--> Processing Dependency: libxml2.so.2 for package: grip
--> Processing Dependency: libosp.so.3 for package: libofx
--> Processing Dependency: libasound.so.2 for package: ogle
--> Processing Dependency: libxml2.so.2 for package: rhythmbox
--> Processing Dependency: libxml2.so.2 for package: abiword
--> Processing Dependency: libxml2.so.2 for package: gthumb
--> Processing Dependency: libxml2.so.2 for package: koffice
--> Processing Dependency: libxml2.so.2 for package: usermode-gtk
--> Processing Dependency: libdv4= 0.103-4.rhfc3.at for package: libdv
--> Processing Dependency: libxml2.so.2 for package: openoffice.org
--> Processing Dependency: libasound.so.2 for package: gstreamer-plugins
--> Processing Dependency: libxml2.so.2 for package: gtksourceview
--> Processing Dependency: libxml2.so.2 for package: xscreensaver
--> Processing Dependency: libxml2.so.2 for package: foomatic
--> Processing Dependency: libxslt.so.1 for package: dia
--> Processing Dependency: libxml2.so.2 for package: evolution-webcal
--> Processing Dependency: libdv.so.4 for package: mjpegtools
--> Processing Dependency: libdv.so.4 for package: pwlib
--> Processing Dependency: libasound.so.2 for package: arts
--> Processing Dependency: libxml2.so.2 for package: perl-XML-LibXML-Common
--> Processing Dependency: libxml2.so.2 for package: ImageMagick
--> Processing Dependency: libxml2.so.2 for package: transcode
--> Processing Dependency: libxml2.so.2 for package: kdelibs
--> Processing Dependency: libsndfile.so.1(libsndfile.so.1.0) for package: libsamplerate
--> Processing Dependency: libxml2.so.2 for package: librsvg2
--> Processing Dependency: libasound.so.2(ALSA_0.9) for package: gstreamer-plugins
--> Processing Dependency: libexslt.so.0 for package: libxslt
--> Processing Dependency: libasound.so.2(ALSA_0.9) for package: ogle
--> Processing Dependency: libxml2.so.2 for package: gedit
--> Processing Dependency: libxml2.so.2 for package: gaim
--> Processing Dependency: libasound.so.2 for package: mjpegtools
--> Processing Dependency: /usr/bin/pyzor for package: spamassassin
--> Processing Dependency: libasound.so.2 for package: bonobo
--> Processing Dependency: libxml2.so.2 for package: evolution-data-server
--> Processing Dependency: libxslt.so.1 for package: libgda
--> Processing Dependency: libasound.so.2 for package: gtkhtml
--> Processing Dependency: atrpms-perl-module-helper for package: spamassassin
--> Processing Dependency: libdv.so.4 for package: mplayer
--> Processing Dependency: libxml2.so.2 for package: gpdf
--> Processing Dependency: libxml2.so.2 for package: dia
--> Processing Dependency: libdv.so.4 for package: libquicktime
--> Processing Dependency: libxml2.so.2 for package: gnome-volume-manager
--> Processing Dependency: libasound.so.2 for package: gnomemeeting
--> Processing Dependency: libxml2.so.2 for package: tvtime
--> Processing Dependency: libOggFLAC1= 1.1.1 for package: flac
--> Processing Dependency: /etc/yum.conf for package: yum
--> Processing Dependency: libxml2.so.2 for package: gconf-editor
--> Processing Dependency: libxml2.so.2 for package: libgnomedb
--> Processing Dependency: libdv.so.4 for package: dvgrab
--> Processing Dependency: libxml2.so.2 for package: gnome-pilot
--> Processing Dependency: libxml2.so.2 for package: gnopernicus
--> Processing Dependency: libasound.so.2(ALSA_0.9) for package: kdelibs
--> Processing Dependency: libxml2.so.2 for package: devhelp
--> Processing Dependency: libxml2.so.2 for package: libbonoboui-devel
--> Processing Dependency: libxml2.so.2 for package: planner
--> Processing Dependency: libxml2.so.2 for package: vcdimager
--> Processing Dependency: libasound.so.2(ALSA_0.9) for package: kdemultimedia
--> Processing Dependency: libxml2.so.2 for package: libxml2-devel
--> Processing Dependency: opensp for package: docbook-utils
--> Processing Dependency: libasound.so.2(ALSA_0.9.0rc4) for package: alsa-utils-->
--> Processing Dependency: libasound.so.2 for package: SDL
--> Processing Dependency: libxslt.so.1 for package: planner
--> Processing Dependency: libxslt.so.1 for package: libgnomedb
--> Processing Dependency: libsndfile.so.1 for package: libfishsound
--> Processing Dependency: libFLAC++4= 1.1.1 for package: flac
--> Processing Dependency: libasound.so.2(ALSA_0.9.0rc4) for package: audacity
--> Processing Dependency: libsndfile.so.1(libsndfile.so.1.0) for package: libfishsound
--> Processing Dependency: libsndfile.so.1 for package: audacity
--> Processing Dependency: libxml2.so.2 for package: libxslt
--> Processing Dependency: libxml2.so.2 for package: gnome-python2
--> Processing Dependency: libsndfile.so.1(libsndfile.so.1.0) for package: libsndfile
--> Processing Dependency: libxml2.so.2 for package: kdenetwork
--> Processing Dependency: libxml2.so.2 for package: balsa
--> Processing Dependency: libosp.so.4 for package: openjade
--> Processing Dependency: libasound.so.2 for package: audacity
--> Processing Dependency: libOggFLAC++0= 1.1.1 for package: flac
--> Processing Dependency: libexslt.so.0 for package: planner
--> Processing Dependency: libxml2.so.2 for package: gnome-applets
--> Processing Dependency: libxml2.so.2 for package: GConf2
--> Processing Dependency: libxml2.so.2 for package: kdewebdev
--> Processing Dependency: libxml2.so.2 for package: nautilus-media
--> Processing Dependency: libasound.so.2(ALSA_0.9.0rc4) for package: gstreamer-plugins
--> Processing Dependency: libasound.so.2 for package: libglade
--> Processing Dependency: libxml2.so.2 for package: libgda
--> Processing Dependency: libxvidcore.so.4 for package: ffmpeg
--> Processing Dependency: libxml2.so.2 for package: gtkhtml3
--> Processing Dependency: libxml2.so.2 for package: libgnomeprintui22
--> Processing Dependency: libxml2.so.2 for package: xffm
--> Processing Dependency: libxml2.so.2 for package: gtk-gnutella
--> Processing Dependency: atrpms-perl-module-helper for package: perl-HTML-Parser
--> Processing Dependency: libxml2.so.2 for package: xmlsec1
--> Processing Dependency: libasound.so.2 for package: k3b
--> Processing Dependency: libasound.so.2 for package: Gtk-Perl
--> Processing Dependency: libasound.so.2(ALSA_0.9.0rc4) for package: ogle
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package libxslt1.i386 0:1.1.12-2_7.rhfc3.at set to be installed
---> Package libsndfile1.i386 0:1.0.11-6.rhfc3.at set to be installed
---> Downloading header for SDL_sound to pack into transaction set.
SDL_sound-1.0.1-1.rhfc3.n 100% |=========================| 8.4 kB 00:00
---> Package SDL_sound.i386 0:1.0.1-1.rhfc3.nr set to be installed
---> Downloading header for atrpms-package-config to pack into transaction set.
atrpms-package-config-87- 100% |=========================| 5.0 kB 00:00
---> Package atrpms-package-config.i386 0:87-1.rhfc3.at set to be installed
---> Package libxml2_2.i386 0:2.6.16-3_15.rhfc3.at set to be installed
---> Package nvidia-graphics4496-libs.i386 1:1.0_4496-61.rhfc3.at set to be installed
---> Package atrpms.noarch 0:61-1.at set to be installed
---> Package libasound2.i386 0:1.0.7-17.rhfc3.at set to be installed
---> Package opensp.i386 0:1.5-0_6.1.rhfc3.at set to be installed
---> Package libdv4.i386 0:0.103-4.rhfc3.at set to be installed
---> Package pyzor.noarch 0:0.4.0-2.rhfc3.at set to be installed
---> Package libOggFLAC1.i386 0:1.1.1-6.rhfc3.at set to be installed
---> Package DCC.i386 0:1.2.58-8.rhfc3.at set to be installed
---> Package xvidcore.i386 0:1.0.2-2.1.fc3.rf set to be updated
---> Package libFLAC6.i386 0:1.1.1-6.rhfc3.at set to be installed
---> Package lirc.i386 0:0.6.6-4.1.fc3.rf set to be installed
---> Package apt.i386 0:0.5.15cnc6-3.1.fc3.rf set to be updated
---> Package perl-DBI.i386 0:1.40-5 set to be installed
---> Package gnet2.i386 0:2.0.5-1.1.fc3.rf set to be installed
---> Package perl-IO-Socket-SSL.noarch 0:0.95-1.rhfc3.at set to be installed
---> Package perl-XML-XPath.noarch 0:1.13-1.1.fc3.rf set to be installed
---> Package elfutils-devel.i386 0:0.96-1 set to be installed
---> Package razor-agents.i386 0:2.61-7.rhfc3.at set to be installed
---> Package libxvidcore4.i386 0:1.0.2-6.rhfc3.at set to be installed
---> Package libFLAC++4.i386 0:1.1.1-6.rhfc3.at set to be installed
warning: package opensp = 1.5-0_6.1.rhfc3.at was already added, replacing with opensp <= 1.5.1-0_8.rhfc3.at
---> Package opensp.i386 0:1.5.1-0_8.rhfc3.at set to be installed
---> Package libOggFLAC++0.i386 0:1.1.1-6.rhfc3.at set to be installed
--> Running transaction check
--> Processing Dependency: elfutils-libelf-devel= 0.96-1 for package: elfutils-devel
--> Processing Dependency: libFLAC++.so.2 for package: k3b
--> Processing Dependency: libosp.so.3 for package: libofx
--> Processing Dependency: libFLAC.so.4 for package: gstreamer-plugins
--> Processing Dependency: libFLAC.so.4 for package: k3b
--> Processing Dependency: perl(Net::SSLeay)>= 1.08 for package: perl-IO-Socket-SSL
--> Processing Dependency: libFLAC.so.4 for package: vorbis-tools
--> Processing Dependency: libsmpeg-0.4.so.0 for package: SDL_sound
--> Processing Dependency: libosp4= 1.5.1 for package: opensp
--> Processing Dependency: libphysfs-1.0.so.0 for package: SDL_sound
--> Processing Dependency: libFLAC.so.4 for package: kdemultimedia
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package opensp.i386 0:1.5-0_6.1.rhfc3.at set to be installed
---> Package elfutils-libelf-devel.i386 0:0.96-1 set to be installed
---> Package perl-Net-SSLeay.i386 0:1.25-1.1.fc3.rf set to be installed
---> Downloading header for smpeg to pack into transaction set.
smpeg-0.4.4-9_2.rhfc3.at. 100% |=========================| 4.6 kB 00:00
---> Package smpeg.i386 0:0.4.4-9_2.rhfc3.at set to be installed
---> Package libosp4.i386 0:1.5.1-0_8.rhfc3.at set to be installed
---> Downloading header for physfs to pack into transaction set.
physfs-1.0.0-1.rhfc3.nr.i 100% |=========================| 2.8 kB 00:00
---> Package physfs.i386 0:1.0.0-1.rhfc3.nr set to be installed
--> Running transaction check
--> Processing Dependency: libFLAC.so.4 for package: gstreamer-plugins
--> Processing Dependency: libFLAC.so.4 for package: kdemultimedia
--> Processing Dependency: libFLAC.so.4 for package: k3b
--> Processing Dependency: libFLAC.so.4 for package: vorbis-tools
--> Processing Dependency: libFLAC++.so.2 for package: k3b
--> Finished Dependency Resolution
Error: Missing Dependency: libFLAC++.so.2 is needed by package k3b
Error: Missing Dependency: libasound.so.2(ALSA_0.9.0rc4) is needed by package pwlib
Error: Missing Dependency: libxml2.so.2 is needed by package libxklavier
Error: Missing Dependency: libxml2.so.2 is needed by package gnome-kerberos
Error: Missing Dependency: libxml2.so.2 is needed by package libsoup
Error: Missing Dependency: libasound.so.2 is needed by package kdeaddons
Error: Missing Dependency: libxml2.so.2 is needed by package rhn-applet
Error: Missing Dependency: libxslt.so.1 is needed by package abiword
Error: Missing Dependency: libasound.so.2 is needed by package mplayer
Error: Missing Dependency: libxml2.so.2 is needed by package libgnomeprint22
Error: Missing Dependency: libxml2.so.2 is needed by package eog
Error: Missing Dependency: libxml2.so.2 is needed by package libwpd
Error: Missing Dependency: libxml2.so.2 is needed by package gnome-utils
Error: Missing Dependency: libxml2.so.2 is needed by package gnome-bluetooth
Errcontrol-center
Error: Missing Dependency: libasound.so.2 is needed by package kdenetwork
Error: Missing Dependency: libasound.so.2 is needed by package koffice
Error: Missing Dependency: libasound.so.2 is needed by package gdk-pixbuf-gnome
Error: Missing Dependency: libasound.so.2(ALSA_0.9) is needed by package pwlib
Error: Missing Dependency: libasound.so.2 is needed by package SDL_image
Error: Missing Dependency: libasound.so.2 is needed by package libgnomeprint15
Error: Missing Dependency: libasound.so.2 is needed by package gnome-print
Error: Missing Dependency: libasound.so.2 is needed by package control-center
Error: Missing Dependency: libasound.so.2 is needed by package kdepim
Error: Missing Dependency: libasound.so.2(ALSA_0.9.0rc8) is needed by package alsa-lib
Error: Missing Dependency: libdv.so.4 is needed by package transcode
Error: Missing Dependency: libFLAC.so.4 is needed by package kdemultimedia
Error: Missing Dependency: libasound.so.2(ALSA_0.9.5) is needed by package alsa-lib
Error: Missing Dependency: libFLAC.so.4 is needed by package vorbis-tools
Error: Missing Dependency: libFLAC.so.4 is needed by package gstreamer-plugins
Error: Missing Dependency: libFLAC.so.4 is needed by package k3b
[root@localhost ravin]#

how do i fix it?

Thanks,
Ravin
 
Old 11-21-2004, 07:02 PM   #2
zajelo3
Member
 
Registered: Mar 2004
Location: Central Florida
Distribution: Gentoo & Fedora
Posts: 153

Rep: Reputation: 30
It seems that your using more than one repository at a time, which pretty much is a no-no. Here's a link to explain what I mean: http://openskills.info/view/boxdetai...1&boxtype=path . Sometimes I still run into the missing dependenc problem only using one repo, then I have to search out the individual rpms for each missing dependency and install the rpms.
 
Old 11-22-2004, 08:21 PM   #3
canyon289
Member
 
Registered: Sep 2004
Posts: 125

Original Poster
Rep: Reputation: 15
since im stupid how can i fix this
the website is over my head
 
Old 11-23-2004, 01:03 AM   #4
zajelo3
Member
 
Registered: Mar 2004
Location: Central Florida
Distribution: Gentoo & Fedora
Posts: 153

Rep: Reputation: 30
My best advice is to read up on yum and repositories. If you keep using more than one repository at a time you will keep having problems. Here's a good example, this is my apt/sources.list file:

# Package repository URLs
#
# Planet CCRMA for Fedora Core 1

# Main site, CCRMA, California, USA

rpm http://ccrma.stanford.edu/planetccrma/apt fedora/2/i386 core updates
rpm http://ccrma.stanford.edu/planetccrma/apt fedora/2/i386 planetccrma
rpm http://ccrma.stanford.edu/planetccrma/apt fedora/2/i386 planetcore
#rpm http://www-ccrma.stanford.edu/planetccrma/apt fedora/2/i386 planetedge
#rpm-src http://www-ccrma.stanford.edu/planetccrma/apt fedora/2/i386 planetccrma

# Mirrors: IRCAM, Paris, France
#
# rpm http://freesoftware.ircam.fr/mirrors/planetccrma/apt fedora/2/i386 core updates
# rpm http://freesoftware.ircam.fr/mirrors/planetccrma/apt fedora/2/i386 planetccrma
# rpm http://freesoftware.ircam.fr/mirrors/planetccrma/apt fedora/2/i386 planetcore
#
# rpm-src http://freesoftware.ircam.fr/mirrors/planetccrma/apt fedora/2/i386 planetccrma

#rpm http://apt.atrpms.net fedora/2/en/i386 at-stable
#rpm http://apt.atrpms.net fedora/2/en/i386 at-testing
#rpm http://apt.atrpms.net fedora/2/en/i386 at-bleeding

#rpm http://ayo.freshrpms.net fedora/linux/2/i386 core updates freshrpms
#rpm http://ayo.freshrpms.net fedora/linux/2/i386 tupdates
#rpm http://ayo.freshrpms.net fedora/linux/2/i386 extras alternatives
#rpm-src http://ayo.freshrpms.net fedora/linux/2/i386 core updates freshrpms
#rpm-src http://ayo.freshrpms.net fedora/linux/2/i386 tupdates
#rpm-src http://ayo.freshrpms.net fedora/linux/2/i386 extras alternatives

The top 3 lines that start with "rpm" are my main repositories that apt-get uses when I want to update my system with the latest packages. All the other lines have a "#" sign in front of them (they are commented out) so apt-get knows not to use them. However, not every repository will have all the packages I want, so when I want to install a package that my main repository doesn't have I have to uncomment that repository (remove the # sign) and then comment out (add the # sign) in front of my main repository. Apt-get and Yum are similar in that they use repositories, but I don't know yum other than the fact that I've read it works similar to apt-get. As far as the missing dependency problem it sounds like something got broken along the way. What I do when apt-get finds a missing dependency is to go and locate each missing dependency and install it by hand. This line is a good example:

Error: Missing Dependency: libasound.so.2 is needed by package mplayer

You are missing libasound.so.2 so you need to go get that rpm and install it. I found a page that has libasound.so.2 here: http://rpmfind.net/linux/RPM/fedora/...a-2.i386.html. The package is alsa-lib but it contains the libasound.so.2 you need. Well actually it doesn't because if you look closely that rpm is for Fedora Core 2 so you would need to find one for Fedora Core 3 and install it. The reason I think something is broken is because your system should already have libasound.so.2 with no problems. The breakage might have been caused from using multiple repositories or it might just be a bug in Fedora Core 3 since it's so new, but I would bet it's from using multiple repositories.

Anyhow, your not stupid your just new to Linux. Give Linux a few more months and then everything will fall together for you. In the mean time go to the bookstore or library and get a book on Fedora Core 3 and read it, that's the best way to learn. I haven't switched to FC3 yet, I'm letting them work some of the bugs out of it first. I went through the whole newbie thing when the 2.4 kernel came out and I've learned not to be so anxious to jump to the newest, coolest thing because it's probably going to be a pain to use at first. Same thing goes for the 2.6 kernel, its got some bugs now but by 2.6.15 it will be great to use. By the way, I find packages on the internet by typing the name of the package and then typing "rpmfind" in google (libasound.so.2 rpmfind).

P.S That link to the libasound.so.2 rpm doesn't work, but by now you should know how to find the right rpm.

Last edited by zajelo3; 11-23-2004 at 01:05 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
dependency problem black_man Debian 3 12-04-2005 07:55 PM
how to solve failed dependency when dependency exists dwcramer Linux - Newbie 2 08-24-2004 09:03 PM
rpm dependency problem horence Linux - Software 1 02-24-2004 12:20 PM
dependency problem - need help please lpriyamb Linux - Software 9 10-09-2003 03:45 AM
Dependency problem. glenn69 Linux - Newbie 1 09-01-2003 11:11 PM


All times are GMT -5. The time now is 01:15 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration