LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 04-29-2004, 12:17 AM   #1
mardanian
Member
 
Registered: Mar 2004
Distribution: Fedora
Posts: 254

Rep: Reputation: 30
dependency error kde


I dowloaded all the listed KDE 3.2.2 *.rpm from http://sunsite.rediris.es/mirror/kde...t/Fedora/i386/

However when I tries to install it at one go
rpm -Uvh *.rpm

I get these dependencies

libartsmodulescommon.so.0 is needed by kdeaddons-3.2.2-0.1
libartsmoduleseffects.so.0 is needed by kdeaddons-3.2.2-0.1
libartsmodulesmixers.so.0 is needed by kdeaddons-3.2.2-0.1
libartsmodulessynth.so.0 is needed by kdeaddons-3.2.2-0.1
libnoatun.so.1 is needed by kdeaddons-3.2.2-0.1
libnoatuncontrols.so.1 is needed by kdeaddons-3.2.2-0.1
libnoatuntags.so.1 is needed by kdeaddons-3.2.2-0.1
qt >= 1:3.3.1 is needed by kdeartwork-3.2.2-0.1
kdeedu = 3.2.2-0.1 is needed by kdeedu-devel-3.2.2-0.1
kdegraphics = 7:3.2.2-0.1 is needed by kdegraphics-devel-3.2.2-0.1
qt >= 1:3.3.1 is needed by kdelibs-3.2.2-0.1
qt-devel >= 1:3.3.1 is needed by kdelibs-devel-3.2.2-0.1
kdemultimedia = 6:3.2.2-0.1 is needed by kdemultimedia-devel-3.2.2-0.1
libkdeinit_ksirc.so is needed by kdenetwork-3.2.2-0.1
libnetsnmp.so.5 is needed by kdeutils-3.2.2-0.1
qt-designer >= 1:3.3.1 is needed by kdevelop-3.0.3-0.1
/usr/lib/qt-3.3 is needed by redhat-artwork-0.93-1
kdenetwork = 7:3.1.4-1 is needed by (installed)
kdenetwork-devel-3.1.4-1

ok i will upgrade my QT, but I am receiving dep errors like.
" libartsmoduleseffects.so.0 is needed by kdeaddons-3.2.2-0.1"

For which i duno what to install
AND
also
"kdeedu = 3.2.2-0.1 is needed by kdeedu-devel-3.2.2-0.1"

for each I readly dowloaded kdeedu , dededu-devel from the same repository, still giving me dep error

anyhelp me in this regards will be greatly appriciated
 
Old 06-17-2004, 06:12 PM   #2
sinoue
LQ Newbie
 
Registered: Aug 2003
Location: Faroe Islands
Distribution: Fedore Core, Ubuntu
Posts: 4

Rep: Reputation: 0
I had that libnetsnmp.so.5 dep error too. I tried googling for it and found that it is included in the net-snmp package. I then used synaptic to install the package as synaptic takes care of all dependencies when installing a package. After that I got the installation started :-)

Try googling the files which are missing.

Hope this helps
 
Old 06-17-2004, 10:09 PM   #3
foo_bar_foo
Senior Member
 
Registered: Jun 2004
Posts: 2,553

Rep: Reputation: 51
you have to do
arts
kdelibs
kdebase
first and in that order
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Failed Dependency: KDE 3.2.3 Upgrade MatthewASmith79 Linux - Newbie 1 06-13-2004 08:15 PM
dependency error laclac01 Linux - Software 0 05-18-2004 11:36 AM
KDE 3.2 dependency errors svarreby Fedora 3 02-16-2004 01:00 PM
Stupid Dependency Errors! KDE 3.2 gamehack Debian 1 01-27-2004 12:41 PM
DHCP Installation Error: Dependency Error rhonneil Linux - Networking 2 09-15-2003 05:56 AM


All times are GMT -5. The time now is 08:30 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration