LinuxQuestions.org
Did you know LQ has a Linux Hardware Compatibility List?
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices



Reply
 
Search this Thread
Old 12-07-2006, 11:15 AM   #1
gymnart
Member
 
Registered: Oct 2005
Distribution: SUSE 11.4
Posts: 331

Rep: Reputation: 30
dependency conflicts - avidemux2 & kino


I have a SuSE 10.0 system.
I want to be able to edit .mov files that I get from my Olympus camera. I have found rpm's of the 2 recommended video editing programs but when I tried to install them using, first Yast [got conflict messages] and then tried Kpackage, I got these conflict messages:

First from avidemux2 in Yast:
#### YaST2 conflicts list - generated 2006-12-07 10:25:09 ####

faac 1.25-0.pm.3 conflict
Required by:
libffmpeg0 requires faac >= 1.25-
Conflict Resolution:
( ) Do Not Set faac to Protected
( ) Remove All 4 Referring Packages
Delete k3b
Delete k3b-arts
Delete transcode
Delete libffmpeg0
( ) Ignore Conflict and Risk System Inconsistencies
faad2 2.5-0.pm.2 conflict
Required by:
libffmpeg0 requires faad2 >= 2.5-
faac requires faad2 >= 2.5-
faac requires faad2 >= 2.5-
Conflict Resolution:
( ) Do Not Set faad2 to Protected
( ) Remove All 6 Referring Packages
Delete k3b
Delete k3b-arts
Delete transcode
Do Not Install avidemux
Delete libffmpeg0
Delete faac
( ) Ignore Conflict and Risk System Inconsistencies
k3b-arts 0.12.15-3.pm.2 conflict
Broken Dependencies of Installed:
k3b-arts requires k3b = 0.12.15-
Unresolved Requirements:
k3b-arts requires k3b = 0.12.15-
Conflict Resolution:
( ) Do Not Set k3b-arts to Protected
( ) Ignore Conflict and Risk System Inconsistencies
k3b not available
Required by:
k3b-arts requires k3b = 0.12.15-
Conflict Resolution:
( ) Remove the Referring Package
Delete k3b-arts
( ) Ignore Conflict and Risk System Inconsistencies
libffmpeg0 0.4.9-8.pm.svn20061008 conflict
Conflict Resolution:
( ) Do Not Set libffmpeg0 to Protected
( ) Ignore Conflict and Risk System Inconsistencies
x264 0.0svn20061031-1 conflict
Required by:
avidemux requires libx264.so.54
libffmpeg0 requires libx264.so.54
Conflict Resolution:
( ) Do Not Set x264 to Protected
( ) Remove All 5 Referring Packages
Delete k3b
Delete k3b-arts
Delete transcode
Do Not Install avidemux
Delete libffmpeg0
( ) Ignore Conflict and Risk System Inconsistencies

#### YaST2 conflicts list END ###

and from avidemux2 in Kpackage:
error: Failed dependencies:
libjs.so.1 is needed by avidemux-2.3.0-2.pm.0
libx264.so.54 is needed by avidemux-2.3.0-2.pm.0

This one is from trying to install kino.
First one is from using Yast:
#### YaST2 conflicts list - generated 2006-12-07 10:28:06 ####

faac 1.25-0.pm.3 conflict
Required by:
libffmpeg0 requires faac >= 1.25-
Conflict Resolution:
( ) Do Not Set faac to Protected
( ) Remove All 5 Referring Packages
Delete k3b
Delete k3b-arts
Delete transcode
Do Not Install kino
Delete libffmpeg0
( ) Ignore Conflict and Risk System Inconsistencies
faad2 2.5-0.pm.2 conflict
Required by:
libffmpeg0 requires faad2 >= 2.5-
faac requires faad2 >= 2.5-
faac requires faad2 >= 2.5-
Conflict Resolution:
( ) Do Not Set faad2 to Protected
( ) Remove All 6 Referring Packages
Delete k3b
Delete k3b-arts
Delete transcode
Do Not Install kino
Delete faac
Delete libffmpeg0
( ) Ignore Conflict and Risk System Inconsistencies
k3b-arts 0.12.15-3.pm.2 conflict
Broken Dependencies of Installed:
k3b-arts requires k3b = 0.12.15-
Unresolved Requirements:
k3b-arts requires k3b = 0.12.15-
Conflict Resolution:
( ) Do Not Set k3b-arts to Protected
( ) Ignore Conflict and Risk System Inconsistencies
k3b not available
Required by:
k3b-arts requires k3b = 0.12.15-
Conflict Resolution:
( ) Remove the Referring Package
Delete k3b-arts
( ) Ignore Conflict and Risk System Inconsistencies
libffmpeg0 0.4.9-8.pm.svn20061008 conflict
Conflict Resolution:
( ) Do Not Set libffmpeg0 to Protected
( ) Ignore Conflict and Risk System Inconsistencies
x264 0.0svn20061031-1 conflict
Required by:
kino requires libx264.so.54
libffmpeg0 requires libx264.so.54
Conflict Resolution:
( ) Do Not Set x264 to Protected
( ) Remove All 5 Referring Packages
Delete k3b
Delete k3b-arts
Delete transcode
Do Not Install kino
Delete libffmpeg0
( ) Ignore Conflict and Risk System Inconsistencies

#### YaST2 conflicts list END ###

This one is from using Kpackage:
error: Failed dependencies:
libdts.so.0 is needed by kino-0.9.3-1.pm.2
libiec61883.so.0 is needed by kino-0.9.3-1.pm.2
libx264.so.54 is needed by kino-0.9.3-1.pm.2


I don't know what I should do. I want to be able to have k3b working so I can make CD's (it does not do DVD's for me though) and I'm wondering how do I update this stuff without interfering with k3b?
 
Old 12-09-2006, 12:07 AM   #2
tshrinivasan
Member
 
Registered: Jan 2006
Location: Chennai, Tamil nadu, India
Distribution: Debian Etch Testing
Posts: 117

Rep: Reputation: 16
http://packman.links2linux.org

search and get the required rpms for suse from here.

install them manually.

Login as root in a console.

#rpm -ivh <packname-version>.rpm

This will install the package.
If it requires any other package, download it and intall it first.

After completing all dependencies, you can install the kino and avidemux well.
 
Old 12-13-2006, 11:16 AM   #3
gymnart
Member
 
Registered: Oct 2005
Distribution: SUSE 11.4
Posts: 331

Original Poster
Rep: Reputation: 30
Thank you tshrinivasan.
I had been under the wrong impression that I had those libraries but after thinking about what you said, I went to http://rpm.pbone.net/ and used their "check requires" feature and it told me that I did not have them.
After doing as you said, the programs are installed. Thanks again!
 
  


Reply

Tags
conflict, kino, packages, rpm


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
yum install kino - Missing Dependency: libavutil.so schlough Linux - Software 5 01-13-2006 10:07 PM
Kino & coriander camcorder master Linux - Software 4 01-04-2006 10:00 AM
How does CVS conflicts work & howto fix? rylan76 Linux - Software 3 02-10-2005 02:59 AM
Getting a laptop: touchpad locking & bios conflicts & other possible laptop problems? mandrakemikael Linux - Laptop and Netbook 2 12-09-2004 08:15 AM
whenever i try to install something using YAST there are dependency conflicts Dr K Linux - Newbie 3 02-29-2004 03:21 PM


All times are GMT -5. The time now is 06:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration