LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   dependency conflicts - avidemux2 & kino (http://www.linuxquestions.org/questions/linux-software-2/dependency-conflicts-avidemux2-and-kino-508222/)

gymnart 12-07-2006 11:15 AM

dependency conflicts - avidemux2 & kino
 
I have a SuSE 10.0 system.
I want to be able to edit .mov files that I get from my Olympus camera. I have found rpm's of the 2 recommended video editing programs but when I tried to install them using, first Yast [got conflict messages] and then tried Kpackage, I got these conflict messages:

First from avidemux2 in Yast:
#### YaST2 conflicts list - generated 2006-12-07 10:25:09 ####

faac 1.25-0.pm.3 conflict
Required by:
libffmpeg0 requires faac >= 1.25-
Conflict Resolution:
( ) Do Not Set faac to Protected
( ) Remove All 4 Referring Packages
Delete k3b
Delete k3b-arts
Delete transcode
Delete libffmpeg0
( ) Ignore Conflict and Risk System Inconsistencies
faad2 2.5-0.pm.2 conflict
Required by:
libffmpeg0 requires faad2 >= 2.5-
faac requires faad2 >= 2.5-
faac requires faad2 >= 2.5-
Conflict Resolution:
( ) Do Not Set faad2 to Protected
( ) Remove All 6 Referring Packages
Delete k3b
Delete k3b-arts
Delete transcode
Do Not Install avidemux
Delete libffmpeg0
Delete faac
( ) Ignore Conflict and Risk System Inconsistencies
k3b-arts 0.12.15-3.pm.2 conflict
Broken Dependencies of Installed:
k3b-arts requires k3b = 0.12.15-
Unresolved Requirements:
k3b-arts requires k3b = 0.12.15-
Conflict Resolution:
( ) Do Not Set k3b-arts to Protected
( ) Ignore Conflict and Risk System Inconsistencies
k3b not available
Required by:
k3b-arts requires k3b = 0.12.15-
Conflict Resolution:
( ) Remove the Referring Package
Delete k3b-arts
( ) Ignore Conflict and Risk System Inconsistencies
libffmpeg0 0.4.9-8.pm.svn20061008 conflict
Conflict Resolution:
( ) Do Not Set libffmpeg0 to Protected
( ) Ignore Conflict and Risk System Inconsistencies
x264 0.0svn20061031-1 conflict
Required by:
avidemux requires libx264.so.54
libffmpeg0 requires libx264.so.54
Conflict Resolution:
( ) Do Not Set x264 to Protected
( ) Remove All 5 Referring Packages
Delete k3b
Delete k3b-arts
Delete transcode
Do Not Install avidemux
Delete libffmpeg0
( ) Ignore Conflict and Risk System Inconsistencies

#### YaST2 conflicts list END ###

and from avidemux2 in Kpackage:
error: Failed dependencies:
libjs.so.1 is needed by avidemux-2.3.0-2.pm.0
libx264.so.54 is needed by avidemux-2.3.0-2.pm.0

This one is from trying to install kino.
First one is from using Yast:
#### YaST2 conflicts list - generated 2006-12-07 10:28:06 ####

faac 1.25-0.pm.3 conflict
Required by:
libffmpeg0 requires faac >= 1.25-
Conflict Resolution:
( ) Do Not Set faac to Protected
( ) Remove All 5 Referring Packages
Delete k3b
Delete k3b-arts
Delete transcode
Do Not Install kino
Delete libffmpeg0
( ) Ignore Conflict and Risk System Inconsistencies
faad2 2.5-0.pm.2 conflict
Required by:
libffmpeg0 requires faad2 >= 2.5-
faac requires faad2 >= 2.5-
faac requires faad2 >= 2.5-
Conflict Resolution:
( ) Do Not Set faad2 to Protected
( ) Remove All 6 Referring Packages
Delete k3b
Delete k3b-arts
Delete transcode
Do Not Install kino
Delete faac
Delete libffmpeg0
( ) Ignore Conflict and Risk System Inconsistencies
k3b-arts 0.12.15-3.pm.2 conflict
Broken Dependencies of Installed:
k3b-arts requires k3b = 0.12.15-
Unresolved Requirements:
k3b-arts requires k3b = 0.12.15-
Conflict Resolution:
( ) Do Not Set k3b-arts to Protected
( ) Ignore Conflict and Risk System Inconsistencies
k3b not available
Required by:
k3b-arts requires k3b = 0.12.15-
Conflict Resolution:
( ) Remove the Referring Package
Delete k3b-arts
( ) Ignore Conflict and Risk System Inconsistencies
libffmpeg0 0.4.9-8.pm.svn20061008 conflict
Conflict Resolution:
( ) Do Not Set libffmpeg0 to Protected
( ) Ignore Conflict and Risk System Inconsistencies
x264 0.0svn20061031-1 conflict
Required by:
kino requires libx264.so.54
libffmpeg0 requires libx264.so.54
Conflict Resolution:
( ) Do Not Set x264 to Protected
( ) Remove All 5 Referring Packages
Delete k3b
Delete k3b-arts
Delete transcode
Do Not Install kino
Delete libffmpeg0
( ) Ignore Conflict and Risk System Inconsistencies

#### YaST2 conflicts list END ###

This one is from using Kpackage:
error: Failed dependencies:
libdts.so.0 is needed by kino-0.9.3-1.pm.2
libiec61883.so.0 is needed by kino-0.9.3-1.pm.2
libx264.so.54 is needed by kino-0.9.3-1.pm.2


I don't know what I should do. I want to be able to have k3b working so I can make CD's (it does not do DVD's for me though) and I'm wondering how do I update this stuff without interfering with k3b?

tshrinivasan 12-09-2006 12:07 AM

http://packman.links2linux.org

search and get the required rpms for suse from here.

install them manually.

Login as root in a console.

#rpm -ivh <packname-version>.rpm

This will install the package.
If it requires any other package, download it and intall it first.

After completing all dependencies, you can install the kino and avidemux well.

gymnart 12-13-2006 11:16 AM

Thank you tshrinivasan.
I had been under the wrong impression that I had those libraries but after thinking about what you said, I went to http://rpm.pbone.net/ and used their "check requires" feature and it told me that I did not have them.
After doing as you said, the programs are installed. Thanks again!


All times are GMT -5. The time now is 08:53 AM.