LinuxQuestions.org
View the Most Wanted LQ Wiki articles.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
LinkBack Search this Thread
Old 01-08-2011, 09:36 AM   #1
prabhatsoni
Member
 
Registered: Oct 2004
Location: India
Distribution: FC 12
Posts: 233

Rep: Reputation: 30
Default creation time user home directory permissions.


Hello folks,
When I am creating a user (say sandy) on my FC14 system, I find that the default permissions for her home directory (/home/sandy) are 700.
Can I somehow set up my system so that these permissions are 711 in place of 700.


Thanks,

Prabhat Soni
 
Old 01-08-2011, 09:40 AM   #2
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,566

Rep: Reputation: 510Reputation: 510Reputation: 510Reputation: 510Reputation: 510Reputation: 510
What's your umask set to (`umask` command)? You can change it to 0066 to do this (unless the permissions are in a user creation script) (`umask 0066`), though keep in mind this will make the default permissions on files 600.

http://en.wikipedia.org/wiki/Umask
 
Old 01-08-2011, 09:46 AM   #3
prabhatsoni
Member
 
Registered: Oct 2004
Location: India
Distribution: FC 12
Posts: 233

Original Poster
Rep: Reputation: 30
The umask is for creation of file after the user accounts are created. (perhaps ). And what is more each user can have a different value for umask.

I feel the permissions for the user home directory reflects some system-wide setting ?

Incidently for my account the umask is set to 0002.

Am I wrong in above ? It seems I am a bit confused.

Last edited by prabhatsoni; 01-08-2011 at 10:00 AM.
 
Old 01-08-2011, 10:32 AM   #4
prabhatsoni
Member
 
Registered: Oct 2004
Location: India
Distribution: FC 12
Posts: 233

Original Poster
Rep: Reputation: 30
OK folks,
It seems that the default setting are there in the /etc/login.defs. I changed the umask value in this file to 066.
However I find that this change has effect when I am creating user directly by giving command "useradd" in the terminal. But if I create the user through "System->Administration->Users and Groups", there is still the same permissions. I even restarted the computer. Since this graphical tool uses system-config-users, I tried to check its configuration files, but alas, no use.

Strange !

How can we make system-config-users fall in line ?

Any help.

Last edited by prabhatsoni; 01-08-2011 at 10:43 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Changing default user creation BEBigBear Linux - Desktop 3 06-24-2007 03:39 PM
first /home/user directory: permissions bug! rino.caldelli Ubuntu 11 04-21-2007 12:37 AM
default permissions for home directory gerghk Slackware 2 11-02-2006 01:01 AM
get creation time of hidden directory allelopath Linux - Software 2 12-30-2005 11:56 AM
permissions of my /home/"user" directory error darkleaf Linux - Software 10 09-26-2004 02:08 AM


All times are GMT -5. The time now is 11:32 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration