LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Software
User Name
Password
Linux - Software This forum is for Software issues.
Having a problem installing a new program? Want to know which application is best for the job? Post your question in this forum.

Notices

Reply
 
Search this Thread
Old 12-19-2002, 04:12 PM   #1
XavierP
Moderator
 
Registered: Nov 2002
Location: Kent, England
Distribution: Lubuntu
Posts: 19,176
Blog Entries: 4

Rep: Reputation: 430Reputation: 430Reputation: 430Reputation: 430Reputation: 430
Default Browser in Ximian Evolution


I use Mozilla 1.1 as my browser and Ximian Evolution 1.0.8 as my mail client. Whenever I hit a url in an email, the mail client opens Galeon as the internet browser. I have looked through Evolution's settings, but can't find where to change it. I am running Mandrake 9.

Can anyone tell me how to change the default browser? I guess that there is a file I need to amend, I just don't know where to find it and what to type.

Thanks in anticipation.
 
Old 12-19-2002, 10:57 PM   #2
ubien
Member
 
Registered: Oct 2002
Distribution: RH 8.0 and fluxbox
Posts: 122

Rep: Reputation: 15
Good question! <--also wants to know the answer.
 
Old 12-20-2002, 12:36 AM   #3
Meatwad
Member
 
Registered: Dec 2002
Distribution: Debian, Libranet, Red Hat
Posts: 43

Rep: Reputation: 15
The answers I have received is that you must open your control center in Gnome and specify your preferred applications and make sure web browser is set to Mozilla.

But that didn't work for me. But maybe it will for you guys.
 
Old 03-03-2003, 02:33 PM   #4
lsiden
LQ Newbie
 
Registered: Mar 2003
Location: Ann Arbor, MI
Distribution: Gentoo
Posts: 5

Rep: Reputation: 0
Please reply if you found a solution to this.
 
Old 03-03-2003, 04:04 PM   #5
onurb
Member
 
Registered: Dec 2002
Posts: 263

Rep: Reputation: 30
This may not be the way you want it, but I use galeon as default, in the prefrerences for galeon there is an entry for the preferred mail handler, for me it is evolution.
Now, perhaps mozilla has the same entry where you can specify the mail handler, it might be that once this is set, it would work in both directions.
 
Old 03-03-2003, 04:52 PM   #6
Meatwad
Member
 
Registered: Dec 2002
Distribution: Debian, Libranet, Red Hat
Posts: 43

Rep: Reputation: 15
The only thing I can think of is to put Mozilla ahead of galeon in your /etc/mailcap or ~/.mailcap file for the text/html handler.
 
Old 03-03-2003, 05:24 PM   #7
lsiden
LQ Newbie
 
Registered: Mar 2003
Location: Ann Arbor, MI
Distribution: Gentoo
Posts: 5

Rep: Reputation: 0
Edit [URL Handlers] in ~/.gnome/Gnome.

[URL Handlers]
;default-show=/usr/local/mozilla/mozilla --newwin "%s"
default-show=/opt/opera/bin/opera "%s"
 
Old 04-18-2003, 11:37 AM   #8
volrath
LQ Newbie
 
Registered: Apr 2003
Posts: 1

Rep: Reputation: 0
File types and programs

Go to gnome control center, and under advanced there is a button labeled file types and programs. Go there, and find the section Documents, and go to World Wide Web. Under that there should be a section labeled html page. Edit it and select Mozilla as default action.
This is under Mandrake 9.1, so it may be labeled different.


-Volrath
 
Old 04-19-2003, 08:44 PM   #9
daveharding25
LQ Newbie
 
Registered: Apr 2003
Posts: 1

Rep: Reputation: 0
Rename Galeon

I couldn't get gnome to change from Galeon to Mozilla using the UI tools so i simply renamed the Galeon executible and created a symolic link to Mozilla. You can do this many ways - I used the command line but if your not familar with bash here are some steps you can follow (at your own risk)

open the shell (default gnome-terminal)
type: su (for "SuperUser Mode"
enter your ROOT password

type: cd /usr/bin (this is to get to where the galeon executable is stored)
type: mv galeon galeon1 (this renames galeon with the name galeon1)
type: ln mozilla -s galeon (this creates a link to mozilla wheneve the computer tries to start galeon)

I use Mandrake 9.0 your system may be different. Note: If you installed from mozilla.org your current mozzila binary is most likely in a different directory (usr/local/mozilla by default) you just need to change that last command to ln /usr/local/mozilla/mozilla -s /usr/bin/galeon (change directories as neccessary).

Email me if you have and questions, I just stumpled on this board looking for an anwser myself.

-Dave
 
Old 07-05-2003, 04:02 PM   #10
hughbiquitous
LQ Newbie
 
Registered: Jul 2003
Distribution: RedHat 9
Posts: 1

Rep: Reputation: 0
Use the GNOME configuration utility.

/usr/bin/gnome-default-applications-properties

Piece of cake.
 
Old 07-24-2003, 07:35 PM   #11
roryg
LQ Newbie
 
Registered: May 2003
Distribution: Mandrake 9.1
Posts: 4

Rep: Reputation: 0
The answer is a combination of Lsiden's & hughbiquitous' posts. editting .gnome/Gnome changes the URL handler for all GTK1 prgrammes (as evolution is up to & including mdk 9.1). /usr/bin/gnome-default-applications-properties alters the behaviour of Gnome2 native programmes.

Man it took some stuffing around to figure this out.
 
Old 08-03-2003, 03:02 AM   #12
Krypt0n
LQ Newbie
 
Registered: Aug 2003
Location: Brisbane, Australia
Distribution: Mandrake 9.1
Posts: 2

Rep: Reputation: 0
Excellent! That worked perfectly for me.

I had to change the default TO galeon, so I did the /usr/bin/gnome-default-applications-properties trick, and also edited ~/.gnome/Gnome and changed the line to "default-show=galeon "%""

Cheers,
David
 
Old 08-13-2003, 10:17 AM   #13
rfoard
LQ Newbie
 
Registered: Aug 2003
Posts: 1

Rep: Reputation: 0
Default Browser in Ximian Evolution

Also if you would like for the URL to popup in an already running instance of the browser, and in a tab, I use:

/usr/bin/gnome-default-applications-properties

And in the Web Browser tab enter

netscape -remote "openURL (%s, new-tab)"

I use netscape, but I am pretty sure this works with the other mozilla based browsers as well.
 
Old 08-13-2003, 10:42 AM   #14
gargamel237
Member
 
Registered: Aug 2003
Location: Los Angeles
Distribution: gentoo
Posts: 52

Rep: Reputation: 15
Under desktop preferences > advanced > prefered applications I checked custom browser and put "MozillaFirebird %s" and it worked like a dream.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Setting the default browser for Ximian Evolution mail client. sepulture Linux - Software 2 11-21-2005 10:03 PM
Changing default browser in Ximian Evolution 1.4 apache363 Linux - Software 5 05-12-2004 07:41 PM
default web browser in Ximian Evolution JDA Linux - Software 4 02-25-2004 01:52 PM
Ximian Evolution - Default character set KTN Linux - Software 1 08-29-2003 10:03 AM
evolution default browser killi Linux - Software 1 08-19-2003 02:35 PM


All times are GMT -5. The time now is 06:20 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration