LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Software (http://www.linuxquestions.org/questions/linux-software-2/)
-   -   Debian Wheezy no sound (http://www.linuxquestions.org/questions/linux-software-2/debian-wheezy-no-sound-917079/)

KGyST 12-04-2011 11:29 AM

Debian Wheezy no sound
 
Hi,
I've upgraded with dist-upgrade (and some other commands) a while ago, and I basically have a working system with loads of nasty bugs, many of them being related to user credentials (I can do as a root bot not as a normal user).
Nastiest bug is having no sound at all (also as root).

Symptoms:
-sound related kernel modules are loaded automatically, seem to work
-in alsamixer (ALSA 1.0.24) card (Intel HDA) is selectable, has sound gadgets, I can in/decrease channels etc
-PulseAudio GNOME applet sees no soundcard
-No sound at all.

Where to search for problems?

Thanks

on.sid 12-04-2011 12:46 PM

Hello KGyST,

your problems with user credentials seem to indicate a problem with your PulseAudio setup rather than a problem with ALSA. PulseAudio is a sound server, most probably supposed to work with an ALSA backend to actually play music.

So firstly, you should look if it is ALSA that fails (may happen) or PulseAudio that doesn't work (most likely, because you pointed out rather severe problems with credentials). Make sure the volume is up in alsamixer and nothing's muted, then bring up a terminal and try to play an audio file $FILENAME using ALSA with like mplayer:

Code:

mplayer -ao alsa:device=default $FILENAME
Does it work? If yes, you could try to fix pulseaudio as root with

Code:

dpkg-reconfigure pulseaudio
If not, try an additional
Code:

dpkg-reconfigure alsa-base
Or maybe the PulseAudio daemon is not running? Did you try a reboot? If
Code:

mplayer -ao pulse $FILENAME
DOES work, it might be GNOME's fault.

In ANY case, make sure your user account is a member of group 'audio':
Code:

as root: useradd -G audio $USERNAME
I do not use PulseAudio, but there may be a group (pulse?) for the PulseAudio daemon too.

Regards,
on.sid.

KGyST 12-04-2011 01:26 PM

Thanks,
I've done all You have described, but still no sound.

After reconfiguring PulseAudio, it warned that it is configured for per-user sections.

Both root and user were members group audio, and I added them to pulse and pulse-access.

Some additional infos: it can be important that default card in alsamixer is 'default', and I have to select the other card 'HDA-Intel' manually to edit stuff.
The only sound comes out of the computer is the beeping of misuse of the keyboard, but that can be a different kernel module.
The system was originally a lenny, upgraded to squeeze (following a detailed manual, with working sound) and then to wheezy (just following a detailless forum post).

Oh,
I've just found that user.log has some Pulseaudio stuff:

Dec 4 18:14:42 Debian pulseaudio[2773]: [null-sink] ratelimit.c: 21 events suppressed
Dec 4 18:14:42 Debian pulseaudio[2773]: [null-sink] asyncq.c: q overrun, queuing locally
Dec 4 19:47:41 Debian pulseaudio[15278]: [pulseaudio] shm.c: Failed to read /dev/shm/: Nincs ilyen fájl vagy könyvtár
Dec 4 20:04:13 Debian pulseaudio[15924]: [pulseaudio] pid.c: Stale PID file, overwriting.
Dec 4 20:04:13 Debian pulseaudio[15924]: [pulseaudio] shm.c: Failed to read /dev/shm/: Nincs ilyen fájl vagy könyvtár
Dec 4 20:04:15 Debian pulseaudio[15959]: [pulseaudio] pid.c: Daemon already running.

(Nincs ilyen fájl vagy könyvtár = No such file or directory, in Hungarian)

on.sid 12-04-2011 02:59 PM

@The 'default' device:
No, this is irrelevant. By default, ALSA defines as the 'default' device a dmix instance (which is a ALSA plugin allowing simultanous output from different software audio sources to a hardware device (your sound card), i.e. parallel playback) the backend of which is surely your Intel HDA.

Obviously, I am a Pure ALSA man, so I do not know off the bat how to configure PulseAudio sinks. But at least I can point you to some resources that might prove to be useful; I used most of that stuff to actually understand how ALSA works.

PulseAudio configuration + troubleshooting section + links:
https://wiki.archlinux.org/index.php/PulseAudio

How ALSA is to be configured:
http://www.alsa-project.org/main/index.php/Asoundrc

One guy made himself a setup with ALSA and PulseAudio, and documented it well (hope it is not outdated):
https://defectivecompass.wordpress.c...configuration/

Of course
/usr/share/doc/pulse*

And the man pages.

Sorry I can not give a real hand;
Yours
on.sid.

impert 12-04-2011 03:40 PM

http://wiki.debian.org/ALSA
Or you can follow the general approach in this Ubuntu thread, making the necessary changes for Debian,
http://ubuntuforums.org/showthread.php?t=205449

Note the bit about getting ALSA to use the right card.

KGyST 12-24-2011 01:45 AM

I've tried the PulseAudio manual, and at the GStreamer step the error appeared:

Code:

Debian:/home/samu/Letoltesek# gstreamer-properties

(gstreamer-properties:12314): Gtk-WARNING **: Unknown property: GtkDialog.has-separator

(gstreamer-properties:12314): Gtk-WARNING **: Unknown property: GtkDialog.has-separator
gstreamer-properties-Message: Skipping unavailable plugin 'artsdsink'
gstreamer-properties-Message: Skipping unavailable plugin 'esdsink'
gstreamer-properties-Message: Skipping unavailable plugin 'sunaudiosink'

(gstreamer-properties:12314): gstreamer-properties-WARNING **: gst_properties_gconf_get_string() error: Nem sikerült kapcsolatot teremteni a konfigurációs kiszolgálóval; az egyik lehetséges ok, hogy a D-Bus munkamenetbusz-démon hiányzik vagy rosszul van beállítva. További információ: http://projects.gnome.org/gconf/. (Részletek -  1: Nem sikerült kapcsolatot szerezni a munkamenethez: A kapcsolat le van zárva)
gstreamer-properties-Message: Skipping unavailable plugin 'glimagesink'
gstreamer-properties-Message: Skipping unavailable plugin 'sdlvideosink'

(gstreamer-properties:12314): gstreamer-properties-WARNING **: gst_properties_gconf_get_string() error: Nem sikerült kapcsolatot teremteni a konfigurációs kiszolgálóval; az egyik lehetséges ok, hogy a D-Bus munkamenetbusz-démon hiányzik vagy rosszul van beállítva. További információ: http://projects.gnome.org/gconf/. (Részletek -  1: Nem sikerült kapcsolatot szerezni a munkamenethez: A kapcsolat le van zárva)
gstreamer-properties-Message: Skipping unavailable plugin 'v4lmjpegsrc'
gstreamer-properties-Message: Skipping unavailable plugin 'qcamsrc'
gstreamer-properties-Message: Skipping unavailable plugin 'v4lsrc'

(gstreamer-properties:12314): gstreamer-properties-WARNING **: gst_properties_gconf_get_string() error: Nem sikerült kapcsolatot teremteni a konfigurációs kiszolgálóval; az egyik lehetséges ok, hogy a D-Bus munkamenetbusz-démon hiányzik vagy rosszul van beállítva. További információ: http://projects.gnome.org/gconf/. (Részletek -  1: Nem sikerült kapcsolatot szerezni a munkamenethez: A kapcsolat le van zárva)
gstreamer-properties-Message: Skipping unavailable plugin 'esdmon'
gstreamer-properties-Message: Skipping unavailable plugin 'sunaudiosrc'

(gstreamer-properties:12314): gstreamer-properties-WARNING **: gst_properties_gconf_get_string() error: Nem sikerült kapcsolatot teremteni a konfigurációs kiszolgálóval; az egyik lehetséges ok, hogy a D-Bus munkamenetbusz-démon hiányzik vagy rosszul van beállítva. További információ: http://projects.gnome.org/gconf/. (Részletek -  1: Nem sikerült kapcsolatot szerezni a munkamenethez: A kapcsolat le van zárva)
g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
Befejeződött

After googling the "Remote peer vanished" error, I tried su -lc 'gstreamer-properties', and the stuff ran, I could setup audio sink (ALSA with ALC268 analog), the sound card was detected and the test sound beeped. (Note: the Default remained silent, but sound card was selectable and after selecting it had sound)
The topic was this: http://www.fedoraforum.org/forum/sho...d.php?t=262965
Note that I've various errors exist on my system (Gedit does the same error), so this could be a root-privilege problem.
(But after that, I ran Opera with the same credentials, and on a YouTube video, there was no sound :-/ In general, this beep is the only sound now)

PS
Ah,
mplayer -ao alsa:device=hw=0.0 modulations.avi
has sound, somewhere it's not set the audio output to be (hw:0,0)
But I realized that sound volume wheel doesn't work.

impert 01-01-2012 08:04 AM

KGyST,
A week has passed, so you may have already found and fixed your problem.
By coincidence, sound on my Debian Squeeze installation suddenly died after an upgrade.
After a lot of hunting about, I fixed it using info in the following:
http://forums.debian.net/viewtopic.p...39116&start=45
http://gstreamer-devel.966125.n4.nabble.com/gstreamer-interaction-with-Gnome-td1677658.html
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=598314
From the first link:
Quote:

gnome provides to set the default audio sink through the gstreamer-properties (which was/is (?) usually located under System>>Preferences>>Multimedia but is not there in Squeeze. You can call it from the command line.

Code:

$ gstreamer-properties

Select your alsa as plugin and your [correct] sound card as device. This will change the gconf key "audiosink". According to the thread mentioned Rhythmbox/totem/... will ignore that setting and use "musicaudiosink" instead which is not set by gstreamer-properties.

To adjust that open gconf (applications>>System Tools>>Configuration Editor) and under
system>>gstreamer>>0.10>>default
copy the value from "audiosink" (which was adjusted by gstreamer-properties) to "musicaudiosink".
In my case, I could play music with rhythmbox as long as the test button in gstreamer-properties was in use. Changing the muicaudiosink value fixed it.

Hope this helps.

KGyST 03-04-2012 03:51 AM

The (partial) solution was not so difficult. The problem could originate from migrating from Squeezy to Wheezy, because then udevd wasn't (and now still isn't) set up correctly and cannot detect sound devices.

I edited /etc/pulse/default.pa and uncommented two rows:
Code:

load-module module-alsa-sink
load-module module-alsa-source device=hw:0,0

to say PulseAudio which undetected (by failing udevd) hardware device should it use. Works.


All times are GMT -5. The time now is 01:41 PM.